English Amiga Board


Go Back   English Amiga Board > Support > support.Other

 
 
Thread Tools
Old 20 October 2021, 12:37   #1
D94pam
Registered User

 
Join Date: Jan 2019
Location: Sweden
Posts: 5
HELP - Amiga 600 with non working keyboard

Hi,

I would really need some help troubleshooting an Amiga 600 where the keyboard stopped working (after being stored for a while).

The machine has been recapped some 2-3 years ago and back then the keyboard worked just fine.

What I have done is the following:
- Tested the keyboard in another 600 where it works fine (ribbon cable is in other words ok).
- Measured for continuity from all the traces leading up to the white keyboard connector.
- Reflowed the solder on the keyboard controller and connector in case of a micro crack.

The keyboard is completely dead. Caps lock does not even lit up when I press the button.

Thanks!!
D94pam is offline  
Old 20 October 2021, 15:11   #2
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,630
What is your A600 motherboard revision and what is your keyboard - has it got a blue or green membrane?

You can simulate the keys presses by shorting certain pins on the keyboard connector or on the keyboard MCU - I would test this to rule out the membrane, keyboard connector or keyboard MCU.
solarmon is offline  
Old 20 October 2021, 15:29   #3
D94pam
Registered User

 
Join Date: Jan 2019
Location: Sweden
Posts: 5
Yeah, that sounds like a good approach.
Motherboard is a Rev 1.5 and the membrane is green.
D94pam is offline  
Old 20 October 2021, 16:08   #4
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,630
OK, here's what I would do.

Use Amiga Test Kit for the keyboard test feature.

Then use the following resources to understand the keyboard matrix:

https://github.com/BleuLlama/AmigaSc...yb_Mitsumi.pdf

and translate that to the A600 schematics:

https://www.amigawiki.org/dnl/schematics/A600_R1.5.pdf

And use amigapcb.org to figure out where those signals are on the A600 motherboard:

https://www.amigapcb.org/

(although, this only has it for rev 2 A600, the pinouts for the keyboarfd connector and MCU should be the same).

For example, the Left Amiga key (LAMI) is in the PB6 trace in the keyboard matrix. This is active (i.e. pressed) when it is connected to ground. PB6 is connected to pin 14 on the keyboard connector (CN13) and pin 26 on the keyboard MCU (U13). Use amigapcb.org to locate where these pins are and you can short it to ground to simulate that key press. If the keyboard MCU is working then the Left Amiga key in the Amiga Test Kit keyboard test should be highlighted. Repeat this for other keys if you want, by most of the keys require for the 'X' and 'Y' signals to be shorted, as per the keyboard matrix.
solarmon is offline  
Old 21 October 2021, 13:20   #5
D94pam
Registered User

 
Join Date: Jan 2019
Location: Sweden
Posts: 5
Thank you very much for valuable information. The route to check functionality using the keyboard matrix I hadn't thought of. Brilliant!

Unfortunately everything is still dead. I tried a couple of different keypresses using this method.

But one thing that struck me when looking at the schematics (https://www.amigawiki.org/dnl/schematics/A600_R1.5.pdf) is the circuitry handling the power up reset. One of the caps there is an electrytic one and even though the machine has been recapped and the area looks at least ok (the problem area in this machine was caps located on the right side of the mainboard handling audio where pads/traces had been eaten up). But there might still be some issue here, so I will dig out my oscilloscope checking the signals are doing what they are supposed to here.

Maybe you have any other idea though that I can also look into? Or am I on the right track you think?

Thanks!!
D94pam is offline  
Old 21 October 2021, 13:28   #6
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,630
Just to be clear, maybe I misunderstood - is your A600 booting up at all? I.e. can it boot to the Kickstart screen and you can load Amiga Test Kit either via floppy disk or as an ADF using a Gotek?

Or is the A600 not booting up at all? If so, then that is a whole different issue and the focus shouldn't be about the keyboard!
solarmon is offline  
Old 22 October 2021, 08:39   #7
D94pam
Registered User

 
Join Date: Jan 2019
Location: Sweden
Posts: 5
Yes, sure, absolutely! Apart from a dead keyboard everything else works just fine. So no misunderstanding.
D94pam is offline  
Old 22 October 2021, 12:28   #8
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,630
If your A600 is booting and working apart from this keyboard issue, then that could suggest an issue with the keyboard MCU (U13) or an issue with the _KB_DATA and _KB_CLOCK signals/tracs going to the ODD CIA (U7).

Have you run health checks using Amiga Test Kit - especially a CIA test?
solarmon is offline  
Old 23 October 2021, 21:41   #9
D94pam
Registered User

 
Join Date: Jan 2019
Location: Sweden
Posts: 5
I did a health check using Hertell's DiagROM and now after your suggestion also Amiga Test Kit. All CIA tests are passing.

Interesting thing (using ATK) is that when doing the keyboard test a number of times (going in and out of the test) I managed to get some kind of signal (bouncy though with a bunch of zeroes being sent) one single time from the ~ key.

So it is very much leaning towards a faulty MCU or the signals from the ODD CIA. That will be my next deep dive. Just wanted to let you know my status.
D94pam is offline  
Old 02 November 2021, 14:40   #10
vk3heg
Registered User
vk3heg's Avatar
 
Join Date: Oct 2008
Location: Australia
Age: 52
Posts: 77
I had to replace the membrane in my A600. I tried a replacement flex one, and it only lasted six months,. Then came across the hard-keyboard-membrane. Ordered one, and it has been a delight.

https://www.sordan.ie/product/712/ne...0-green--blue/


Stephen
vk3heg is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiga 600 keyboard problem nikosidis support.Hardware 0 25 November 2020 21:21
Keyboard problems on Amiga 600 cbmeeks support.Hardware 7 16 January 2020 18:22
Amiga 600 keyboard problem Mekanikal support.Hardware 6 13 July 2018 01:38
Buy keyboard for Amiga 600 OldMan MarketPlace 0 14 August 2014 20:13
Wanted: Amiga 600 keyboard membrane (Blue) or full keyboard assembly RetromanIE MarketPlace 8 19 August 2012 15:48

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 07:40.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.09355 seconds with 13 queries