English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 26 September 2010, 20:38   #1
Zetr0
Ya' like it Retr0?
Zetr0's Avatar
 
Join Date: Jul 2005
Location: United Kingdom
Age: 46
Posts: 9,768
A1200 Rev 2B mouse madness

Hello there my fellow forum chummies =)

Recently I had an A1200 RevB with the classic mouse movement problem; whereby the mouse point jumps wildly about the screen - almost random in its movement.

A hit up on the schematics points out that Paula [U3] is tied directly to the mouse ports X and Y pots - I removed the original Paula chip [U3]and replaced it with a known working one - since I was at it I also replaced the C307 and C305.

I buzzed out the resistors and they are all reporting good values.

so you might be thinking... ooo job done.... well... no.... infact its the same as before..

I can only conclude that either some feed to the paula has gone bad, I could use and would really appreciate some advice =)
Zetr0 is offline  
Old 26 September 2010, 20:52   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 24,796
Denise/Lisa has mouse counters, not Paula (this myth never dies..) Pot lines are used by analog joystick/paddles.

Check/replace U34 first.
Toni Wilen is offline  
Old 26 September 2010, 22:33   #3
Zetr0
Ya' like it Retr0?
Zetr0's Avatar
 
Join Date: Jul 2005
Location: United Kingdom
Age: 46
Posts: 9,768
@Toni

my thanks - I shall give that a go in the morning =)
Zetr0 is offline  
Old 27 September 2010, 04:45   #4
8bitbubsy
Registered User

8bitbubsy's Avatar
 
Join Date: Sep 2009
Location: Norway
Posts: 1,536
Yes, replace U34 (it's labeled 74LS166A or just LS166A, it's located to the right by the floppy power connector), I've had problems with it earlier too. Also clean the pads under the SMD chip and take a good look near it for any damage or suspicious things!

http://www.datasheetcatalog.org/data...SN74LS166D.pdf

Last edited by 8bitbubsy; 27 September 2010 at 04:53.
8bitbubsy is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse wheel madness in Dopus (Classic Wb Lite v 24) emuola project.ClassicWB 9 26 September 2010 14:55
Which A1200 rev and which acc... Silver support.Hardware 18 15 May 2009 13:43
A1200 rev 1D.1 issue patrik support.Hardware 2 06 June 2007 23:36
A1200 REV 1.D1 versus A1200 REV 1.D4 eLowar support.Hardware 6 28 April 2004 16:57
amiga madness i just got an a1200 and need help Hammy New to Emulation or Amiga scene 2 16 May 2003 22:43

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:14.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.07008 seconds with 13 queries