English Amiga Board


Go Back   English Amiga Board > Coders > Coders. Language > Coders. Blitz Basic

 
 
Thread Tools
Old 25 October 2021, 18:57   #1
Nightshft
Registered User

Nightshft's Avatar
 
Join Date: Mar 2018
Location: Austria
Posts: 580
Amiblitz 3 and PtPlayer

Due to zooperdan posting "Playing a module from INCBIN in AmiBlitz 3.8" I fired up AB 3.8.0 and tried ptPlayer again, after a longer break.

PtPlayer is great, but I experience quite some bugs with it.

Especially one is severe and it makes using ptPlayer in Amiblitz quite impossible at the moment

- minor bug: when the vbr is moved you won't hear the module when playing.

- It now seems necessary to call mtInstall before calling mtInit. Which IIRC wasn't necessary in earlier versions of blitz.
Without mtInstall you won't get a crash or error, but you won't hear the module either.

- This is the most severe: compiling works fine once, but the whole machine crashes (guru 8000 0004 or 8000 000B) at the second compile run! I think this only happens when you call mtInstall. However commenting out mtInstall on the second compile run won't prevent the guru from happening.

Update: Seems to only happen when the Amiblitz debugger is disabled.


Has anybody experienced this, fixed this or an idea how to fix it?



PS:Machine is Winuae, A1200, Kick 3.1, 2+16MB ram. Amiblitz 3.8.0

IIRC I experienced similar problems when manually adding ptPlayer to Amiblitz 3.7.x too.
Nightshft is offline  
Old 01 November 2021, 20:55   #2
Zener
Registered User
Zener's Avatar
 
Join Date: Jan 2009
Location: Barcelona / Spain
Posts: 385
Quote:
Originally Posted by Nightshft View Post
Due to zooperdan posting "Playing a module from INCBIN in AmiBlitz 3.8" I fired up AB 3.8.0 and tried ptPlayer again, after a longer break.

PtPlayer is great, but I experience quite some bugs with it.

Especially one is severe and it makes using ptPlayer in Amiblitz quite impossible at the moment

- minor bug: when the vbr is moved you won't hear the module when playing.

- It now seems necessary to call mtInstall before calling mtInit. Which IIRC wasn't necessary in earlier versions of blitz.
Without mtInstall you won't get a crash or error, but you won't hear the module either.

- This is the most severe: compiling works fine once, but the whole machine crashes (guru 8000 0004 or 8000 000B) at the second compile run! I think this only happens when you call mtInstall. However commenting out mtInstall on the second compile run won't prevent the guru from happening.

Update: Seems to only happen when the Amiblitz debugger is disabled.


Has anybody experienced this, fixed this or an idea how to fix it?



PS:Machine is Winuae, A1200, Kick 3.1, 2+16MB ram. Amiblitz 3.8.0

IIRC I experienced similar problems when manually adding ptPlayer to Amiblitz 3.7.x too.
Not sure how to help you, have you tried calling mtRemove before the end of the program?
Zener is offline  
Old 10 November 2021, 23:25   #3
E-Penguin
Banana

E-Penguin's Avatar
 
Join Date: Jul 2016
Location: Darmstadt
Posts: 1,127
Quote:
Originally Posted by Nightshft View Post
- This is the most severe: compiling works fine once, but the whole machine crashes (guru 8000 0004 or 8000 000B) at the second compile run! I think this only happens when you call mtInstall. However commenting out mtInstall on the second compile run won't prevent the guru from happening.
.
I've had this happen in BB2 also, and seems to be related to the mtinstall. I just left that out.
E-Penguin is offline  
Old 13 November 2021, 13:21   #4
E-Penguin
Banana

E-Penguin's Avatar
 
Join Date: Jul 2016
Location: Darmstadt
Posts: 1,127
I updated the ptplayer library based on the suggestions in the thread here: https://eab.abime.net/showpost.php?p...80&postcount=9

It seems to have fixed it!
E-Penguin is offline  
Old 14 November 2021, 01:28   #5
Nightshft
Registered User

Nightshft's Avatar
 
Join Date: Mar 2018
Location: Austria
Posts: 580
I'm busy with real life/job currently. Nice work, thanks! Will take a look at it when there is time again.
Nightshft is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Release of AmiBlitz 3! Daedalus Coders. Blitz Basic 130 21 November 2021 19:10
Problem with ptplayer MacSpain support.Other 2 23 January 2020 20:52
Amiblitz 3 Retrofan Amiga scene 2 15 December 2016 23:55
AmiBlitz 3 AF2013 Coders. Blitz Basic 13 26 September 2013 01:27
AmiBlitz 3 slk486 support.Apps 2 16 May 2010 22:26

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
Page generated in 0.07197 seconds with 13 queries