English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 10 June 2021, 22:07   #1
Laine
Registered User

 
Join Date: Sep 2018
Location: Canada
Posts: 19
OS 3.2 Amiga 4000D IDE spliter AtapiMagic

HW: Amiga 4000D/3660 16megs fast Onboard, ZZ9000 Bios 1.8, 4 way splitter for an Amiga 4000D

Installed 3.2 on formatted CF card,
(installed the drivers for the ZZ9000/P06/roadshow and AExplorer to move files)

move CD0 from Storage\DOSDrivers to DevsOSDrivers

Downloaded AtapiMagic followed the instruction of editing startup-sequence and moving the atapimagic file to LIBS:modules
dir this edit to the start chaning the 46 to 47 like it says

If Exists C:LoadModule
C:Version exec.library version 47 >NIL:
If Warn
C:LoadModule LIBS:modules/AtapiMagic ROMUPDATE
Else
C:LoadModule LIBS:modules/AtapiMagic
EndIf
EndIf

rebooted and the amiga gurus, used WinUAE recover startup- sequence

So to make it work Change tooltype to from scsi.device to atapi.device
find an atapi.device place in devs:

edited the startup-sequence to leaving what was there and add

C:LoadModule LIBS:modules/AtapiMagic


what mine looks like


;Version exec.library version 47 >NIL:
;If Warn
LoadModule L:System-Startup ROMUPDATE
EndIf

C:LoadModule LIBS:modules/AtapiMagic

SetPatch >NIL:




reboot CD roms read fine, hope this helps someone
Laine is offline  
Old 10 June 2021, 22:16   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 6,399
atapi.device is part of IDEfix. It handles IDE splitters out of the box, it does not need AtapiMagic.
thomas is offline  
Old 10 June 2021, 22:38   #3
Laine
Registered User

 
Join Date: Sep 2018
Location: Canada
Posts: 19
Thank you Thomas,

I wasn't sure if the IDEFix was compatible with 3.2 so used what I read in the FAQ

I'll make an other install using IDEFix and see how that goes
Laine is offline  
Old 10 June 2021, 22:44   #4
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 6,399
You don't need IDEfix to run a CD drive. You can use atapi.device with 3.2's CD file system. IDEfix will undo the improvements introduced with 3.2.
thomas is offline  
Old 10 June 2021, 22:50   #5
Laine
Registered User

 
Join Date: Sep 2018
Location: Canada
Posts: 19
So using Thomas's advice I removed the 'C:LoadModule LIBS:modules/AtapiMagic'

just using the atapi.device from IDEfix (with the tooltype change of CD0)

it all works fine

Thanks again Thomas
Laine is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
AMIGA 4000D internal ide cf card size limit? oguzog support.Hardware 18 09 September 2021 21:29
Amiga 4000D and IDE videofx support.Hardware 5 03 July 2013 15:37
Amiga 4000d mal101 support.Hardware 10 21 May 2013 08:12
FS: Amiga 4000D (1 of 2) r.cade MarketPlace 2 21 August 2012 20:35
FOR SALE: Vidi RGB Video Colour Spliter - Video Digitiser LDR MarketPlace 0 02 March 2009 14:35

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:47.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.07326 seconds with 15 queries