English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 16 March 2009, 05:52   #1
watertonian
2 1200s in Wisconsin
watertonian's Avatar
 
Join Date: Mar 2008
Location: Wisconsin, USA
Age: 44
Posts: 115
Send a message via AIM to watertonian Send a message via Yahoo to watertonian
New Tower owner with OpenPCI probs.

Hello, I've been going blind all week trying to get this system up and running, and have been posting updates on the other 3 forums (aw.net, a.org, amigans). However, I'm having trouble with my Mediator in an A1200 tower that I recently purchased. (Had the 1200 since high school, just bought tower+mediator and some other stuff) The prob is, I have an SMS ethernet card, and MediatorNET won't see it at all. (Its a 100MBPS, but it should still recognize it as 10MBPS as fastethernet doesn't support it). I've also tried openpci.library, but it can never open that. Any suggestions?

pciinfo output:
Pci Device 1:
VendorID: $10b8
VendorName: Standard Microsystems Corporation
DeviceID: $5
DeviceName: LAN83C170QF/171 EPIC/XF 10/100 Mbps Fast Ethernet Ctrlr
ClassCode: $20000
RevisionID: $6
InterruptPin: 1
SubsystemVendorID: $10b8
SubsystemID: $a011
IOSpace0: $ed6000 - $ed60ff
MemSpace1: $80000000 - $80000fff
RomSpace: $80010000 - $8001ffff

Pci Device 2:
VendorID: $5333
VendorName: S3 Graphics Co., Ltd
DeviceID: $8a01
DeviceName: 86C375/86C385 ViRGE /DX & /GX
ClassCode: $30000
RevisionID: $1
InterruptPin: 2
SubsystemVendorID: $10b4
SubsystemID: $1717
MemSpace0: $84000000 - $87ffffff
RomSpace: $80020000 - $8002ffff

Pci Device 3:
VendorID: $1274
VendorName: Ensoniq
DeviceID: $5000
DeviceName: ES1373 AudioPCI
ClassCode: $40100
RevisionID: $0
InterruptPin: 3
SubsystemVendorID: $4942
SubsystemID: $4c4c
IOSpace0: $ed6400 - $ec643f

Pci Device 4:
VendorID: $105a
VendorName: Promise Technology
DeviceID: $4d33
DeviceName: PDC20246 FastTrak Ultra ATA RAID controller
ClassCode: $10400
RevisionID: $1
InterruptPin: 4
SubsystemVendorID: $0
SubsystemID: $0
IOSpace0: $ed6800 - $ed6807
IOSpace1: $ed6c00 - $ed6c03
IOSpace2: $ed7000 - $ed7007
IOSpace3: $ed7400 - $ed7403
IOSpace4: $ed7800 - $ed781f
RomSpace: $80030000 - $8003ffff

Last edited by watertonian; 16 March 2009 at 05:54. Reason: Setting post notification
watertonian is offline  
Old 16 March 2009, 09:03   #2
keropi
.
 
Join Date: Oct 2004
Location: Ioannina/Greece
Posts: 5,040
to save you lots of trouble: get a supported ethernet card (they are ultra-cheap nowdays so no worries) and don't bother at all with openPCI , it will never work as it should.
keropi is offline  
Old 16 March 2009, 09:42   #3
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 6,466
http://www.elbox.com/mediator_driver_guide.html

Neither MediatorNet nor FastEthernet list $10b8 as a recognised vendor, so there is no chance to get this NIC to work.


http://bvernoux.free.fr/DevPCI.php#drivers

OpenPCI has even less compatible cards, it only supports RTL8139 chips.


Quote:
Its a 100MBPS, but it should still recognize it as 10MBPS
That's complete nonsense. The driver searches the PCI bus for a known vendor/product combination and if it does not find such, it does not open. Unknown devices are left alone.

That pciinfo knows the name of the vendor does not mean that it is supported by any driver. There is a list of vendor and product names in a file somewhere (IIRC in the S directory). This file can be updated by downloading a new version. But updating the list of names does not magically make drivers support more devices.
thomas is offline  
Old 16 March 2009, 10:39   #4
cosmicfrog
The 1 who ribbits
cosmicfrog's Avatar
 
Join Date: Apr 2006
Location: leek, Staffs, UK
Age: 54
Posts: 3,556
Send a message via MSN to cosmicfrog
Quote:
Originally Posted by thomas View Post
But updating the list of names does not magically make drivers support more devices.
If only it was that simple
cosmicfrog is offline  
Old 16 March 2009, 16:16   #5
amigakit.com
Registered User

amigakit.com's Avatar
 
Join Date: Aug 2004
Location: www.amigakit.com
Posts: 1,943
The SANAII drivers (FastEthernet.device and MediatorNET.device) should be placed into the DEVS:Networks drawer (create it if you dont already have this drawer)

When entering the SANA II driver name into your TCP/IP stack, please note that it is case sensitive e.g. DEVS:Networks/FastEthernet.device and not fastethernet.device

Also ensure you have the ENVARC: settings to specify the speed the network card should go Half or Full Duplex or Auto Negotiation.

We stock a suitable Mediator card here with EasyNet software included:
http://amigakit.leamancomputing.com/...products_id=63
amigakit.com is offline  
Old 16 March 2009, 16:23   #6
DDNI
Targ Explorer

DDNI's Avatar
 
Join Date: Mar 2006
Location: Northern Ireland
Age: 47
Posts: 5,347
Send a message via ICQ to DDNI Send a message via MSN to DDNI
Is the included software, that which you sell for £9.78 on its own?
http://amigakit.leamancomputing.com/...roducts_id=586

If so, BARGAIN!!
DDNI is offline  
Old 16 March 2009, 16:39   #7
amigakit.com
Registered User

amigakit.com's Avatar
 
Join Date: Aug 2004
Location: www.amigakit.com
Posts: 1,943
Yes it has. We aim to please :-)
amigakit.com is offline  
Old 16 March 2009, 21:12   #8
watertonian
2 1200s in Wisconsin
watertonian's Avatar
 
Join Date: Mar 2008
Location: Wisconsin, USA
Age: 44
Posts: 115
Send a message via AIM to watertonian Send a message via Yahoo to watertonian
Smile

Thanx for the help, all! I looked at the vendor list on elbox's site, and the SMS cards are listed under 10mbps, however the chipset is all wrong... I'll have to get a supported one next paycheck.. Meanwhile, I do have the PCMCIA card that t works well, though I don't think the case will work without pinching wire a bit. Also wanted to mention, I got all this stuff from AmigaKit, and couldn't be happier with the customer service. I've bought from there before, and will do so again without hesitation if needed! (I've had a few bad experiences buying stuff online, never with AmigaKit though. They seem to go out of their way to make sure everything is OK, including sending me an e-mail to make sure I ordered the right equipment, seeing as I accidentally ordered the wrong power adapter, and fixed the prob!)
watertonian is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenPCI Radeon driver released Ratte News 16 18 August 2014 13:27
Rattes OpenPCI Radeon drivers JohnFante request.Other 1 17 May 2013 00:00
Help for a new Amiga owner using a CF please mancity support.Hardware 18 27 April 2012 18:29
AHI 6 error: can't open openpci.library keropi support.Apps 7 11 May 2009 17:32
G-Rex 1200, openPCI, and usb cards... keropi support.Hardware 8 16 November 2005 19:26

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:46.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.10048 seconds with 13 queries