English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 03 March 2007, 18:12   #1
andyc1864
 
Posts: n/a
WinUAE 1.4 crash on start

Hi,

I have just downloaded and installed version 1.4 on my Dell M90 laptop. After the install completed, the application loads, but when i close and then try to re-run it immediately crashes and creates a dmp file.

Has anyone had this problem, i can't get the GUI to load at all.

I have got the dump file available if someone wouldn't mind taking a look.

Many Thanks

Andy
 
Old 03 March 2007, 19:59   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
Email/attach winuaebootlog.txt and dump file, thanks.
Toni Wilen is offline  
Old 04 March 2007, 00:40   #3
andyc1864
 
Posts: n/a
Dump file and winuaebootlog.txt

Hi Toni,

Thanks for taking the time. I have uploaded both files, but had to add .txt extension to the dmp file as it would not let me post. Hope this is ok.

Thanks again.

Andy
Attached Files
File Type: txt winuaebootlog.txt (8.9 KB, 193 views)
File Type: txt winuae_1400_20070303_163738.dmp.txt (22.2 KB, 176 views)
 
Old 04 March 2007, 04:15   #4
Mnemesi
Registered User

Mnemesi's Avatar
 
Join Date: Nov 2005
Location: North America
Age: 53
Posts: 58
Ditto

I'm having similar response. Here is a zipped dump report and the boot log. Dropped back to 1.33 for now.
Attached Files
File Type: zip winuae_1400_20070303_220114.zip (7.2 KB, 158 views)
File Type: txt winuaebootlog.txt (12.9 KB, 189 views)
Mnemesi is offline  
Old 04 March 2007, 11:10   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
"Compatibility mode" serial port enumeration can overflow.. (seems I forgot something important) Only workaround is to disable serial ports until it stops crashing. (or disable Bluetooth temporarily, I guess)
Toni Wilen is offline  
Old 04 March 2007, 17:18   #6
bomfirit
 
Posts: n/a
yep

i have the same problem here on my notebook. WinUAE crashes on start.
 
Old 04 March 2007, 18:47   #7
andyc1864
 
Posts: n/a
Update with Serial

Hi,

I have no serial port on this laptop but it does have bluetooth. I have disbaled it from within the bios but unfortunately it made no difference, has anyone else had any luck?

Going to try 1.3.3 i think.

Toni - Thanks for the prompt feedback .

Andy
 
Old 04 March 2007, 19:58   #8
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
Quote:
Originally Posted by andyc1864
I have no serial port on this laptop but it does have bluetooth. I have disbaled it from within the bios but unfortunately it made no difference, has anyone else had any luck?
Do you have less than 8 serial ports in winuaebootlog.txt now? If yes, then there is another bug.. (dump shows the crash happening in P96 display mode sorting code but it may not have anything to do with the crash because serial bug will corrupt memory)

Could you try 1.4.0 betas? Which one is the last working (or first crashing) version?
Toni Wilen is offline  
Old 04 March 2007, 23:43   #9
thom87
 
Posts: n/a
Quote:
Originally Posted by Toni Wilen
Do you have less than 8 serial ports in winuaebootlog.txt now? If yes, then there is another bug.. (dump shows the crash happening in P96 display mode sorting code but it may not have anything to do with the crash because serial bug will corrupt memory)

Could you try 1.4.0 betas? Which one is the last working (or first crashing) version?
Hi All.

I have found crash problem with version 1.4 beta 6 (all before works fine).
I discover something perhaps usefull - version 1.4beta6+ is working if you delete config in registry but without picasso gfx card (modes are not avaliable in screen mode). After shutdown winuae and start again situation going same as before (winaue crash).
My computer is laptop with bluetooth as well.

Sorry for my english is not perfect yet.
Thom
Attached Files
File Type: zip winuae_1400_20070304_223216.zip (20.6 KB, 167 views)
File Type: zip WinUAEbootlog.zip (9.9 KB, 176 views)
 
Old 06 March 2007, 00:58   #10
Ian
Global Moderator

Ian's Avatar
 
Join Date: May 2001
Location: Derby, UK
Age: 44
Posts: 2,254
I have a problem too.

When I first install WinUAE everything works fine, the next time I start it as soon as I click on something that opens a file dialog box it crashes without warning or error message.

I'm using Windows XP 64

Beta 7 was the last version to work "properly".

Last edited by Ian; 06 March 2007 at 01:04.
Ian is offline  
Old 06 March 2007, 08:16   #11
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
Quote:
Originally Posted by Ian
I have a problem too.

When I first install WinUAE everything works fine, the next time I start it as soon as I click on something that opens a file dialog box it crashes without warning or error message.

I'm using Windows XP 64

Beta 7 was the last version to work "properly".
Probably caused by same bug (if you have more than 8 serial ports listed in winuaelog.txt) but could you also attach/email winuaelog.txt and dump file?

[I am currently ignoring other non-serious reports until this bug is confirmed fixed and update has been released]
Toni Wilen is offline  
Old 06 March 2007, 10:04   #12
Ian
Global Moderator

Ian's Avatar
 
Join Date: May 2001
Location: Derby, UK
Age: 44
Posts: 2,254
There is no crash dump created, but here are the logs.
Attached Files
File Type: txt winuaebootlog.txt (8.9 KB, 192 views)
File Type: txt winuaelog.txt (2.8 KB, 198 views)
Ian is offline  
Old 06 March 2007, 10:36   #13
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
Quote:
Originally Posted by Ian
There is no crash dump created, but here are the logs.
Something else than serial port bug here..

Dump may not be created if Windows error reporting is completely disabled.
Toni Wilen is offline  
Old 06 March 2007, 10:51   #14
Ian
Global Moderator

Ian's Avatar
 
Join Date: May 2001
Location: Derby, UK
Age: 44
Posts: 2,254
I just enabled it, but it still doesn't create a crash dump.

Nothing is added to dr watson32 either.

Anything (free) I can use to monitor WinUAE with?
Ian is offline  
Old 06 March 2007, 11:50   #15
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
Quote:
Originally Posted by Ian
I just enabled it, but it still doesn't create a crash dump.
Weird..

Quote:
Originally Posted by Ian
When I first install WinUAE everything works fine, the next time I start it as soon as I click on something that opens a file dialog box it crashes without warning or error message.
Every file dialog? (even hdf/directory harddisk dialog?)

Perhaps some buggy explorer shell extension?
Toni Wilen is offline  
Old 06 March 2007, 12:52   #16
Ian
Global Moderator

Ian's Avatar
 
Join Date: May 2001
Location: Derby, UK
Age: 44
Posts: 2,254
I have events in the log about Microsoft Groove (Part of Office Ultimate 2007) around the times I tested it this morning which does add something to the context menu when in a dialog box I think. There is no reason for Groove to be running as I have no idea what it's supposed to do and never use it.

I haven't tried every dialog box, just the ones for configurations and floppies.

I will do some more testing later.
Ian is offline  
Old 24 April 2007, 13:02   #17
toprak
 
Posts: n/a
Maybe something wrong with DirectInput?

Hi All Together,

I have got the same problems, like the others too (-> After the first successful start of WinUAE and closing it, the Application won't start for a second time!)...

As the others, I get two Message-boxes telling me, that it won't work

I looked inside the dump file (winuae_1410_20070424_022712.dmp), but sad to say, that I am a lamer , and I don't know how to "read" these kinds of "messages", so I let it very soon...

Then I tried some of the tips in this forum (disabled the COM-Ports and the Printer-Ports) just to see what happens, but there happend nothing

Even if I tried to start it again, nothing happens, even no new dump-files... So, I renamed the dump-file from *.dmp to *.dmp.old just to see, if now there is a new dump-file. And yes, there was a new dump-file. The both dump-files just differ a little...

After that, I read the winuaebootlog.txt file and now I saw something at the end of the file, I read before in the dump.file: The word "Tastatur" (german word for "keyboard") and something with "DirectInput"...

The whole last three lines:
DirectInput enumeration.. Keyboards..
GUID=6F1D2B61-0000D5A0-000011CF-BFC7444553540000:
'Tastatur' 'Tastatur' 00000413 [Keyboard]

I now tried to start (just for "fun") to see, what dxdiag (Ctrl-R -> dxdiag) reports me: And look, it crashed... The second time I started dxdiag, it said something like: ... the last time DirectInput was making problems! Should we just let it out... (sorry for my "english")...

Could it be, that there is something wrong with WinUAEs use of DirectInput?

Here my System:
- Asus P5WDG2 WS Pro
- Intel Core 2 2x 2400Ghz
- 4GB Ram
- ATI Radeon X1950 GT (512MB)
- WinXP SP#2
- DirectX_v9.0c Dezember 2006
- WinUAE 1.4.1.0

Before this system, I had this one (and the same problems
- Asus P4C800-E Deluxe
- Intel Pentium 4 3,2 GHz
- 2GB RAm
- Matrox Parhelia
- WinXP SP#2
- DirectX_v9.0c Dezember 2006
- WinUAE 1.4.0.0, 1.3.2.0, 1.3.1.0



Don't know if the things I wrote here help anyone, but I still hope it does

Greeting from Germany
Toprak
 
Old 24 April 2007, 13:08   #18
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
Quote:
I looked inside the dump file (winuae_1410_20070424_022712.dmp), but sad to say, that I am a lamer , and I don't know how to "read" these kinds of "messages", so I let it very soon...
It is useless without debugger and other stuff
Email or attach one dump, thanks.

Quote:
Originally Posted by toprak
The whole last three lines:
DirectInput enumeration.. Keyboards..
GUID=6F1D2B61-0000D5A0-000011CF-BFC7444553540000:
'Tastatur' 'Tastatur' 00000413 [Keyboard]
Try removing all non-critical USB devices and game controllers. Still crashing? (there is at least one known game controller driver that crashes during DirectInput enumeration...)
Toni Wilen is offline  
Old 25 April 2007, 00:58   #19
toprak
 
Posts: n/a
So again...

Hello Again,

Yesterday forgot to say, that there were no USB Devices installed in my PC-System, while I was testing it... And at the moment I am not using a Gamecontroller...

The Files are uploaded...

Greetings from Hammer-Iron-Beach/Germany
Toprak
Attached Files
File Type: txt winuae_1410_20070424_022712.dmp.txt (22.5 KB, 157 views)
File Type: txt winuaebootlog.txt (4.9 KB, 173 views)
 
Old 25 April 2007, 15:36   #20
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
It crashes inside directinput. Looks like your keyboard driver has issues.. DXDiag crashing confirms it is not WinUAE problem.


Keyboard manufacturer and model? Did you replace your keyboard when you updated your PC?
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE random crash BippyM support.WinUAE 7 19 March 2013 20:54
Winuae 2.0.1 crash Heula support.WinUAE 7 03 January 2010 10:43
another annoying winuae crash orko33 support.WinUAE 13 29 November 2008 20:19
another WinUAE 1.5.1 crash jharrison support.WinUAE 4 04 September 2008 16:53
WinUAE V0.9.2 crash with lzx ghost support.WinUAE 3 27 December 2004 14:05

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:46.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.18875 seconds with 14 queries