English Amiga Board


Go Back   English Amiga Board > Support > support.OtherUAE

 
 
Thread Tools
Old 27 January 2020, 09:50   #21
Etze
A3000-Fan

Etze's Avatar
 
Join Date: Sep 2008
Location: Germany
Posts: 231
Quote:
Originally Posted by digitalMedic View Post
This should help get Amiberry to run.

Thanks, but it didn't help. So I just reinstalled everything. Now it works after I figured that I had (at first start) to wait a few seconds after pressing "Start" in Amiberry.


Now even RTG works, even in 1920x1080. Though I have a rather small 10 inch 16:10-Display, so I'm using a much smaller resolution. Looks brilliant.






But one question left: How do I access a USB-Stick within DietPi? I'd like to use it as a backup-solution for (Amiga-)data from the sd-card but can't find it mounted. I think I remember that it worked out-of-the-box with Amibian on my RPi3.
Etze is offline  
Old 27 January 2020, 13:49   #22
midwan
Registered User

 
Join Date: Dec 2014
Location: Gothenburg
Posts: 93
Quote:
Originally Posted by fitzsteve View Post
Sorry for the slightly OT but how good is Amiga emulation on the Pi4? I don't mean for just running an ADF, I was thinking my Pi4 could be useful as a standalone small Amiga, target machine would something similar in performance to an Amiga with Vampire or am I dreaming?
Amiberry with JIT is several times faster than a Vampire in fact. You can test that by running a real-life test, e.g. try to render a scene in Lightwave.

On the RPI4, the speed is 2-3 times faster than the RPI3B+ at least - depends on the scenario. Most of the games/demos I've tested with run at full speed.

That being said, emulation is still software that needs to run on the underlying system, so there's some overhead and even with multi-threading (which Amiberry already uses), there can be things that will be slower than the "real" thing which does them in parallel and in hardware.

We don't have cycle-accurate emulation there yet, but from my experience it's actually very rarely needed. Most of the times you can get a good result with the proper configuration.

Regarding games, we have a unique feature in Amiberry that can match the WHDLoad game title to a list of best known configurations, and pick that automatically. This makes things really easy since you can launch a game with a single command/click, without having to fiddle around with configs, swapping disks, etc.
midwan is offline  
Old 27 January 2020, 23:07   #23
digitalMedic
Registered User

digitalMedic's Avatar
 
Join Date: Nov 2019
Location: Michigan/US
Posts: 60
Quote:
Originally Posted by Etze View Post
Thanks, but it didn't help. So I just reinstalled everything. Now it works after I figured that I had (at first start) to wait a few seconds after pressing "Start" in Amiberry.
There was a bug in DietPi that MichaIng fixed shortly after I posted that had to do with audio. When you reinstalled, you got the fixed version. DietPi had the required dependencies all along.


Quote:
But one question left: How do I access a USB-Stick within DietPi? I'd like to use it as a backup-solution for (Amiga-)data from the sd-card but can't find it mounted. I think I remember that it worked out-of-the-box with Amibian on my RPi3.
Mount the USB stick using the drive manager and then it will show up.

Last edited by digitalMedic; 31 January 2020 at 02:46.
digitalMedic is offline  
Old 28 January 2020, 09:19   #24
Etze
A3000-Fan

Etze's Avatar
 
Join Date: Sep 2008
Location: Germany
Posts: 231
Ok, so I have to manually mount it.

Thanks!
Etze is offline  
Old 26 January 2021, 18:49   #25
t3v6
Registered User

 
Join Date: Feb 2018
Location: Bremen, Germany
Posts: 10
I tried Dietpi with Amiberry on Pi400 the last two days, and I can´t make it work without sound stuttering and heavy CPU overload (is the on-screen UAE LED´s CPU the Pi´s or Amiga´s CPU value)?

Before on WinUAE, I installed a AGS2 Game launcher package via HSTWB (using WINUAE, copying then the 16GB HDF to Pi400).

Setup is straight-forward, Amiga boots.
But the MODs in the AGS player are heavily distorted.
CPU LED with MODs off won´t go under 50-60%,
and up to over 90% with MODs on.

The "state of the art" MOD in AGS menu is barely recognizable.
When I start the demo itself via AGS, it (strangely) runs better! Only a little stuttering on heavy image processing bits (UAE CPU LED up to 160%).

What´s that? On WinUAE the HDF runs completely fine, but it´ s a heavy gaming laptop.

Is 16GB HDF simply too big?
I don´t believe Pi400 UAE can´t manage a 68020 OS-friendly program, especially when the WHDLoad started from the AGS launcher runs so much better!
WHDLoad games seem flawless, but UAE-CPU-LED constantly at 100%

Any ideas before I try a standalone Amiberry Distro?! Or a version based on Raspbian Desktop?
t3v6 is offline  
Old 26 January 2021, 19:23   #26
t3v6
Registered User

 
Join Date: Feb 2018
Location: Bremen, Germany
Posts: 10
I know a little more now.
The Amiga MOD-player "easymod", used by AGSlauncher, is killing the emulation speed.
It seems UAE can´t keep up even on a simple CLI prompt when easymod is launched.

Can someone re-confirm this by playing any MOD with easymod
via Dietpi Amiberry with OS3.1.4?

I can make easymod available if needed for testing, issue happens with any MOD file.
I will also try booting the Amiga without any startup-sequence. Barenaked test
t3v6 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiberry 3.0 very slow endre1952 support.OtherUAE 6 26 November 2019 19:29
Amiberry Expectations MartinW support.OtherUAE 11 05 March 2019 13:30
Custom controls on Amiberry?? Akira support.OtherUAE 29 09 November 2018 18:49
Amiberry on S905 boxes Mark36 support.OtherUAE 0 01 October 2018 08:43
Autofire in uae4arm/Amiberry cakeisaliegamin support.OtherUAE 5 02 June 2018 13:16

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:52.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.07614 seconds with 14 queries