English Amiga Board


Go Back   English Amiga Board > Support > support.OtherUAE

 
 
Thread Tools
Old 23 January 2020, 23:17   #1
digitalMedic
Registered User

digitalMedic's Avatar
 
Join Date: Nov 2019
Location: Michigan/US
Posts: 60
DietPi and Amiberry problem

Hi all,

I installed the latest version of DietPi for RaspberryPi 4B and the latest version of Amiberry from within DietPi. Everything starts great and I can create the Amiga config, but when I click Start, I get a black screen. There is something in the center of the screen because the mouse cursor disappears under it when moving the mouse around. I cannot quit the emulator or anything and have to pull the plug. Any ideas what may be wrong?

Rick
digitalMedic is offline  
Old 24 January 2020, 13:59   #2
midwan
Registered User

 
Join Date: Dec 2014
Location: Gothenburg
Posts: 93
Can you get back to the emulator GUI, using F12?
Have you tried reporting this to the DietPi team on Github? They are usually very helpful and quick to respond.
midwan is offline  
Old 24 January 2020, 16:18   #3
Etze
A3000-Fan

Etze's Avatar
 
Join Date: Sep 2008
Location: Germany
Posts: 228
I have the same problem and was about to ask for advice...
Etze is offline  
Old 24 January 2020, 18:39   #4
midwan
Registered User

 
Join Date: Dec 2014
Location: Gothenburg
Posts: 93
Just a thought: Have you checked the /boot/config.txt file?
Is the fkms driver enabled there?

Can you post the contents of the file here (you can exclude the commented out sections, but keep everything else)?
midwan is offline  
Old 24 January 2020, 21:48   #5
digitalMedic
Registered User

digitalMedic's Avatar
 
Join Date: Nov 2019
Location: Michigan/US
Posts: 60
I cannot get the config screen back with F12. I also have not mentioned anything to Amiberry on GitHub as I wanted to make sure it was not something I was missing. It appears that the fkms driver is enabled at the bottom of the config file.
Attached Files
File Type: txt config.txt (2.8 KB, 190 views)
digitalMedic is offline  
Old 25 January 2020, 00:37   #6
midwan
Registered User

 
Join Date: Dec 2014
Location: Gothenburg
Posts: 93
The config file seems correct to me.
If you can get to the GUI once but not after that, something's going wrong when the emulator starts and opens up the emulation screen. On a RPI the default option is to use Dispmanx to do that, which is why it's important to have the "fkms" driver enabled.

I'd recommend you open an issue on the DietPi Github page (https://github.com/MichaIng/DietPi) - not Amiberry's, as this seems to be specific to DietPi at the moment. I can't recreate this problem in any other distro.
midwan is offline  
Old 25 January 2020, 02:05   #7
digitalMedic
Registered User

digitalMedic's Avatar
 
Join Date: Nov 2019
Location: Michigan/US
Posts: 60
I posted the question on the dietpi forum. I did manage to get Amiberry to start the emulator with Raspbian, but it will not load the install disk fully. It stops loading the disk after it opens a WB screen, but there are no icons or anything and the emulator just sits there. It is not frozen as the CPU indicator fluctuates and I reopen the control panel. This is with WB 3.1.4. I am going to try 3.1 next. It is kind of frustrating. Have not had this much problem with Amiberry in the past (under Amibian).
digitalMedic is offline  
Old 25 January 2020, 03:32   #8
digitalMedic
Registered User

digitalMedic's Avatar
 
Join Date: Nov 2019
Location: Michigan/US
Posts: 60
Found the issue using Amiberry with DietPi. I needed to still install the required dependencies manually. Submitted a bug report on DietPi github.

Thanks for all the help.
digitalMedic is offline  
Old 25 January 2020, 09:10   #9
Etze
A3000-Fan

Etze's Avatar
 
Join Date: Sep 2008
Location: Germany
Posts: 228
Quote:
Originally Posted by digitalMedic View Post
install the required dependencies manually.
which dependencies?
Etze is offline  
Old 25 January 2020, 11:40   #10
fitzsteve
Professional slacker!
fitzsteve's Avatar
 
Join Date: Jul 2009
Location: Kent, UK
Age: 41
Posts: 6,602
Send a message via MSN to fitzsteve
Sorry for the slightly OT but how good is Amiga emulation on the Pi4? I don't mean for just running an ADF, I was thinking my Pi4 could be useful as a standalone small Amiga, target machine would something similar in performance to an Amiga with Vampire or am I dreaming?
fitzsteve is offline  
Old 25 January 2020, 11:50   #11
manossg
Registered User

 
Join Date: Nov 2019
Location: Greece
Posts: 733
Quote:
Originally Posted by fitzsteve View Post
Sorry for the slightly OT but how good is Amiga emulation on the Pi4? I don't mean for just running an ADF, I was thinking my Pi4 could be useful as a standalone small Amiga, target machine would something similar in performance to an Amiga with Vampire or am I dreaming?
RPi4 with Amiberry is pretty sweet and runs very fast! I don't know how it compares to the Vampire, though.
manossg is offline  
Old 25 January 2020, 11:57   #12
fitzsteve
Professional slacker!
fitzsteve's Avatar
 
Join Date: Jul 2009
Location: Kent, UK
Age: 41
Posts: 6,602
Send a message via MSN to fitzsteve
Quote:
Originally Posted by manossg View Post
RPi4 with Amiberry is pretty sweet and runs very fast! I don't know how it compares to the Vampire, though.
Cheers I'll look it up, if it can do RTG screens that would be good. I have a Pi4 here that's gathering dust due to no proper retroipie and be nice to replace my aging Netbook which was my mini Amiga
fitzsteve is offline  
Old 25 January 2020, 12:05   #13
manossg
Registered User

 
Join Date: Nov 2019
Location: Greece
Posts: 733
Quote:
Originally Posted by fitzsteve View Post
Cheers I'll look it up, if it can do RTG screens that would be good. I have a Pi4 here that's gathering dust due to no proper retroipie and be nice to replace my aging Netbook which was my mini Amiga
I haven't managed to use RTG in Amiberry, because I run an old version of RetroPie still and I cannot, for some reason, upgrade to the latest Amiberry version. But I have FSUAE as well and it runs RTG perfectly!

Do give your RPi4 a shot, it's truly Amiga bliss, especially with Amiberry.
manossg is offline  
Old 25 January 2020, 12:57   #14
Etze
A3000-Fan

Etze's Avatar
 
Join Date: Sep 2008
Location: Germany
Posts: 228
On my RPi3 with Amibian and Amiberry, RTG worked like a charm. So I guess it should work on a RPi4 too.
Etze is offline  
Old 25 January 2020, 15:02   #15
dreadnought
Registered User
 
Join Date: Dec 2019
Location: Ur, Atlantis
Posts: 849
Quote:
Originally Posted by manossg View Post
RPi4 with Amiberry is pretty sweet and runs very fast!
Does it have the cycle-accurate option though? This is the major problem with (otherwise awesome) Amiberry on Pi.
dreadnought is offline  
Old 25 January 2020, 16:25   #16
manossg
Registered User

 
Join Date: Nov 2019
Location: Greece
Posts: 733
Quote:
Originally Posted by dreadnought View Post
Does it have the cycle-accurate option though? This is the major problem with (otherwise awesome) Amiberry on Pi.
It doesn't, but I run an old version of Amiberry (v.2.25). I am not sure if this has been rectified in later versions, but I don't feel like I am missing anything here, since Amiberry runs way better than anything else I have tried.

My gripes would have to be having to hold down the mouse button in the GUI to select anything and not supporting RTG and CD images. But I think these problems have been solved by now.
manossg is offline  
Old 25 January 2020, 16:46   #17
dreadnought
Registered User
 
Join Date: Dec 2019
Location: Ur, Atlantis
Posts: 849
Quote:
Originally Posted by manossg View Post
It doesn't, but I run an old version of Amiberry (v.2.25). I am not sure if this has been rectified in later versions, but I don't feel like I am missing anything here, since Amiberry runs way better than anything else I have tried.
It does not affect all games, but it changes the speed in others and makes them unplayable (eg Barbarian or It Came From The Desert - perhaps more).

I know RPi 3 was simply not powerful enough to make this feature possible so I'm curious about RPi 4.
dreadnought is offline  
Old 25 January 2020, 17:31   #18
endre1952
Registered User
 
Join Date: Oct 2009
Location: Hungary
Posts: 94
How fast is Amiberry on the RPi 4 compared to the RPi 3? A few games such as Risky Woods don't run at full speed on the RPi 3. AGA games are also rather slow. I'm only interested in putting the RPi 4 in a portable shell such as the GamePI43. Unfortunately, the RPi 4 has a different kind of HDMI socket.
endre1952 is offline  
Old 25 January 2020, 19:05   #19
digitalMedic
Registered User

digitalMedic's Avatar
 
Join Date: Nov 2019
Location: Michigan/US
Posts: 60
Quote:
Originally Posted by Etze View Post
which dependencies?
I just entered the command to install all of them. It installed the ones that were missing:

sudo apt-get install libsdl2-2.0-0 libsdl2-ttf-2.0-0 libsdl2-image-2.0-0 libxml2 libflac8 libmpg123-0 libmpeg2-4


This should help get Amiberry to run.
digitalMedic is offline  
Old 27 January 2020, 09:27   #20
Solskogen
Registered User
 
Join Date: Nov 2016
Location: Skien / Norway
Posts: 46
Quote:
Originally Posted by digitalMedic View Post
I posted the question on the dietpi forum. I did manage to get Amiberry to start the emulator with Raspbian, but it will not load the install disk fully. It stops loading the disk after it opens a WB screen, but there are no icons or anything and the emulator just sits there. It is not frozen as the CPU indicator fluctuates and I reopen the control panel. This is with WB 3.1.4. I am going to try 3.1 next. It is kind of frustrating. Have not had this much problem with Amiberry in the past (under Amibian).

Disable JIT.

JIT on 32bit (like DietPi and Raspbian is) don't work with 3.1.4. If you rather use a 64bit distro like Manjaro ARM, it will work.
Solskogen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiberry 3.0 very slow endre1952 support.OtherUAE 6 26 November 2019 19:29
Amiberry Expectations MartinW support.OtherUAE 11 05 March 2019 13:30
Custom controls on Amiberry?? Akira support.OtherUAE 29 09 November 2018 18:49
Amiberry on S905 boxes Mark36 support.OtherUAE 0 01 October 2018 08:43
Autofire in uae4arm/Amiberry cakeisaliegamin support.OtherUAE 5 02 June 2018 13:16

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:57.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.12446 seconds with 16 queries