English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 24 April 2020, 11:36   #21
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 6,243
Quote:
Originally Posted by Weaselrama View Post
Thomas - I have a bug report to file regarding the CPU usage on WBDock

There is a 50 Hz pulse sent to each dock icon in case it needs to animate. This could cause a basic load on the CPU. But it should be far from "running hot".
thomas is offline  
Old 24 April 2020, 15:04   #22
Weaselrama
Registered Voter

Weaselrama's Avatar
 
Join Date: Oct 2019
Location: Neunkirchen aP, DE
Age: 59
Posts: 573
Quote:
Originally Posted by thomas View Post
There is a 50 Hz pulse sent to each dock icon in case it needs to animate. This could cause a basic load on the CPU. But it should be far from "running hot".
Ok, here are the behaviors I'm seeing. NOTE: This is 3.9 running in FS-UAE. I understand that running an emulator may not mirror the app running on actualy hardware.

1. When I run it from startup-sequence the screen flashes an odd orange to white. Same if I create a link and run it from WBStartup.

2. With use the animations get slower. Opening windows cause icons to populate more slowly with time and AmigaAMP performance starts to degrade. When I take it out of WBStartup and run AmiDock, these behaviors disappear.

I run a 2019 13" Macbook Pro which already runs pretty warm because it's an ultra-thin and has poor cooling - y'know, because it's a feature, not a bug. Running FS-UAE the average CPU temp is about 93-95C. With WBDock the average is about 97-100C with fans running full. Temperature really isn't an issue and I can switch on a small desk fan which greatly improves the situation.

I'm not knocking the app. I think it's brilliant and will only improve with time. I love the "dockies" as well. I'm reporting what it does *in my configuration* not someone else's.

I used to have the odd screen-flashing behavior last Spring running "Click-to-Front"from WBStartup but I'm afraid I don't recall what the fix was.

Last edited by Weaselrama; 24 April 2020 at 15:06. Reason: updated info
Weaselrama is offline  
Old 24 April 2020, 15:42   #23
Gorf
Registered User

Gorf's Avatar
 
Join Date: May 2017
Location: Munich/Bavaria
Posts: 1,309
Quote:
Originally Posted by thomas View Post
There is a 50 Hz pulse sent to each dock icon in case it needs to animate. This could cause a basic load on the CPU. But it should be far from "running hot".
Constantly or only if something changes? there could be more elegant ways of messaging...
Gorf is offline  
Old 24 April 2020, 17:18   #24
Weaselrama
Registered Voter

Weaselrama's Avatar
 
Join Date: Oct 2019
Location: Neunkirchen aP, DE
Age: 59
Posts: 573
Quote:
Originally Posted by Gorf View Post
Constantly or only if something changes? there could be more elegant ways of messaging...
That reminds me - when I start WBDock it says "screenmessage.library" (I think that was the name of it) not found. If that was documented, I missed it. I believe it's available on Aminet but I don't know what functionality it provides.

I checked and re-checked what I wrote above. If I start it manually I don't get any of the screen flashing but it eventually slows down the WB and the Mac's CPU (without additional external cooling such as the desk fan) hits 100C.
Weaselrama is offline  
Old 25 April 2020, 11:25   #25
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,521
Sorry thomas if I bother you again, is there a way in "Funny Style" mode to "not make the icons bigger" when they are raised by the click?

Another question why on AfA OS the toolbar (AmiDock, Magic, ToolManager) is fixed and can't be moved?

I created these skins for "Style Funny". (note a small empty space longer on the right side than the left !)
Attached Thumbnails
Click image for larger version

Name:	WBDock2.jpg
Views:	234
Size:	174.6 KB
ID:	67020  

Last edited by AMIGASYSTEM; 25 April 2020 at 11:34.
AMIGASYSTEM is offline  
Old 25 April 2020, 11:59   #26
malko
Ex nihilo nihil

malko's Avatar
 
Join Date: Oct 2017
Location: CH
Posts: 3,383
Missed this thread. Thanks for the application @thomas & the information @AMIGASYSTEM.
Will give a go to the 1.3 dock
malko is offline  
Old 03 June 2020, 00:03   #27
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,521
Update WBDock v1.10 WBDock2 v2.309, info and download links on the first page.
AMIGASYSTEM is offline  
Old 03 June 2020, 00:52   #28
quantum8
Registered User

 
Join Date: Jun 2019
Location: BNE AU
Posts: 214
This looks like quite a nice update. I'll have to give it a go on my rig soon.
quantum8 is offline  
Old 09 June 2020, 19:03   #29
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,521
@thomas
I noticed that Funny Style on RTG screens, creates a graphic overlay of the Skin on Windows or Icons on the Workbench if you approach the Skin.
Attached Thumbnails
Click image for larger version

Name:	WBDock2.jpg
Views:	219
Size:	36.8 KB
ID:	67698  
AMIGASYSTEM is offline  
Old 23 August 2020, 09:29   #30
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,521
Update WBDock2 v2.312

@thomas
I noticed that some DualPNG Icons look bad, there is also the problem shown in the screenshot the windows are hidden if moved towards the bar.

EDIT:
Solved, discovered that the problem was caused by the WBDock2 startup done after loading the Workbench

The fact remains that the DualPNG icons are not displayed in a perfect way, see second screenshot

Last edited by AMIGASYSTEM; 22 October 2020 at 12:35.
AMIGASYSTEM is offline  
Old 07 September 2020, 19:18   #31
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,521
@Thomas

Excuse me if I'm talking about AROS 68k, but even in the new versions of WBDock2 the graphic problem with "MagicWB Style" remains, with "Funny" I found instead an improvement, only a few small imperfections remain on the icon border (DualPNG), see screenshot.

I take this opportunity to say that NewMeter on AROS One 68k does not work well GUI aperture and graphics problems.

Last edited by AMIGASYSTEM; 22 October 2020 at 12:35.
AMIGASYSTEM is offline  
Old 01 November 2020, 18:59   #32
kamelito
Zone Friend

kamelito's Avatar
 
Join Date: May 2006
Location: France
Posts: 1,357
I had a bug while testing it from RAM: I don't have the step to repro though but all my memory was gone. (out of memory).
kamelito is offline  
Old 20 January 2021, 12:10   #33
ancalimon
Supernormal

ancalimon's Avatar
 
Join Date: Jul 2007
Location: Istanbul / Turkey
Age: 40
Posts: 1,357
The new version added Smart refresh and this fixes the flickering issues. Thanks
ancalimon is offline  
Old 20 January 2021, 13:12   #34
matburton
Registered User

matburton's Avatar
 
Join Date: Apr 2017
Location: Cambridge
Posts: 109
Just wanted to say thanks this is a lovely addition to my WB1.3 setup!
matburton is offline  
Old 21 January 2021, 01:12   #35
Firestone
Registered User

Firestone's Avatar
 
Join Date: Apr 2013
Location: Norway
Posts: 143
Oh nice! Thanks, I've been looking for a Toolmanager/Amidock replacement!
Firestone is offline  
Old 24 January 2021, 01:05   #36
mateusz_s
Registered User

 
Join Date: Jan 2020
Location: Poland
Posts: 56
Looks awesome, Thank you very much for that soft.
mateusz_s is offline  
Old 24 January 2021, 21:54   #37
TuKo
Apollo Team

TuKo's Avatar
 
Join Date: May 2014
Location: not far
Posts: 317
Awesome software !
TuKo is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
QEMU Released AMIGASYSTEM News 12 17 July 2018 00:52
Another new not released shootemup !! dlfrsilver project.aGTW 56 08 May 2012 21:42
Never released??? tomcat666 project.aGTW 18 18 January 2010 14:44
16.6 Released alexh project.WHDLoad 6 09 June 2006 10:02
WINUAEX V9 Just released !!! synchro Amiga scene 16 23 April 2006 23:49

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:54.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.10004 seconds with 16 queries