English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 19 June 2019, 02:24   #541
Wachi
Registered User

Wachi's Avatar
 
Join Date: Jul 2014
Location: Madrid
Posts: 134
Thumbs up

sorry, I did not see that he had uploaded it to his folder on ftp ..
I'm getting old.
Thanks again
Wachi is offline  
Old 22 October 2019, 17:03   #542
Puggsy
Banned

 
Join Date: May 2018
Location: Toronto
Posts: 158
I'm having issues with xbench and my CD32 setup. It seems to me that xbench is ignoring all the options for whdload set in s:whdload.prefs
I set the SplashDelay to 0 in there so it doesn't show a splash, yet every game launched from xbench shows a splash. If I launch from shell, it does not show a splash. Quirtkey also not working.

I really want to love xbench but there's still so m,any little problems like these that get n the way. I wish it would run a bit smoother and one update a year is barely quenching our thirst for a proper launcher.

Oh I also never get a random tune played on the launcher. Seems to work under emulation but not on my machine, always plays the same tune on reboot.

Last edited by Puggsy; 22 October 2019 at 17:08.
Puggsy is offline  
Old 05 January 2020, 15:18   #543
Dopefish
Registered User

 
Join Date: Jul 2017
Location: Sweden
Posts: 8
I made a custom playlist for the launcher, if anyone would like to use some new tunes for it.
Just unzip it to the xbench/datas/ folder, and switch the playlist in the settings.

Xbench_Custom_Playlist.zip
Code:
Abyss1.mod
amegas_remix.mod
Anthrox9.mod
Bamiga_Sector_1_Quaram1.mod
Black_Monks1.mod
Blizzard1.mod
Company2.mod
gods17.mod
heatbeat-nintendo.mod
jerry-feed_it_back.mod
Lightforce1.mod
lotus2-title.mod
Paradox3.mod
pink-classic_tunes.mod
pink-kunitokys_theme.mod
Prodigy5.mod
random_voice_-_monday.mod
technix-back_in_64.mod
tempest-acidjazz_evening.mod
Dopefish is offline  
Old 29 March 2020, 05:11   #544
ransom1122
Registered User
ransom1122's Avatar
 
Join Date: Aug 2011
Location: Omnicorp
Age: 42
Posts: 4,345
Once you select the new playlist, I see no change in the music? Am I doing something wrong?
ransom1122 is offline  
Old 29 March 2020, 13:25   #545
spudje
Registered User

 
Join Date: Dec 2014
Location: Netherlands
Posts: 1,264
Are you running the latest version? There was some bug in earlier versions always playing the same song from the playlist.
spudje is offline  
Old 29 March 2020, 13:46   #546
ransom1122
Registered User
ransom1122's Avatar
 
Join Date: Aug 2011
Location: Omnicorp
Age: 42
Posts: 4,345
Yes... 1.1 Final Public Release
ransom1122 is offline  
Old 29 March 2020, 19:05   #547
digger1
Registered User
 
Join Date: Feb 2020
Location: Bicester/England
Posts: 2
Memory Dump EXC4

Hi, I am very new to the Amiga having by passed it back in the day. I am currently having issues with whdload and Xbench. I can start my games manually and all works well but when using Xbench and scrolling through the Launcher I get crashes which display a core dump of some sort with the EXC4 code. Configuration of the system is A500, Chip Mem Mod, ACA 500 plus, Gotek, I also have the latest Hyperion ROM and OS, I have tested with the previous workbench and get the same error. Any help with this would be appreciated.
digger1 is offline  
Old 02 April 2020, 03:03   #548
ransom1122
Registered User
ransom1122's Avatar
 
Join Date: Aug 2011
Location: Omnicorp
Age: 42
Posts: 4,345
Anyone know how to remove games off th last played list?
ransom1122 is offline  
Old 25 October 2020, 14:00   #549
Wachi
Registered User

Wachi's Avatar
 
Join Date: Jul 2014
Location: Madrid
Posts: 134
Question

There is something new about this launcher?
Wachi is offline  
Old 17 December 2020, 23:20   #550
Bren McGuire
Registered User

Bren McGuire's Avatar
 
Join Date: Nov 2019
Location: Croydon
Posts: 153
how in the hell are you supposed to use this thing? it's ultra buggy.

Tried to scan directories: says either there's nothing (lies, it's a retroplay whdload collection filled directory), or that "the path is not valid".

if i try to make my own list, the program GURUes indifenitly. I have to reinstall it and start over.

is this really how this is? it's total crap. how did anyone get it to run?

also someone mentioned same song being played constantly? I get that too. and i have 1.1 (I downloaded it today)
Bren McGuire is offline  
Old 20 December 2020, 19:54   #551
twiggy
\m/

twiggy's Avatar
 
Join Date: Nov 2008
Location: Devon, U.K.
Age: 32
Posts: 473
Yeah, works fine for me. Didn't have to do anything special to get it running either.
twiggy is offline  
Old 21 December 2020, 15:04   #552
Bren McGuire
Registered User

Bren McGuire's Avatar
 
Join Date: Nov 2019
Location: Croydon
Posts: 153
wouldnt it be great the creator of this would come here answer questions and actually update the program, its been years.

Quote:
Originally Posted by twiggy View Post
Yeah, works fine for me. Didn't have to do anything special to get it running either.
Bren McGuire is offline  
Old 22 December 2020, 01:08   #553
JimNeray
X-bEnCh addict

JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 218
Floppy disk

Hello Amiga fans.

As you may have noticed, it's been a long time since there has been a public x-bench update.

I have good news and bad news: The good news is that development is still in progress. It has been much slower in the last two years for many reasons but it has never totally stopped. Last year a first internal alpha of release 1.2 was diffused to registered users.

The bad news is that the second alpha version of this 1.2 release is in progress but is far from being finished. I was planning to finish this second alpha and release it to registered users before a fixed release can be diffused to public but it would still take some time.

Considering that the 1.2 alpha2 version I'm currently working on is globally quite stable and good, I'll try to finish it quickly enough to release it publicly these days. It won't include everything I thought I would include in this 1.2 version but it will allow everyone to have a much better version than the old 1.1. And all the not finished features will be for the next 1.3 release.

Thanks for your support.

@Bren McGuire : Do you use some kind of tuned workbench distribution ?

@All : x-b seems to have issues with ACA500Plus ... This is in he todo but will not be fixed for this incoming 1.2 release sadly ...
JimNeray is offline  
Old 22 December 2020, 17:21   #554
Bren McGuire
Registered User

Bren McGuire's Avatar
 
Join Date: Nov 2019
Location: Croydon
Posts: 153
i figured out the problem with my scanning and it's really ridiculous, should be more explained: if you dont have the exact same dir, info, list and sort commands that come with the distribution,. all this process fails with those fake error messages. The very least you can do is expleain that these need to be in the xb: path and they need to be exactly the ones you distributed with the program.

still, absolutely any modification i do to the list files by hand, like correcting a title, make xbench guru. why the hell is this?


Quote:
Originally Posted by JimNeray View Post
@Bren McGuire : Do you use some kind of tuned workbench distribution ?
Bren McGuire is offline  
Old 29 December 2020, 06:25   #555
IanS
Registered User
IanS's Avatar
 
Join Date: Aug 2002
Location: Nottingham England
Posts: 270
Quote:
Originally Posted by Bren McGuire View Post
i figured out the problem with my scanning and it's really ridiculous, should be more explained: if you dont have the exact same dir, info, list and sort commands that come with the distribution,. all this process fails with those fake error messages. The very least you can do is expleain that these need to be in the xb: path and they need to be exactly the ones you distributed with the program.

still, absolutely any modification i do to the list files by hand, like correcting a title, make xbench guru. why the hell is this?
Don't you think you're being overly aggressive? This is a piece of software, so it may well have some issues, it may also be user error... but ranting and raving is hardly likely to get you any help from the author. How much did you pay for the software? What kind of warranty does the author promise users? What exactly do you think you're entitled to?
IanS is offline  
Old 29 December 2020, 10:35   #556
Storm
SYS64738

Storm's Avatar
 
Join Date: Oct 2014
Location: Australia
Age: 47
Posts: 82
I'm a registered user of X-Bench and it works great on my lower end Amigas. I highly recommend giving it a go, if you haven't already.
Storm is offline  
Old 29 December 2020, 16:28   #557
Bren McGuire
Registered User

Bren McGuire's Avatar
 
Join Date: Nov 2019
Location: Croydon
Posts: 153
no i am not, i am trying to help with clearly bad documentation/setup problems.
this program has a lot of issues and if we dont report them how is the author going to know whats going on?

Quote:
Originally Posted by IanS View Post
Don't you think you're being overly aggressive? This is a piece of software, so it may well have some issues, it may also be user error... but ranting and raving is hardly likely to get you any help from the author. How much did you pay for the software? What kind of warranty does the author promise users? What exactly do you think you're entitled to?
Bren McGuire is offline  
Old 29 December 2020, 17:11   #558
Wachi
Registered User

Wachi's Avatar
 
Join Date: Jul 2014
Location: Madrid
Posts: 134
Thumbs up

Waiting for version 1.2 alpha 2 to be able to test it, thanks for your effort. A greeting.
Wachi is offline  
Old 08 January 2021, 15:47   #559
Bren McGuire
Registered User

Bren McGuire's Avatar
 
Join Date: Nov 2019
Location: Croydon
Posts: 153
I have BetterWB, which replaces some commands. I didn't keep anything in C because I thought it was redundant. If I knew that these commands were necessary for the software to run, I would not have deleted them.
The problem is the software giving wrong errors when they are not present, like "empty list" or "path not found". It should say "these commands have not been found"or something. Make it more clear.

Quote:
@Bren McGuire : Do you use some kind of tuned workbench distribution ?


Any ETA on this? It's been a while

Quote:
Originally Posted by JimNeray View Post
Considering that the 1.2 alpha2 version I'm currently working on is globally quite stable and good, I'll try to finish it quickly enough to release it publicly these days. It won't include everything I thought I would include in this 1.2 version but it will allow everyone to have a much better version than the old 1.1. And all the not finished features will be for the next 1.3 release.
Bren McGuire is offline  
Old 15 April 2021, 02:57   #560
Cego
Registered User

Cego's Avatar
 
Join Date: Dec 2015
Location: Germany
Posts: 101
I have installed XBench 1.1 on my A1200 with AmigaOS 3.1.4 and Vampire1200.
XBench will freeze after entering and exiting after 2 or 3 games.
Some Games wont start from XBench, while they're running fine when started from Workbench.
I have tried the red and green button options (CD32 pad), the behaviour is still the same.

Nonetheless it is a very sophisticated gamelauncher. Thanks for your hard work @jimneray !!!
Cego is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
whdload games launcher Nova support.Games 5 30 April 2013 23:44
[FS-UAE] Amiga Game Database for FS-UAE Launcher nexusle support.FS-UAE 31 24 August 2012 20:24
Whdload launcher with 2 partitions for games? emuola project.ClassicWB 3 07 November 2011 21:35
New WHDLoad launcher - seconds on a standard A1200! Bloodwych project.ClassicWB 35 17 January 2008 21:29
If WinUAE cannot detect your supposedly empty HDD, look for zap.exe or wipe.exe. fmcpma support.WinUAE 5 08 August 2006 00:35

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:54.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.12013 seconds with 16 queries