English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 02 September 2021, 18:43   #1
enigma776
Bringer of Death

enigma776's Avatar
 
Join Date: Apr 2017
Location: UK
Age: 38
Posts: 302
Slow response in menus over time.

Hello,

For some reason winuae will slow to a crawl in its menus over time, like loading a floppy disk or just scrolling through previous disks.

So on a clean reboot its responsive and works well but then it grinds to a halt over time.

Just switching between the rom section to ram takes ages to change over. No other program does this and apart from winuae everything else runs correctly. Even winuae once running is fine until I hit F12 and it slows down.

I know that some keyboards can cause winuae itself to startup slowly (like this thread) but this all happens when its already loaded.

I have tried clearing the cache out, resetting the emulator and deleting disk history to no avail.

Does anyone else have this issue? or know of a way to solve it?
enigma776 is offline  
Old 24 September 2021, 22:32   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,096
Sorry, late answer..

No one else has reported this kind of problem. Do you have any 3rd party desktop replacements or some other similar utilities? WinUAE GUI uses plain Windows GUI elements, there should not be anything special.

It sounds strange.

Only possible reason is I can think of is GDI handle leak. Check Windows manager Performance page, does Handles value keep increasing slowly before WinUAE GUI becomes slow?

(Windows version?)
Toni Wilen is offline  
Old 25 September 2021, 11:36   #3
Viceroy
Registered User
 
Join Date: Jul 2006
Location: Sunderland
Posts: 861
...not the same issue; but if I start WinUAE at the start of the DD collection and then scroll through each game looking at boxart, by a bit over halfway the images stop displaying.

As Toni says, probably a memory leak.
Viceroy is offline  
Old 25 September 2021, 15:22   #4
enigma776
Bringer of Death

enigma776's Avatar
 
Join Date: Apr 2017
Location: UK
Age: 38
Posts: 302
Quote:
Originally Posted by Toni Wilen View Post
Sorry, late answer..

No one else has reported this kind of problem. Do you have any 3rd party desktop replacements or some other similar utilities? WinUAE GUI uses plain Windows GUI elements, there should not be anything special.

It sounds strange.

Only possible reason is I can think of is GDI handle leak. Check Windows manager Performance page, does Handles value keep increasing slowly before WinUAE GUI becomes slow?

(Windows version?)
The handles increase alright. So quite possibly a leak somewhere.
enigma776 is offline  
Old 25 September 2021, 19:31   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,096
Quote:
Originally Posted by enigma776 View Post
The handles increase alright. So quite possibly a leak somewhere.
Can you narrow it down to some specific sub panel or does it happen with all panels? (To rule out Configurations panel, temporarily enable quickstart mode)

Quote:
Originally Posted by Viceroy View Post
...not the same issue; but if I start WinUAE at the start of the DD collection and then scroll through each game looking at boxart, by a bit over halfway the images stop displaying.
Original author of this package has disappeared which makes this sort of unsupported and very low priority... This was very special case feature.
Toni Wilen is offline  
Old 25 September 2021, 19:47   #6
enigma776
Bringer of Death

enigma776's Avatar
 
Join Date: Apr 2017
Location: UK
Age: 38
Posts: 302
Quote:
Originally Posted by Toni Wilen View Post
Can you narrow it down to some specific sub panel or does it happen with all panels? (To rule out Configurations panel, temporarily enable quickstart mode)



Original author of this package has disappeared which makes this sort of unsupported and very low priority... This was very special case feature.
Its all panels, just switching between them take 3 or 4 seconds which don't sound very long but its usually instant.
enigma776 is offline  
Old 28 September 2021, 21:44   #7
Viceroy
Registered User
 
Join Date: Jul 2006
Location: Sunderland
Posts: 861
Hi Toni,

I understand if you say this is low priority, but if you could take a look sometime.

Regarding DamienD, he hasn’t disappeared, he was banned for over 6 months. I know he still reads EAB threads from time to time.

Also, he is still working on his collection; and there are over 1,500 people that use this.
Viceroy is offline  
Old 29 September 2021, 02:23   #8
enigma776
Bringer of Death

enigma776's Avatar
 
Join Date: Apr 2017
Location: UK
Age: 38
Posts: 302
Quote:
Originally Posted by Viceroy View Post
Hi Toni,

I understand if you say this is low priority, but if you could take a look sometime.

Regarding DamienD, he hasn’t disappeared, he was banned for over 6 months. I know he still reads EAB threads from time to time.

Also, he is still working on his collection; and there are over 1,500 people that use this.
Me included.
enigma776 is offline  
Old 02 October 2021, 18:21   #9
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,096
"Box art" window filehandle leak is fixed in next beta.
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running two emulations at the same time -> very slow radiojoystick support.Amiga Forever 9 03 October 2020 03:31
No response from SPS, did I something wrong Planetinfinity project.SPS (was CAPS) 15 02 September 2020 10:50
winuae cdda access time too slow vs cd32 turrican3 support.WinUAE 9 17 November 2012 05:39
Vesalia response time demolition support.Hardware 11 29 October 2012 01:10
Help ! Problems with user menus and start menus in Directory Opus 5.8 beltrixx support.Apps 0 27 May 2009 09:30

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:11.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.07465 seconds with 15 queries