English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 25 July 2021, 22:31   #1
banderson38911
Registered User

 
Join Date: Jul 2021
Location: Des Moines, US
Posts: 7
Velvet Bootblock

Hello,

I've been messing around with/documenting the features of the Kickstart 0.4 ROM in WinUAE and was wondering how to create or modify a bootblock for an ADF so it will run (virtually) on an A1000 "Velvet" system.

Thanks,
-Bernard Anderson
banderson38911 is offline  
Old 26 July 2021, 13:01   #2
Tomislav
Registered User

 
Join Date: Aug 2014
Location: Zagreb / Croatia
Posts: 297
Does 0.4 have trackdisk.device? I'm thinking that for earlier betas maybe they used some 720K sized format?!?!
Sadly, 0.4 is not included in AmigaForever, although some people say that Cloanto have it.
Tomislav is offline  
Old 26 July 2021, 13:36   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,081
I haven't checked the format but afaik it is something very different than usual Amiga MFM format. Standard ADF won't work, it needs to be extended ADF.
Toni Wilen is online now  
Old 26 July 2021, 14:54   #4
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 3,208
I think it uses standard trackdisk format.

I made a bootable ADF for it, see this post.

Also a ROM-dumping ADF, see this other post.

Neither was tested on real hardware though.
mark_k is offline  
Old 27 July 2021, 02:00   #5
banderson38911
Registered User

 
Join Date: Jul 2021
Location: Des Moines, US
Posts: 7
Quote:
Originally Posted by Tomislav View Post
Does 0.4 have trackdisk.device?
Yes it does. Albeit with fewer commands.
banderson38911 is offline  
Old 27 July 2021, 02:16   #6
banderson38911
Registered User

 
Join Date: Jul 2021
Location: Des Moines, US
Posts: 7
Quote:
Originally Posted by mark_k View Post
I think it uses standard trackdisk format.

I made a bootable ADF for it, see this post.

Also a ROM-dumping ADF, see this other post.

Neither was tested on real hardware though.
I downloaded the ADFs and unfortunately they don't seem to work, they boot to the usual black screen with green garbage. The ROM is 128K and starts at $FE0000.
banderson38911 is offline  
Old 27 July 2021, 06:49   #7
banderson38911
Registered User

 
Join Date: Jul 2021
Location: Des Moines, US
Posts: 7
Quote:
Originally Posted by Toni Wilen View Post
I haven't checked the format but afaik it is something very different than usual Amiga MFM format. Standard ADF won't work, it needs to be extended ADF.
Hello Toni. I think I found the bootblock checksum in Exec. The routine in question is at $FE0400-FE041E in the Kickstart 0.4 ROM.
banderson38911 is offline  
Old 28 July 2021, 11:18   #8
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 3,208
Quote:
Originally Posted by banderson38911 View Post
I downloaded the ADFs and unfortunately they don't seem to work, they boot to the usual black screen with green garbage. The ROM is 128K and starts at $FE0000.
I could have sworn I tested in WinUAE (using whichever version was current at the time). Could something have changed with WinUAE's velvet emulation since then???
mark_k is offline  
Old 28 July 2021, 11:35   #9
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,081
Works for me. It runs this loop:

Code:
00010000 41f9 00df f180           LEA.L $00dff180,A0
00010006 43e8 fe86                LEA.L (A0,-$017a) == $00dff006,A1
0001000A 317c 4000 ff1a           MOVE.W #$4000,(A0,-$00e6) == $00dff09a
00010010 3091                     MOVE.W (A1),(A0)
00010012 3091                     MOVE.W (A1),(A0)
00010014 3091                     MOVE.W (A1),(A0)
00010016 3091                     MOVE.W (A1),(A0)
00010018 60f6                     BT .B #$f6 == $00010010
Toni Wilen is online now  
Old 28 July 2021, 20:14   #10
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 3,208
Quote:
Originally Posted by banderson38911 View Post
I downloaded the ADFs and unfortunately they don't seem to work, they boot to the usual black screen with green garbage. The ROM is 128K and starts at $FE0000.
Is the WinUAE config you're using set to emulate the Velvet hardware? Just loading the Velvet Kickstart on an A500 (or other retail Amiga) config wouldn't work.
mark_k is offline  
Old 29 July 2021, 17:20   #11
banderson38911
Registered User

 
Join Date: Jul 2021
Location: Des Moines, US
Posts: 7
Quote:
Originally Posted by mark_k View Post
Is the WinUAE config you're using set to emulate the Velvet hardware? Just loading the Velvet Kickstart on an A500 (or other retail Amiga) config wouldn't work.
Yes. I have configured WinUAE for the Velvet hardware and ROM in versions 4.4.0 and 3.1.0.

Which one are you using?
banderson38911 is offline  
Old 29 July 2021, 21:22   #12
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,081
Did you configure Velvet using Quickstart? It is too easy to get manual config wrong.

Also add -log -serlog to command line, you should see some Velvet ROM debugging messages in log window.
Toni Wilen is online now  
Old 30 July 2021, 01:14   #13
banderson38911
Registered User

 
Join Date: Jul 2021
Location: Des Moines, US
Posts: 7
Quote:
Originally Posted by Toni Wilen View Post
Did you configure Velvet using Quickstart? It is too easy to get manual config wrong.

Also add -log -serlog to command line, you should see some Velvet ROM debugging messages in log window.
No I didn't. Will try that now.
banderson38911 is offline  
Old 30 July 2021, 01:23   #14
banderson38911
Registered User

 
Join Date: Jul 2021
Location: Des Moines, US
Posts: 7
Quote:
Originally Posted by banderson38911 View Post
No I didn't. Will try that now.
Alright. Configured Velvet in Quickstart and rescanned the ROMS. The ADF to dump the Velvet ROM is doing something. Now after displaying the "green garbage" the background changes to yellow, flashing white, then all lime green.

In other words, I think it works!
banderson38911 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bootblock jarre Coders. General 1 29 July 2019 22:51
Bootblock Games Dan support.Games 3 18 January 2018 17:14
A1000 prototype found (velvet) ovale Amiga scene 40 20 July 2017 17:06
Quickstart - A1000 "Velvet" Prototype AnnaWu support.WinUAE 6 15 December 2015 15:33
bootblock mai support.Apps 7 25 September 2012 12:28

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:50.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.11980 seconds with 15 queries