English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 23 May 2021, 00:15   #1
spudje
Registered User

 
Join Date: Dec 2014
Location: Netherlands
Posts: 1,268
Virtual mouse driver not working in AROS

I'm still running WinUAE 2.1.0, so this may be fixed already, but when running AROS in WinUAE, the virtual mouse driver option doesn't work. I freezes the mouse. So if not yet fixed, this is a bug fix/feature request
spudje is offline  
Old 23 May 2021, 00:30   #2
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,724
Which AROS 68k and which KS ROM are you using ?

I have no problem with AROS One 68k (see screnshot), in the meantime I suggest you to use a more updated version of WinUAE, of AROS 68k !

Last edited by AMIGASYSTEM; 14 July 2021 at 07:05.
AMIGASYSTEM is offline  
Old 23 May 2021, 00:37   #3
spudje
Registered User

 
Join Date: Dec 2014
Location: Netherlands
Posts: 1,268
It's only not working when I enable the virtual mouse driver option. It works fine when this option is not checked. However, then WinUAE doesn't work properly via VNC (both AmigaOS & AROS). I'm usng the ApolloOS AROS rom.
spudje is offline  
Old 23 May 2021, 01:06   #4
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,724
If you use WinUAE use the most updated ROMs that you find in the Nightly Build

If you are using ApolloOS it is not a standard AROS 68k and the Workbench is based on Dopus5

Also the virtual mouse works fine for me, can you attach your WinUAE config?

Last edited by AMIGASYSTEM; 23 May 2021 at 01:12.
AMIGASYSTEM is offline  
Old 23 May 2021, 01:17   #5
spudje
Registered User

 
Join Date: Dec 2014
Location: Netherlands
Posts: 1,268
I'll hope to have some time tomorrow to update WinUAE and if it still doesn't work put a config here.
spudje is offline  
Old 23 May 2021, 17:18   #6
spudje
Registered User

 
Join Date: Dec 2014
Location: Netherlands
Posts: 1,268
I upgraded to WinUAE 4.4, still the same problem. It's with the install image of Vampire Virtual Bootloader.

The mouse freezes a few seconds into booting when virtual mouse driver is configured.

Attached my config.
Attached Files
File Type: uae VBL_Turbo_Install_virtualmouse.uae (12.1 KB, 24 views)
spudje is offline  
Old 23 May 2021, 19:50   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 24,862
Does it work with official AROS m68k? (forks are unsupported)
Toni Wilen is offline  
Old 23 May 2021, 20:39   #8
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,724
Quote:
Originally Posted by spudje View Post
I upgraded to WinUAE 4.4, still the same problem. It's with the install image of Vampire Virtual Bootloader.

The mouse freezes a few seconds into booting when virtual mouse driver is configured.

Attached my config.
You have a completely wrong configuration for AROS 68k, your configuration with my AROS One 68k worked fine although terribly slow.

On WinUAE you can't use ApolloOS if you don't remove the Vampire hardware commands from the startup sequence, you can't use AROS 68k on a PAL screen and you can't use the KS ROM 1MB Vampire

Requirements to start AROS 68k on WinUAE (the system will boot in a few seconds)

- KS ROM aros-rom.bin (Nightly Build)

- KS ROM aros-ext.bin (Nightly Build)
- CPU 040/060 + JIT
- RAM Z3 Fast 256/512 MB
- Scheda Video UAE Zorro III VRAM 256 MB
- Screenmode 1024x768 Windowed (Recommended for better data sharing with Windows)

This is my AROS One 68k running on WinUAE (you see the speed of the restarts, I use an old PC DualCore)

[ Show youtube player ]
AMIGASYSTEM is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE Win10 virtual maschine / mouse problems tyrel support.WinUAE 4 17 November 2019 17:50
mx1000 mouse driver link dead? slaapliedje support.Hardware 6 03 March 2019 00:18
Mouse click problem with cintiq companion and virtual mouse driver donmikko support.WinUAE 9 19 February 2017 11:32
Virtual mouse earok Coders. Asm / Hardware 19 18 March 2016 21:13
Magic mouse/virtual mouse driver issues mark_k support.WinUAE 2 04 December 2012 20:43

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 23:20.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.13220 seconds with 14 queries