English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 01 December 2021, 21:38   #1061
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,242
Another fix attempt, winuae.7z updated.
Toni Wilen is offline  
Old 01 December 2021, 22:19   #1062
vulture
Registered User
 
Join Date: Oct 2007
Location: Athens , Greece
Posts: 1,373
Hi Toni,

Well done, now we are good!!!

Many thanks; I know DamienD will also be very happy indeed
vulture is offline  
Old 02 December 2021, 20:40   #1063
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,242
https://download.abime.net/winuae/fi...uae_4900b43.7z
https://download.abime.net/winuae/fi...e64_4900b43.7z

Beta 43 (RC4): Beta tags removed. Final should be out by 07.12.2021. (and a remainder: it is called 4.9 because this version is expected to have stupid bugs due to huge amount of changes and 68000 IPL timing is not yet correct. 5.0 should be fully A500 compatible)

- CDFS mounting used wrong character set translation functions, file names with character codes larger than 128 could not be opened depending on Windows regional settings.
- Vertical centering sometimes decided to use max offset, pushing the image down as much as possible.
- Filter Overscan blanking used old horizontal origin (which changed to earlier, "true" horizontal=0 position, due to chipset updates). Workaround added.
- Blacker than black in non-HDR mode was not RGB=000000 black.
Toni Wilen is offline  
Old 02 December 2021, 21:50   #1064
paraj
Registered User

 
Join Date: Feb 2017
Location: Denmark
Posts: 167
Quote:
Originally Posted by Toni Wilen View Post
I still don't know what causes JIT do to this, I have never seen it happening.. Not very important because it isn't recoverable.

(disassembler output fixed in this condition).

I agree that it's probably not important, so feel free to ignore/move from 4.9.0 thread. A bit strange that you're not seeing the same behavior as me. It's not fixed in b34.

Callstack when I get the disassembly (sorry I did not provide this in my previous report) is:


Code:
>    winuae64.exe!ShowEA(void * f, unsigned int pc, unsigned short opcode, int reg, amodes mode, wordsizes size, wchar_t * buf, unsigned int * eaddr, int * actualea, int safemode) Line 526    C++
     winuae64.exe!m68k_disasm_2(wchar_t * buf, int bufsize, unsigned int pc, unsigned short * bufpc, int bufpcsize, unsigned int * nextpc, int cnt, unsigned int * seaddr, unsigned int * deaddr, unsigned int lastpc, int safemode) Line 2319    C++
     winuae64.exe!m68k_disasm(unsigned int addr, unsigned int * nextpc, unsigned int lastpc, int cnt) Line 6488    C++
     winuae64.exe!m68k_dumpstate(unsigned int * nextpc, unsigned int prevpc) Line 6579    C++
     winuae64.exe!default_xlate(unsigned int addr) Line 1165    C++
     winuae64.exe!memory_get_real_address(unsigned int addr) Line 3802    C++
     winuae64.exe!op_4ea8_40_ff(unsigned int opcode) Line 18415    C++
     winuae64.exe!execute_normal() Line 5277    C++
     winuae64.exe!m68k_run_jit() Line 5352    C++
     winuae64.exe!m68k_go(int may_quit) Line 6457    C++
Execution continues normally for a while (don't know how long, I only stepped over ~15 times) after the access violation (Access violation reading location 0x0000000080F00000) that causes exit from pushall_call_handler.


It's reproducible for me with a debug build of latest beta as well, so if you have any thing you want me to try out/extra debug stuff that can be enabled, let me know. (Normal log attached)
Attached Files
File Type: txt winuae_log.txt (31.7 KB, 28 views)
paraj is offline  
Old 04 December 2021, 20:42   #1065
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,242
Ah, it tries to jump to address that does not exist. But it should not start debugger unless it was already started previously. It isn't anything serrious because it is not recoverable. Not sure what to do in this case except to cause some exception (bus error) or just stop it completely (HALT).

I'll check this after 4.9 is out..
Toni Wilen is offline  
Old 05 December 2021, 11:00   #1066
paraj
Registered User

 
Join Date: Feb 2017
Location: Denmark
Posts: 167
Quote:
Originally Posted by Toni Wilen View Post
Ah, it tries to jump to address that does not exist. But it should not start debugger unless it was already started previously. It isn't anything serrious because it is not recoverable. Not sure what to do in this case except to cause some exception (bus error) or just stop it completely (HALT).

I'll check this after 4.9 is out..

Yeah, you deserve to have 4.9 done before Christmas after all your hard work



(Just FYI bisection shows that the debug window started showing up from commit d0e56711422 "4500b16" due to change in memory.cpp, specifically the unconditional call to m68k_dumpstate in default_xlate)
paraj is offline  
Old 07 December 2021, 03:17   #1067
heavy
noodle
 
Join Date: Jun 2007
Location: europe
Posts: 247
no more compatible with windows xp sp3 ? kernel32.dll error "CompareStringEx" entry point at start.
heavy is offline  
Old 07 December 2021, 04:02   #1068
MrDBUG
Registered User
 
Join Date: Apr 2010
Location: Larvik, Norway
Posts: 110
Congrats on big release !!! Most excited I am right now about Floppybridge !
Any idea where I can direct questions about Floppybridge on Greaseweazle with Winuae under Wine ? :-/ I am struggling to get the /dev/ttyACM0 device to show up as a com port. I've put it in Wine/Crossover registry :-/
MrDBUG is offline  
Old 07 December 2021, 18:45   #1069
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,242
Create separate threads, thanks. I forgot to close this thread

Quote:
Originally Posted by heavy View Post
no more compatible with windows xp sp3 ? kernel32.dll error "CompareStringEx" entry point at start.
4.3 was last official supported version and apparently 4.4 still worked "accidentally". AFAIK some Visual Studio update released after 4.4 removed XP support completely.

Quote:
Originally Posted by MrDBUG View Post
Congrats on big release !!! Most excited I am right now about Floppybridge !
Any idea where I can direct questions about Floppybridge on Greaseweazle with Winuae under Wine ? :-/ I am struggling to get the /dev/ttyACM0 device to show up as a com port. I've put it in Wine/Crossover registry :-/
No idea. Probably better to ask FB author. WinUAE does not do any direct port accesses, everything happens using FB API.
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 4.0.1 beta series Toni Wilen support.WinUAE 64 15 July 2018 13:03
WinUAE 3.6.1 beta series Toni Wilen support.WinUAE 166 07 March 2018 23:48
WinUAE 3.2.0 beta series Toni Wilen support.WinUAE 385 09 November 2015 00:06
WinUAE 2.5.1 beta series Toni Wilen support.WinUAE 69 22 December 2012 11:22
WinUAE 2.2.0 beta series Toni Wilen support.WinUAE 119 28 June 2010 03:35

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.08880 seconds with 14 queries