English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware > Hardware pics

 
 
Thread Tools
Old 25 November 2005, 00:54   #1
Mr B
Registered User
 
Join Date: Nov 2005
Location: Sweden
Posts: 749
A600/1200/4000 HD interface mod... how to hook up 4 drives.

Well, triggerd by a question in a thread i was asking things in, i feelt it was time i repayed all the advices i recived, so here goes.

This is the basic build instructions translated from swedish, as best i can, after the description published by a friend of mine, in the swedish publication "AmigaInfo" issue 1 1997. The entier project is on the webpage, and the upfront info is in english, but the actual build description, is in swedish, and this is where my service to you is offerd.

I'll translate. Ask anything you need, if i cant get the answer from the text, i'll try and ask him, that might take a day or two, and he might not remeber the answer anymore :- )

Anyway, here we go. Pin config:

A1200/A4000 IDE IDE0/1 IDE2/3
C= Spec. IDE ("Primary") ("Secondary)
"""""""""""""""""""""""""""""""""""""""""""""""""""""
* 1 _RESET o---------+----[ 1]------------[ 1]
+----[38]------------[38]
2 GND o--------------[ 2]------------[ 2]
3 D7 o--------------[ 3]------------[ 3]
4 D8 o--------------[ 4]------------[ 4]
5 D6 o--------------[ 5]------------[ 5]
6 D9 o--------------[ 6]------------[ 6]
7 D5 o--------------[ 7]------------[ 7]
8 D10 o--------------[ 8]------------[ 8]
9 D4 o--------------[ 9]------------[ 9]
10 D11 o--------------[10]------------[10]
11 D3 o--------------[11]------------[11]
12 D12 o--------------[12]------------[12]
13 D2 o--------------[13]------------[13]
14 D13 o--------------[14]------------[14]
15 D1 o--------------[15]------------[15]
16 D14 o--------------[16]------------[16]
17 D0 o--------------[17]------------[17]
18 D15 o--------------[18]------------[18]
19 GND o--------------[19]------------[19]
20 n/c o--------------[20]------------[20]
21 n/c o--------------[21]------------[21]
22 GND o--------------[22]------------[22]
23 _IOW o--------------[23]------------[23]
24 GND o--------------[24]------------[24]
25 _IOR o--------------[25]------------[25]
26 GND o--------------[26]------------[26]
27 IOCHRDYo--------------[27]------------[27]
*28 n/c o--------------[28]
29 n/c o--------------[29]------------[29]
30 GND o--------------[30]------------[30]
*31 IRQ o---------+-|<-[31]
+-|<-----------------[31]
D1-D2
32 nc o--------------[32]------------[32]
33 DA1 o--------------[33]------------[33]
*34 nc o--------------[34]
35 DA0 o--------------[35]------------[35]
36 DA2 o--------------[36]------------[36]
*37 _IDECS1o--------------[37]
*38 _IDECS2o------------------------------[37]
*39 _ACTIVEo--------------[39] [39]---+

40 GND o--------------[40]------------[40] |


(My personal addition)
For independent channel activity diodes, pin 39 should be connected only on channel
1, from the amiga, and a custom active should be construckted as follows:

39 _ACTIVE2 +5V DC o-----[#####]----------->|------------+
R1 D3

(the data for this is actually in the original pinout, but the deformating made it impossible to understand, so i had to do something.)

The options are to connect both channels to one led, connect only the first channel to a led, and ignore the second, and finaly, to use this custom hookup. there is 5v in pin 41 btw, used to power the drives circutry, there is also 5v in pin 42, but since that is the feed for the drives spindle motor, that might be a bad idea... (the 5v feed is my addition to the whole deal, but its nothing fancy)

Pretty straight forward (im sorry about the looks, seams the font is slightly wrong, and the text was once tab formated. Tried to reformat, by spacing, but apparently "extra" spaces are removed.) But anyhow.

Some explaining then. from here on its my own rambling, ask if there is anything unclear.

As you can se the only real "modifications" are the addition of the 2 diods D1/D2, any generic diod will do just fine, altho lowvoltage signal diods are recomended, aka, the 1N4148, since i cant tell one way from the other on the diod, i can only tell you the marking should be on the main connector, and the other side goes to the diffrent channels. (pin 31), the reset signal is taken from pin 1, to pin 1 and pin 38 on both channels, pin 37 is put to channel 1, on pin 37, and pin 38, is put to channel 2 ON PIN 37.. Remember this, this is a great way to ruin your mod, and possibly your amiga if you dont get this right. The mod for pin 39, with the independant activityleds, is up to you, you can actually provide each drive with its own led, if you want, by hooking it a seperat resistor, and led, powering it of pin 41, and feed it to pin 39, localy on the drive. (but plz, if you do, DONT connect the wire (pin 39) at all in the main connector, it should be ok, but who knows.) Pin 28 is only connected on the first channel, why, i have no idea, since its listed as "n/c" along with a bunch of others, that still are connected all the way.

Im hoping there will be SOME questions on this, to show atleast some intrest, hopefully, i dident mess it up TO bad, by adding a few thoughts of my own. (or translating) The circutry is right, and the translation is "ok" altho, spelling and missunderstandings might take the better part of me, any uncertanty, ASK.

Components:
2 2 device cables (3 44 pin connectors)
2 1N4148 or comparable (D1/D2)
(and for the additional activityled/leds)
1 220ohm resistor (R1)
1 generic 5v led, colour by choise (D3)
(not that much hu?)

Best of luck.
B!

Source for the info, for those that feel it relevant, and as a accnowledgement to the fella who did it possible.

Last edited by Mr B; 25 November 2005 at 01:02.
Mr B is offline  
Old 25 November 2005, 08:35   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 6,375
Which software do you use to drive this ? AmigaOS does not care if there is an interface for a second IDE channel, it does only see the first one. For the second channel you need a special driver like IDEfix97. Does the interface work with IDEfix ? If not, which software do you need ?
thomas is offline  
Old 26 November 2005, 11:17   #3
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 41
Posts: 8,740
IdeFix enables this, yes.
Jope is offline  
Old 28 November 2005, 01:39   #4
Mr B
Registered User
 
Join Date: Nov 2005
Location: Sweden
Posts: 749
Offcourse, as Jope said, IDEfix will "enable" the second ide channel. This is a lowtech hack tho, and wont provide any better performance then the original speed (actually, slightly less, considering the simple controller can only use 1 channel at the time.) its as sutch inferior when compared to the 2 channel devices with buffert that are available in stores, but what can you really demand from a 2-5 dollar mod?

Best of luck.
B!
Mr B is offline  
Old 29 November 2005, 07:51   #5
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 41
Posts: 8,740
Also because it's unbuffered, you need to keep the cable lengths short, otherwise you will put unnecessary load on the Gayle's bus drivers..
Jope is offline  
Old 29 November 2005, 08:20   #6
Chain
A-Collector, repairments

Chain's Avatar
 
Join Date: Jul 2001
Location: Czech Rep.
Age: 47
Posts: 1,536
Send a message via ICQ to Chain
Quote:
Originally Posted by Jope
Also because it's unbuffered, you need to keep the cable lengths short, otherwise you will put unnecessary load on the Gayle's bus drivers..
everything less than 3 feet works great (personally tested).
who cares about gayle´s bus
Chain is offline  
Old 29 November 2005, 08:52   #7
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 41
Posts: 8,740
I'd guess the person who uses Gayle IDE would care about it's wellbeing. ;-)
Jope is offline  
Old 29 November 2005, 17:58   #8
Zetr0
Ya' like it Retr0?
Zetr0's Avatar
 
Join Date: Jul 2005
Location: United Kingdom
Age: 46
Posts: 9,768
I am thinking Chain might have to send his Gayle some flowers to make up for the abuse
Zetr0 is offline  
Old 20 August 2021, 04:36   #9
Xtal
Registered User

 
Join Date: Jul 2014
Location: Mora, Sweden
Posts: 35
Swedish article about the simple 4-way IDE adapter.

Since I wrote the article in AmigaInfo I don't mind updating with a (swedish) article where it was published. I know the font in the first post above should be fixed and I used tabs.... So, since a picture says more than a thousand words, here you have the pages covering the adapter. And yes, it's a completely unbuffered adapter, and you can't use expensive 80p cabling in the Amiga. Keep it simple! The layout is for standard A4000 2,54mm connectors and using 40pin. To adapt to a A600/A1200, simply add pins 41-44 (+5v and ground two pins for each) and use 2mm pin distance. Go figure.

https://dmzarkivet.se/pager.cfm?issu...1&page=36&ai=1
and
https://dmzarkivet.se/pager.cfm?issu...1&page=37&ai=1


For Kickstart 3.1.4 and Kickstart 3.2, you can't use IdeFIX97. It's not working (Seems they used some system calls that was marked for being obsoleted already in Kick 2.04). But there's a solution on AmiNET, that's even better and more future proofed. AtapiMagic.



On Aminet you find AtapiMagic under driver/media/


https://aminet.net/driver/media/AtapiMagic.lha


Yours,
Mikael "Xtal" Fors
Xtal is offline  
Old 20 August 2021, 05:00   #10
Xtal
Registered User

 
Join Date: Jul 2014
Location: Mora, Sweden
Posts: 35
Image and some clarification to the post above

I don't even use the activity light for second IDE in my A4000D, why? I obviously already have a activity led in my optical drive.... By the way I reccomend using (if you can find them) Toshiba Samsung SH-S182 for the simple reason is that they give you about 3cm more space between the drive and the PSU in A4000D compared to a standard sized unit like the Yamaha CRW2200 and most other optical drives. And you can select between black, beige and silver fronts :-D



And no. Buffered 4way adapters aren't faster. Everything goes through the same IDE port on the motherboard. Just for clarification.
Xtal is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A3000/4000 1MB ROM Mod SpeedGeek Hardware mods 1 05 November 2014 16:03
Amiga 4000 PSU Fan Mod edd_jedi Hardware mods 8 30 December 2012 17:02
MIDI interface for A600? Hedefar support.Hardware 28 23 November 2012 19:11
FS: Internal drives Cinon FZ-354 A600/1200 mr.niceguy MarketPlace 1 19 October 2009 19:24
Are folks still able to mod their CF memory drives? NastyFreddy Hardware mods 8 24 January 2009 23:44

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:40.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.08847 seconds with 15 queries