English Amiga Board


Go Back   English Amiga Board > Support > support.Other

 
 
Thread Tools
Old 10 January 2022, 09:30   #641
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 324
Quote:
Originally Posted by wiz12 View Post
That's interesting, I didn't know HST would proceed with some missing .adfs. I know you can see what you have and what's missing from the "View Amiga OS Set files" option but I always thought you may need the entire set. Perhaps vital .adfs for installation could be marked in a different colour as an option in a future release?
That's right, not all files are required. I noticed this since I got physical floppies with my Amiga OS 3.2 purchase and this only included 6 floppy disks: Install, Workbench, Classes, Fonts, Storage, Extras.

In view amiga os files, yellow colored entries means files are optional and not found and red colored entries means files are required and don't exist.

So I could actually change Locale disk from required to optional.

Last edited by cyberhead97; 10 January 2022 at 09:33. Reason: Further explained amiga os set coloring
cyberhead97 is offline  
Old 10 January 2022, 14:33   #642
enigma776
Bringer of Death

enigma776's Avatar
 
Join Date: Apr 2017
Location: Peterborough, UK
Age: 38
Posts: 364
If there is going to be an overhaul of detection can we have a manual detection instead of CRC, my 3.1 disks from AF9 never get detected.
enigma776 is offline  
Old 10 January 2022, 18:45   #643
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 324
Quote:
Originally Posted by enigma776 View Post
If there is going to be an overhaul of detection can we have a manual detection instead of CRC, my 3.1 disks from AF9 never get detected.
It's really annoying Cloanto keeps changing Amiga OS 3.1 adf files resulting in new MD5 checksums.

I will add AF9 MD5 for Amiga OS 3.2 adf's with next release. HstWB Installer should be able to detect amiga os adf files regardless of MD5 using "MD5 + Mount" for self install images and install mode, if adf files volume name are the same as the original Amiga OS 3.1 volume names, eg. Workbench:, Install: and so on when inserting adf files.

Are you using setup.cmd and install mode, where it's doesn't detect AF9 3.1 disks?
cyberhead97 is offline  
Old 10 January 2022, 18:47   #644
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 324
HstWB Installer for Raspberry Pi OS is soon ready for release.

The idea is being able to install HstWB Installer on clean/fresh or existing Raspberry Pi OS and comes with a set of menus to simplify installation of Amiberry emulator, Kickstart roms, HstWB Installer UAE4ARM self image and much more.

It also configures auto-login, auto start of Amiga emulator, improves boot speed, installs and configures usbmount to use FAT32 formatted USB sticks, Samba network shares to copy files over network and lots of other options.

Currently it only supports latest Raspberry Pi OS tested on Raspberry Pi 4 and 400, but should work on any Raspberry Pi latest Raspberry Pi OS supports. Later support for other distro's like RetroPie, DietPi, Ubuntu Server will be added.

Here's some teaser screenshots (taken with Putty SSH) showing what HstWB Installer for Raspberry Pi OS looks like
Attached Thumbnails
Click image for larger version

Name:	hstwb installer for raspberry pi os 1.PNG
Views:	37
Size:	16.2 KB
ID:	74358   Click image for larger version

Name:	hstwb installer for raspberry pi os 2.PNG
Views:	38
Size:	13.0 KB
ID:	74359   Click image for larger version

Name:	hstwb installer for raspberry pi os 3.PNG
Views:	41
Size:	21.3 KB
ID:	74360   Click image for larger version

Name:	hstwb installer for raspberry pi os 4.PNG
Views:	38
Size:	14.5 KB
ID:	74361   Click image for larger version

Name:	hstwb installer for raspberry pi os 5.PNG
Views:	38
Size:	14.3 KB
ID:	74362  

Click image for larger version

Name:	hstwb installer for raspberry pi os 6.PNG
Views:	34
Size:	19.3 KB
ID:	74363   Click image for larger version

Name:	hstwb installer for raspberry pi os 7.PNG
Views:	37
Size:	16.7 KB
ID:	74364   Click image for larger version

Name:	hstwb installer for raspberry pi os 8.PNG
Views:	38
Size:	16.8 KB
ID:	74365  

Last edited by cyberhead97; 10 January 2022 at 18:48. Reason: removed text
cyberhead97 is offline  
Old 10 January 2022, 18:48   #645
enigma776
Bringer of Death

enigma776's Avatar
 
Join Date: Apr 2017
Location: Peterborough, UK
Age: 38
Posts: 364
Quote:
Originally Posted by cyberhead97 View Post
It's really annoying Cloanto keeps changing Amiga OS 3.1 adf files resulting in new MD5 checksums.

I will add AF9 MD5 for Amiga OS 3.2 adf's with next release. HstWB Installer should be able to detect amiga os adf files regardless of MD5 using "MD5 + Mount" for self install images and install mode, if adf files volume name are the same as the original Amiga OS 3.1 volume names, eg. Workbench:, Install: and so on when inserting adf files.

Are you using setup.cmd and install mode, where it's doesn't detect AF9 3.1 disks?
No it quite possibly be my fault, as I mess around and change things in the HDTOOLBOX its obviously changing the MD5 of the disk, so I am now keeping a "clean" version of the adfs for use with HstWB. This might be my troubles.
enigma776 is offline  
Old 10 January 2022, 18:49   #646
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 324
... and photos of HstWB self image being installed with WHDLoad Packs games installation running as well for a test run
Attached Thumbnails
Click image for larger version

Name:	hstwb installer for raspberry pi os 9.jpg
Views:	56
Size:	312.2 KB
ID:	74366   Click image for larger version

Name:	hstwb installer for raspberry pi os 10.jpg
Views:	55
Size:	341.1 KB
ID:	74367  
cyberhead97 is offline  
Old 14 January 2022, 10:12   #647
dimfil
Registered User

 
Join Date: Nov 2014
Location: Athens Greece
Posts: 17
On running Setup from version 1.6.2 I get an error for data.psm1 in modules folder.
Any advise?
Attached Thumbnails
Click image for larger version

Name:	hstwb_setup.png
Views:	49
Size:	39.5 KB
ID:	74392  
dimfil is offline  
Old 14 January 2022, 12:09   #648
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 324
Quote:
Originally Posted by dimfil View Post
On running Setup from version 1.6.2 I get an error for data.psm1 in modules folder.
Any advise?
Do you have Cloanto Amiga Forever kickstart rom files in your selected kickstart directory?

If yes, do you also have required rom key file in same directory as kickstart rom files?

That could result in an error and i need to improve the error message if that's the case
cyberhead97 is offline  
Old 14 January 2022, 15:16   #649
dimfil
Registered User

 
Join Date: Nov 2014
Location: Athens Greece
Posts: 17
Quote:
Originally Posted by cyberhead97 View Post
Do you have Cloanto Amiga Forever kickstart rom files in your selected kickstart directory?

If yes, do you also have required rom key file in same directory as kickstart rom files?

That could result in an error and i need to improve the error message if that's the case
It is a completely fresh install. The message comes immediately after launching Launcher.cmd or Setup.cmd.
Never entered menu to select directories pointing to roms etc...
dimfil is offline  
Old 14 January 2022, 15:49   #650
vatastala
Registered User

vatastala's Avatar
 
Join Date: Aug 2019
Location: rome
Posts: 12
Quote:
Originally Posted by cyberhead97 View Post
Does it still make sense to keep updating this thread with new releases?
Hi cyberhead97, I would like to tell you that your work is truly fantastic and I hope that you will always keep updating us on this fabulous project.

I have 2 Amiga's (600 and 1200) and in both I have installed the August version that is 1.5.1. Now I would like to move to 1.6.2, but before doing that I would need to understand something ... Obviously for whdloads you base yourself from time to time on the new releases that come out, but possibly there is a way to update the catalog of images and games of AGS2 without having to switch to a new version every time? For example, I am now on 1.5.1, if I add the whdloads released since August how can I update AGS2 with the new contents?

Thank you so much for everything, you are a true myth !!!
vatastala is offline  
Old 14 January 2022, 19:32   #651
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 324
Quote:
Originally Posted by vatastala View Post
Hi cyberhead97, I would like to tell you that your work is truly fantastic and I hope that you will always keep updating us on this fabulous project.

I have 2 Amiga's (600 and 1200) and in both I have installed the August version that is 1.5.1. Now I would like to move to 1.6.2, but before doing that I would need to understand something ... Obviously for whdloads you base yourself from time to time on the new releases that come out, but possibly there is a way to update the catalog of images and games of AGS2 without having to switch to a new version every time? For example, I am now on 1.5.1, if I add the whdloads released since August how can I update AGS2 with the new contents?

Thank you so much for everything, you are a true myth !!!
Thanks a lot for the very nice feedback. I'm glad you find it useful.

With each new release I also release HstWB package installation and HstWB user package installation. These contain installation of only packages and user packages without Amiga OS installation. They can be downloaded, extracted and transfered to your already running Amiga. On your Amiga double-click on "Package-Installation" or "UserPackage-Installation" to start either package installation or user package installation.

In your case you need download HstWB package installation, which contains the updated EAB WHDLoad menu packages. The installation is the same as the package installation, when installing from scratch. Then just select you want to install EAB WHDLoad Games menu package.

To get WHDLoads from Retroplay updated, download just the new ones manually or using a tool, maybe EAB Downloader can do this. Then download and extract HstWB user package installation and drop the downloaded WHDLoads .lha files in "WHDLoad Packs", "EAB WHDLoad Games" directory. Run build_install_entries script. Next run HstWB user package installation and select you want to install "WHDLoad Packs" to install WHDLoads.
cyberhead97 is offline  
Old 14 January 2022, 19:41   #652
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 324
Quote:
Originally Posted by dimfil View Post
It is a completely fresh install. The message comes immediately after launching Launcher.cmd or Setup.cmd.
Never entered menu to select directories pointing to roms etc...
Ahh darn, then it's a bug with a fresh install.

A temporary fix could be running the following command by pressing Windows Key + R:
Code:
notepad "%LOCALAPPDATA%\HstWB Installer\hstwb-installer-settings.ini"
Then add the line, if it doesn't exist:
Code:
AmigaOsDir=C:\Temp
Save and retry running setup.cmd.
cyberhead97 is offline  
Old 14 January 2022, 20:53   #653
dimfil
Registered User

 
Join Date: Nov 2014
Location: Athens Greece
Posts: 17
Quote:
Originally Posted by cyberhead97 View Post
Ahh darn, then it's a bug with a fresh install.

A temporary fix could be running the following command by pressing Windows Key + R:
Code:
notepad "%LOCALAPPDATA%\HstWB Installer\hstwb-installer-settings.ini"
Then add the line, if it doesn't exist:
Code:
AmigaOsDir=C:\Temp
Save and retry running setup.cmd.
Tnank you for your immediate response!
Tried your suggestion, unfortunately is a "no go". Same error message.
I deleted the settings file and started launcher from my v1.5.1 installation. It starts OK of course and creates the relative settings and assign files. Tried the following:
- started v1.6.2 launcer but error again
- edited settings.ini (already AmigaOsDir present but empty value) with C:\Temp and saved, still error message

Do you believe it would be safe to copy all files from v1.6.2 to an existing v1.5.1 folder overwriting where prompted?
dimfil is offline  
Old 14 January 2022, 21:54   #654
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 324
Quote:
Originally Posted by dimfil View Post
Tnank you for your immediate response!
Tried your suggestion, unfortunately is a "no go". Same error message.
I deleted the settings file and started launcher from my v1.5.1 installation. It starts OK of course and creates the relative settings and assign files. Tried the following:
- started v1.6.2 launcer but error again
- edited settings.ini (already AmigaOsDir present but empty value) with C:\Temp and saved, still error message

Do you believe it would be safe to copy all files from v1.6.2 to an existing v1.5.1 folder overwriting where prompted?
It would be better to take files from GitHub https://github.com/henrikstengaard/hstwb-installer. This contains latest with launcher fixed being prepared for next release. Try downloading both launcher.ps1 and launcher.cmd by opening the files on GitHub and click raw. Then copy the contents of these to files. You can also download them via browser save as
cyberhead97 is offline  
Old 15 January 2022, 08:55   #655
dimfil
Registered User

 
Join Date: Nov 2014
Location: Athens Greece
Posts: 17
Quote:
Originally Posted by cyberhead97 View Post
It would be better to take files from GitHub https://github.com/henrikstengaard/hstwb-installer. This contains latest with launcher fixed being prepared for next release. Try downloading both launcher.ps1 and launcher.cmd by opening the files on GitHub and click raw. Then copy the contents of these to files. You can also download them via browser save as
Great, thank you, I will try it that way.
I thought that releases already contain latest files but that of course could not be the case. I am familiar with GitHub, I will give it a go ..

By the way, I would like to thank you for this project! I use HstWBInstaller already from v1.2.0 creating images for my systems and some fellow amiga users here in Greece.
I also posted a guide for HstWBInstaller in a popular local greek forum which I would like to update, that's why I tried v1.6.2.

Thank you again for all your efforts!
dimfil is offline  
Old 15 January 2022, 09:11   #656
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 324
Quote:
Originally Posted by dimfil View Post
Great, thank you, I will try it that way.
I thought that releases already contain latest files but that of course could not be the case. I am familiar with GitHub, I will give it a go ..

By the way, I would like to thank you for this project! I use HstWBInstaller already from v1.2.0 creating images for my systems and some fellow amiga users here in Greece.
I also posted a guide for HstWBInstaller in a popular local greek forum which I would like to update, that's why I tried v1.6.2.

Thank you again for all your efforts!
It's quite simple to download single files from GitHub.

Each release do contain latest until I start to update, fix and make new changes, which has already happened since HstWB Installer v1.6.2.

Here's the history of changes to HstWB Installer
https://github.com/henrikstengaard/h...commits/master and a lot had happened since January 4th where v1.6.2 was released.

I'm starting to prepare next release today or tomorrow.
cyberhead97 is offline  
Old 16 January 2022, 22:26   #657
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 324
HstWB Installer v1.6.3 is now released at https://hstwb.firstrealize.com with following new downloads available:

HstWB Installer with packages:
  • HstWB Installer v1.6.3 Portable with packages

HstWB Installer without packages:
  • HstWB Installer v1.6.3 Portable without packages

HstWB package and user package installation:
  • HstWB Package Installation v1.6.3
  • HstWB User Package Installation v1.6.3

Prebuild self install images for Amiga's, WinUAE and FS-UAE emulators supporting RDB:
  • 4GB HstWB self install HDF image v1.6.3
  • 8GB HstWB self install HDF image v1.6.3
  • 16GB HstWB self install HDF image v1.6.3
  • 32GB HstWB self install HDF image v1.6.3
  • 64GB HstWB self install HDF image v1.6.3
  • 120GB HstWB self install HDF image v1.6.3

Prebuild self install images for Amiberry, UAE4ARM, UAE4ALL, UAE4ALL2 emulators that doesn't support RDB:
  • UAE4ALL HstWB self install HDF image v1.6.3 (HDF files DH1, DH2, DH3 and DH4 requires surfaces is set to 2. Some Amiga emulators doesn't support this!)
  • UAE4ARM HstWB self install HDF image v1.6.3

HstWB Installer v1.6.3 comes with following updates and fixes:
  • HstWB Installer for Raspberry Pi, supports Raspberry Pi OS Lite. See https://github.com/henrikstengaard/h...r-Raspberry-Pi GitHub Wiki for installation.
  • Add UAE4ARM image with DH0 and DH1 as directories.
  • Fix launcher not starting and fix launcher topaz font.
  • Fix Amiga OS 3.2.1 prefs.
  • Fix Amiga OS detection for package installation.
  • Fix rom key error when Amiga OS directory is not defined.

HstWB Installer for Raspberry Pi can download, compile and install latest version of Amiberry and UAE4ARM with just a few clicks in menus it comes with. This also simplifies Raspberry Pi configuration and HstWB Installer image setup with menus. Even auto usb mount of FAT32 devices and Samba network shares are automatically configured.

Amiberry and UAE4ARM has been installed (downloaded and compiled) and tested with Raspberry Pi 400, 4 and 3 B.

Wiki pages and documentation are being updated. Next release will focus on tests and possible support for Raspberry Pi distros like Ubuntu, DietPi and RetroPie.

Enjoy the release and please report any issues
Attached Thumbnails
Click image for larger version

Name:	Raspberry_Pi_Logo.jpg
Views:	36
Size:	69.8 KB
ID:	74431   Click image for larger version

Name:	hstwb_installer_self_install_1.6.3.png
Views:	35
Size:	13.3 KB
ID:	74432   Click image for larger version

Name:	hstwb_installer_setup_1.6.3.png
Views:	36
Size:	68.2 KB
ID:	74433   Click image for larger version

Name:	hstwb_rpi_2_hstwb_main_menu.png
Views:	40
Size:	16.2 KB
ID:	74434   Click image for larger version

Name:	hstwb-installer_rpi_setup_amiberry.png
Views:	42
Size:	18.1 KB
ID:	74435  

Click image for larger version

Name:	hstwb-installer_rpi_setup_uae4arm.png
Views:	33
Size:	17.4 KB
ID:	74436   Click image for larger version

Name:	hstwb-installer_rpi_setup_raspberry_pi_os.png
Views:	38
Size:	28.9 KB
ID:	74437  
cyberhead97 is offline  
Old 27 January 2022, 02:43   #658
Lisko
Registered User

 
Join Date: Mar 2021
Location: Avellino, Italy
Posts: 161
Hi I downloaded latest user packages to install eab whdload pack on my existing workbench installation. After downloading all the packages from the ftp to the eab's directories inside whdload packs folder and click on build_install_entries.command (I'm on mac os), the terminal opens but python errors with a TypeError: expected unicode instead of str as argument of normalize() function. Is my only option to recover a windows machine and use the powershell script instead? Thanks
Lisko is offline  
Old 27 January 2022, 22:09   #659
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 324
Quote:
Originally Posted by Lisko View Post
Hi I downloaded latest user packages to install eab whdload pack on my existing workbench installation. After downloading all the packages from the ftp to the eab's directories inside whdload packs folder and click on build_install_entries.command (I'm on mac os), the terminal opens but python errors with a TypeError: expected unicode instead of str as argument of normalize() function. Is my only option to recover a windows machine and use the powershell script instead? Thanks
It needs to be fixed and I will look into it. I assume you're running latest version of macOS Big Sur or Monterey?
cyberhead97 is offline  
Old 29 January 2022, 17:37   #660
geoff
Registered User

 
Join Date: Jan 2022
Location: Stockport
Posts: 5
Hiya,

Brilliant utility! Noticed using both 1.6.2 and 1.6.3 that iGame does not load when clicked when using hdf16gb. Not sure if I am doing something wrong or if it is a bug?

Cheers
geoff is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
HstWB Installer for Classic Amiga AMIGASYSTEM News 26 05 March 2021 17:31
Legal Issues if Sharing RP9 Snapshots? tygre Retrogaming General Discussion 17 18 September 2014 20:04
Making cf_ClassicWB_FULL.hdf bigger? emuola project.ClassicWB 3 06 June 2009 00:23
New ruling making retro-archives legal? Bloodwych Retrogaming General Discussion 3 24 November 2006 19:30

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:11.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.11079 seconds with 14 queries