English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 24 January 2022, 08:08   #21
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 46
Posts: 1,965
Here is it:
https://1drv.ms/u/s!ApMUGr0cuN39goZq...l0UIg?e=hoYYKg

This was the video with JoyPortTest by Psygore:
[ Show youtube player ]
hexaae is offline  
Old 24 January 2022, 08:26   #22
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,367
I missed the video yesterday. Joyport tester finally shows what I wanted to see, mouse counters jump mostly randomly around which probably points to mouse speed adjustment going wrong in emulator side but I can't see anything obvious. Some kind of overflow most likely.
Toni Wilen is offline  
Old 24 January 2022, 08:37   #23
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 46
Posts: 1,965
No hints from the logs/dump?
Tonight I'll test starting emulation WITHOUT "Mouse/Joystick autoswitching" from the beginning...

The strange thing is that it starts jumping ONLY in laced modes and not in general situation... When it starts doing so there is no issue if I open Low/Hires PAL/NTSC normal screens, so there's something related to laced screen emulation vs mouse input.

Last edited by hexaae; 24 January 2022 at 08:55.
hexaae is offline  
Old 24 January 2022, 20:11   #24
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 46
Posts: 1,965
Just reproduced the issue after 10h with "Mouse/Joystick autoswitching=OFF"
hexaae is offline  
Old 24 January 2022, 20:14   #25
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,367
I might have found one possibility for overflow that could happen if running long enough, ~10 hours or so. Depends on used screen modes (programmed mode or RTG + 31KHz amigavideo) can make it happen faster.
Toni Wilen is offline  
Old 24 January 2022, 21:45   #26
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 46
Posts: 1,965
Sounds promising... This long-standing bug has its hours counted!
hexaae is offline  
Old 25 January 2022, 15:29   #27
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 46
Posts: 1,965
b7: 14h... no jumping mouse issue! Will test again overnight of course...
hexaae is offline  
Old 26 January 2022, 22:58   #28
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 46
Posts: 1,965
Another 10hours run and... NO mouse problems in laced modes!
hexaae is offline  
Old 27 January 2022, 23:09   #29
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 46
Posts: 1,965
4.9.1 b7, just to be sure... Never two without three



Another 10 hours test that definitely proves this mouse issue with laced screen res after long run is definitely fixed! Case solved. Thank you Toni.

Last edited by hexaae; 27 January 2022 at 23:19.
hexaae is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blitz2: Hires laced BippyM Coders. Language 25 06 February 2020 01:07
Mouse pointer resolution in P96 mode? hexaae support.WinUAE 7 24 September 2019 21:29
Mouse Pointer resolution problem rsn8887 support.WinUAE 3 13 December 2015 18:26
ClassicWB OS3.9 : High resolution Pointer vertically stretched? Amon_RA project.ClassicWB 2 10 July 2015 22:37
Few games don't switch resolution from video card to native amiga resolution! digital support.WinUAE 12 14 March 2003 13:23

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:52.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.08327 seconds with 15 queries