English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 01 February 2003, 00:38   #1
scaf
Registered User
scaf's Avatar
 
Join Date: Jan 2003
Location: france
Age: 46
Posts: 116
Send a message via MSN to scaf
A2091 and CDROM

I have a A2000HD with A2091.
I tried to plug a SCSI CDROM drive, but the system don't even boot. it's just blocked to the grey screen.

The A2091 has a 6.6 ROM, the CDROM drive and the hard disk have a different ID.

Is it possible to plug a CDROM drive in the A2091?
scaf is offline  
Old 01 February 2003, 02:25   #2
RetroMan
Registered User
RetroMan's Avatar
 
Join Date: Aug 2001
Location: Germany
Age: 48
Posts: 3,704
Should be possible Are you sure you terminated the CDRom (if it´s the last SCSI Device) ??
RetroMan is offline  
Old 01 February 2003, 03:23   #3
Akira
Black Lives Matter

Akira's Avatar
 
Join Date: May 2001
Location: New York
Posts: 19,518
I'd also think about a termination issue! Make sure you plugged a terminator at the end of the chain...
Akira is offline  
Old 01 February 2003, 23:29   #4
scaf
Registered User
scaf's Avatar
 
Join Date: Jan 2003
Location: france
Age: 46
Posts: 116
Send a message via MSN to scaf
I tried to plug the CDROM in internal (with the hard drive), then in external, checked the termination, but the result is the same.

My CDROM is a Toshiba XM-3601B and works on my PC.

Maybe I should buy another controller (one with processor acceleration) ?
scaf is offline  
Old 05 February 2003, 12:36   #5
Phiber
Hardware Freak
Phiber's Avatar
 
Join Date: May 2002
Location: Helsinki / Finland
Age: 47
Posts: 222
Send a message via MSN to Phiber
Upgrading the ROM to version 7.0 should cure a few flaws in this card's performance..

ROM revisions are a common problem with the A2091; 6.6 or later ROMs are desirable, with 7.0 being the last version (strongly recommended, and necessary for 68040 machines). Most A2091s have revision 04 of the Western Digital 33C93 SCSI controller chip; replacing this with the 08 version may clear up SCSI bus problems. (Despite common belief, the "PROTO" marking is insignificant on either version of the WD chip; version 04 or version 08 are the only significant values.)

The version 7 ROM fixes the following bugs in the 6.6 ROM
- >1GB HD support
- DMA reselection bug fixed
- disconnect/reconnect performance improved a lot
- Sync messages are handled
- Error handling improved
- Sync problems with Seagate/Syquest fixed
- Removable media recognition fixed
- Slow boot jumper now does a 15 second wait plus 300ms scan
Phiber is offline  
Old 07 February 2003, 00:44   #6
scaf
Registered User
scaf's Avatar
 
Join Date: Jan 2003
Location: france
Age: 46
Posts: 116
Send a message via MSN to scaf
I read something about the Guru ROM. Is it the 7.0 ROM for A2091 ?

In case i'd change the ROM (and/or the controller chip), it must be very hard to find one, nowadays...

About the controller chip : are there some PC SCSI cards that have this chip? I know someone who has a AHA1540.
Perhaps I should look at its chip............
scaf is offline  
Old 07 February 2003, 14:16   #7
Phiber
Hardware Freak
Phiber's Avatar
 
Join Date: May 2002
Location: Helsinki / Finland
Age: 47
Posts: 222
Send a message via MSN to Phiber
Quote:
Originally posted by scaf
I read something about the Guru ROM. Is it the 7.0 ROM for A2091 ?

In case i'd change the ROM (and/or the controller chip), it must be very hard to find one, nowadays...

About the controller chip : are there some PC SCSI cards that have this chip? I know someone who has a AHA1540.
Perhaps I should look at its chip............
The Guru 7.0 ROM is a third party chip made for the A2091
Basically, it updates the functionality and features of the original chips that came with the controller..

There are a few places you might ask for it

http://amiga-israel.hypermart.net/Products_1.html
http://www.datakompaniet.no/produkter/apriser.txt (Norwegian company)
Phiber is offline  
Old 13 February 2003, 16:31   #8
scaf
Registered User
scaf's Avatar
 
Join Date: Jan 2003
Location: france
Age: 46
Posts: 116
Send a message via MSN to scaf
I changed the drive for a Yamaha writer (cdr-400t), and it works very well
In fact, it seems the first drive wasn't fully compatible with the card

The new prob I have is that, since I added the drive, my A2000 waits more than 40 s to boot. It looks like blocked to the white screen, and then boots.
There is a SCSI delay i didn't activate.
If someone knows a trick to make it boot faster ?
scaf is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A2091 Roms desantii support.Hardware 7 01 July 2010 17:26
A2091 for sale again boing_1000 MarketPlace 2 27 October 2006 07:50
A2091 The Luney Bin support.Hardware 1 10 September 2002 01:17
A2091 Help! Pete support.Hardware 11 17 July 2002 16:15
a2091 hal support.Hardware 3 08 March 2002 22:02

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:11.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.10258 seconds with 15 queries