English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 24 June 2011, 10:51   #1
pmc
gone
pmc's Avatar
 
Join Date: Apr 2007
Location: completely gone
Posts: 1,596
Hardware feature not emulated...?

I'm not sure if this is where I should post this or whether Photon might already have mentioned it himself so apologies in advance if this is repetition or old news but...

This prod recently released by Photon: http://www.pouet.net/prod.php?which=57097

runs OK on real A500 but doesn't run OK in the emulator - what I mean to say is, it runs with no crashes or anything but you don't see the same in WinUAE (blank screen) that you do on the real hardware (see screenshot at link for real hardware output).

Thought I'd mention it in case it leads to something in the emulator being emulated more accurately than it is now.
pmc is offline  
Old 24 June 2011, 10:54   #2
StingRay
move.l #$c0ff33,throat

StingRay's Avatar
 
Join Date: Dec 2005
Location: Berlin/Joymoney
Posts: 6,629
As far as I know Photon sent the intros to Toni already.
StingRay is offline  
Old 24 June 2011, 10:57   #3
pmc
gone
pmc's Avatar
 
Join Date: Apr 2007
Location: completely gone
Posts: 1,596
I had a feeling when I submitted this thread that someone was about to reply saying just what you said...

What do you know, my crystal ball was working!

Apologies for wasting time - I'll shuffle away quietly now...
pmc is offline  
Old 24 June 2011, 11:20   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 24,736
It is "feature" that can't be emulated without major display emulation rewrite (without causing huge slowdowns) because currently Agnus display DMA and Denise shift registers are not as separate as in real hardware. (and they shouldn't be for performance reasons, this special stuff needs completely separate code path)

"7-plane" BPLDAT5/6 emulation is easy because patterns are static, this can be faked without actually emulating it.
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
access emulated memory ara support.WinUAE 6 03 April 2010 13:05
Emulated to A3000 Problems shorin New to Emulation or Amiga scene 1 05 August 2005 17:54
What do I need to do to get my emulated Amiga 'online'? Peanutuk support.Apps 2 06 July 2004 18:41
Problems with the Emulated Filesystem Kintaro support.WinUAE 0 11 September 2002 16:17
System you would like to see emulated next Ian Retrogaming General Discussion 18 08 November 2001 08:16

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:43.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.07105 seconds with 15 queries