English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 15 October 2021, 18:17   #1
rzazar
Registered User

rzazar's Avatar
 
Join Date: Jul 2019
Location: Virginia / USA
Age: 45
Posts: 20
Exclamation Amiga 500, main return key not working

Hi, Hope you all are doing well.
I am having an issue with my new Amiga 500, the main return key.
All other keys are working except for the main return key. I thought it was caused by a bad membrane, so I ordered a brand new one from Amigastore. I just received it today and replace it.
Still the same issue, The return key is not working. Amiga boot to the workbench and everything works perfectly.
Does anyone have any ideas of what it might be?
rzazar is offline  
Old 15 October 2021, 18:49   #2
amiman99
Registered User

amiman99's Avatar
 
Join Date: Sep 2009
Location: San Antonio, TX USA
Age: 48
Posts: 1,128
Did you clean the plunger? Try pressing harder.
Did you try ALL keys, like F keys, del, Help etc?

I would try a keyboard test program to see if other key are working.
amiman99 is offline  
Old 15 October 2021, 18:53   #3
rzazar
Registered User

rzazar's Avatar
 
Join Date: Jul 2019
Location: Virginia / USA
Age: 45
Posts: 20
I cLeaned the keyboard in and out. I just checked the plunger, everything looks fine.
I checked the keyboard functionality with the AmigaTest program, and also the workbench shell
All other keys are working!
Attached Thumbnails
Click image for larger version

Name:	20211015_115659.jpeg
Views:	43
Size:	229.0 KB
ID:	73489   Click image for larger version

Name:	20211015_115710.jpeg
Views:	41
Size:	314.7 KB
ID:	73490  

Last edited by rzazar; 15 October 2021 at 19:00.
rzazar is offline  
Old 15 October 2021, 20:19   #4
amiman99
Registered User

amiman99's Avatar
 
Join Date: Sep 2009
Location: San Antonio, TX USA
Age: 48
Posts: 1,128
There is a hard way to check,
Trace the return key to both pins on the ribbon cable, then trace those positions to corresponding pins on ic chip. Short the pins momentarily while your keyboard test is running and see if it get registered. I did that once to see if my IC was good.

Last resort, change the controller board.
I think I have one somewhere...
amiman99 is offline  
Old 15 October 2021, 20:24   #5
rzazar
Registered User

rzazar's Avatar
 
Join Date: Jul 2019
Location: Virginia / USA
Age: 45
Posts: 20
The issue has been resolved. I had a bad plunger. Changed it and now working.
Thank you for your time and assistance.
rzazar is offline  
Old 15 October 2021, 23:28   #6
amiman99
Registered User

amiman99's Avatar
 
Join Date: Sep 2009
Location: San Antonio, TX USA
Age: 48
Posts: 1,128
Cool.
amiman99 is offline  
Old 18 October 2021, 01:00   #7
rjd324
Registered User

rjd324's Avatar
 
Join Date: May 2020
Location: NE / UK
Posts: 177
Sometimes I use an exacto knife and scrape the contact of the plunger a little bit too and then give it an IPA.

Nice that it is solved.
rjd324 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A1200 right Amiga key not working Cobe support.Hardware 5 21 April 2021 10:27
A600 right Amiga key not working Akira support.Hardware 2 09 August 2015 23:37
Amiga 500: main return key dead. Muzer support.Hardware 2 22 September 2012 02:07
'Wait' program that checks for a joy button press instead of 'Return' key... Heavy Stylus request.Apps 7 10 May 2009 20:01
Repairing my 'return' key mattyjim support.Hardware 8 22 February 2006 00:00

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:52.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.07275 seconds with 16 queries