English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 23 January 2021, 21:57   #1
McBierle
Registered User

 
Join Date: Sep 2019
Location: Salzgitter/Germany
Posts: 13
External Floppydisk "Problem" / Question

Hello, I have an external Floppydrive for an Amiga 500. It is working; the mainparts are in the pictures. Now i wanted to connect another drive to it instead of the drive seen in the pics. I modified three different drives as described on the net (The usual changing to RDY, getting DC on pin 2 and setting to DS0). Non are working, either the drive is not recognized or i get "df1:bad"...
Attached Thumbnails
Click image for larger version

Name:	IMG_20210123_115756.jpg
Views:	40
Size:	293.1 KB
ID:	70550   Click image for larger version

Name:	IMG_20210123_115801.jpg
Views:	38
Size:	265.9 KB
ID:	70551   Click image for larger version

Name:	IMG_20210123_115820.jpg
Views:	35
Size:	343.9 KB
ID:	70552  
McBierle is offline  
Old 24 January 2021, 06:56   #2
torsti76
Registered User

 
Join Date: May 2018
Location: Germany, Baden-Wuerttemberg
Posts: 329
My guess is that you jumpered/modified your replacement drives as S1 (i.e. DF1, right?

For this kind of external drives, however, it must be set as S0 usually. The little PCB in the external box then presents the drive as "DF1:" to the Amiga, or as DF2: ... DF3: if the drive is further down the daisy chain.

EDIT: Sorry, just read that you mentioned setting it to S0.
However, you don't need to change the drive to produce /Ready. The signal is generated by the flipflop circuit on the little PCB. But I can't see why the usual Amiga mod shouldn't work, anyway. Maybe it's the circuitry of the external case that's damaged.
Do you happen to have tried the original drive from the external box as DF0 inside your Amiga?

Last edited by torsti76; 24 January 2021 at 07:04.
torsti76 is offline  
Old 24 January 2021, 13:04   #3
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,480
Do the modified drives work on the internal floppy port as DF0?

If they do then they should work in the external drive.

If they don't, then this is what you need to get working first.

You can use Amiga Test Kit to rest the floppy drive signals to help you troubleshoot why the drive is not working (as DF0).
solarmon is offline  
Old 24 January 2021, 13:17   #4
McBierle
Registered User

 
Join Date: Sep 2019
Location: Salzgitter/Germany
Posts: 13
Thanks for the answers. Fresh day and i tried some stuff.
I tried all drives as internal and as external. While doing that i found that one drive was dead and i forgot a jumperbridge on another (mitsumi D359T5)


Results:
Chinon FB-354, the "original" internal drive: only internal
Matsushita JU-255, the original external one: internal and external
Mitsumi D359T5: internal and external (the one with the forgotten solderbridge )
Chinon FZ-357: only internal
Mitsumi D359T3: defective


So i have what i want, two working as external. But i wonder why the other only work as internal...


Greetings...
McBierle is offline  
Old 24 January 2021, 13:30   #5
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,480
The Chinon FB-354 drive will probably require 12V, so if the external adapter doesn't supply 12v then it won't work. This applies to any drive that requires 12v too
solarmon is offline  
Old 24 January 2021, 14:37   #6
McBierle
Registered User

 
Join Date: Sep 2019
Location: Salzgitter/Germany
Posts: 13
Ah well, next time i open it up i will take another look.

Followup question:
If i want to use both external drives, i asume it is not as simple as connecting it directly to the daisychain port?
Do i have to recreate the circuit with both DM7438N and SN74LS74AN?

Greetings
McBierle is offline  
Old 24 January 2021, 14:46   #7
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,480
If the external adapter/enclosure has a dasiy-chain passthrough port, then you can just connect another external adapter/enclosure to it. See my diagram at:

https://sites.google.com/one-n.co.uk...py-disk-drives
solarmon is offline  
Old 24 January 2021, 14:58   #8
McBierle
Registered User

 
Join Date: Sep 2019
Location: Salzgitter/Germany
Posts: 13
Ah thats nice, thank you very much. I'll try that, if it works i will put a "solarmon" sticker on my dual enclosure...
McBierle is offline  
Old 05 March 2021, 22:46   #9
McBierle
Registered User

 
Join Date: Sep 2019
Location: Salzgitter/Germany
Posts: 13
So i'm back. I don't know if i misudnerstood you or not, but anyways it is working. I designed/replicated the circuit from that board and made it usable for two drives. As you can see i have still to make it tidy inside and i have to do something about the unused stuff on the back, but it works. And as promised, your kudos... (hope it's ok)


Greetings
Attached Thumbnails
Click image for larger version

Name:	IMG_20210305_191049.jpg
Views:	22
Size:	810.9 KB
ID:	71169   Click image for larger version

Name:	IMG_20210305_220112.jpg
Views:	23
Size:	819.8 KB
ID:	71170   Click image for larger version

Name:	IMG_20210305_221849.jpg
Views:	22
Size:	543.9 KB
ID:	71171   Click image for larger version

Name:	IMG_20210305_222917.jpg
Views:	19
Size:	253.1 KB
ID:	71172   Click image for larger version

Name:	IMG_20210305_222931.jpg
Views:	17
Size:	201.1 KB
ID:	71173  

Click image for larger version

Name:	IMG_20210305_133418.jpg
Views:	17
Size:	358.0 KB
ID:	71174  
McBierle is offline  
Old 06 March 2021, 00:33   #10
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,480
LOL! I'm flattered to see my name and avatar on your drive. But I only gave you some support and it looks like you put in a lot of effort to make the drive.

I do like it when people go to the extra effort of making their own thing. Top job!

I would be interested in seeing the schematics for your board. Are you planning on making that publically available?

What software did you use to design the board? I have recently started learning to use KiCAD.
solarmon is offline  
Old 12 March 2021, 21:33   #11
McBierle
Registered User

 
Join Date: Sep 2019
Location: Salzgitter/Germany
Posts: 13
As i actually just remade the circuits from the original and doubled them i would certainly give any files away, well except my Logo .

I made an error with the amiga-in connector.
The original connector is:

1 ---- 12
13 ---- 24

Which i got confused:

12 ---- 1
13 ---- 24

I ended changing the original plug.

And as you maybe can see the Floppy_B connector is mirrored not just turned 180 degrees. It was just easier to get the needed connections this way. But you can't just connect it to a secopnd drive the normal way.


I used fritzing. Not the most professional tool, but i'm no professional . I already made some pcbs using fritzing and it suits my needs and knowledge (which is not that great electrostuffwise).


As three pcbs did cost me the same as one, i have two spare ones. If anyone wants one i would give them away just for postage fees (from germany).

greetings

p.s.: Aaaaand don't get confused with the IC labels. Fritzing doesn't know the "DM7438" or "74LS74N" so i just used a random dip14 IC...
Attached Thumbnails
Click image for larger version

Name:	1.PNG
Views:	15
Size:	362.9 KB
ID:	71255   Click image for larger version

Name:	2.PNG
Views:	15
Size:	298.5 KB
ID:	71256  
McBierle is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
"Diabolik" & "Dylan Dog" & "Tex" & "Time Runners" series DamienD request.Old Rare Games 14 07 February 2020 16:34
"Voices8" 8 Channel Soundtracker "DemoSongI" song - "This is the Amiga with 8 Voices" DemosongIHunter request.Music 44 27 October 2019 19:04
Question on audio settings: Should I use UAE "sinc" or OpenAL "4-point sync" or both? Dr.Venom support.FS-UAE 3 14 September 2017 08:22
External USB 3.0 HD not mounted / "No disk in drive" GraveR support.WinUAE 3 11 November 2015 14:11
"Reminder "Lincs Amiga User Group aka "LAG" Meet Sat 5th of January 2013" rockape News 4 30 January 2013 00:06

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:56.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.11083 seconds with 16 queries