English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 01 July 2013, 05:05   #1
videofx
Registered User
 
Join Date: Jan 2013
Location: Chicago, IL USA
Posts: 582
Amiga 4000D and IDE

Does the 4000D support IDE CF and IDE CD ROM on the same cable as Master and Slave?

With the CF as master and CD as Slave I can boot WB 3.1 no problem but hdtools doesnt see the CD and ASIMCDFS doesnt see the CD either.

Is there anyway to get this to work?

Thanks!
videofx is offline  
Old 01 July 2013, 07:29   #2
mfilos
Paranoid Amigoid

mfilos's Avatar
 
Join Date: Mar 2008
Location: Athens/Greece
Age: 42
Posts: 1,577
Yeah they work just fine mate.
It all depends on the CF adapter, the CF card and the orientation on the cable.
I think I had some issues as well while putting a CF adapter, but when I changed it with an IDE2ZIF attaching an old 40GB ZIF disk it worked just fine.
In this example that worked for me I had the cable as this:

A4000 IDE Header ------- CDROM (slave) ------- HD (master)
mfilos is offline  
Old 03 July 2013, 02:41   #3
videofx
Registered User
 
Join Date: Jan 2013
Location: Chicago, IL USA
Posts: 582
Thanks for the reply. I figured out the problem. After reading a lot of Amiga technical info it boils down to this:

SCSI.DEVICE: this device driver is supplied with Workbench 3.1 and ONLY supports SCSI hard drives and SCSI CD ROM and IDE hard drive. It does NOT support IDE CD ROMs. Workbench does not come with an ATAPI device driver. So I dug out my AsimCDFS 3.9 floppy and installed the AsimCDFS ATAPI driver and now the CD ROM works

I hope this will help others!
videofx is offline  
Old 03 July 2013, 09:18   #4
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 41
Posts: 8,698
Well basically yes, but there are in fact many different scsi.devices depending on what machine/expansion card it is built for. The one in the A1200/A4000 kickstarts is actually an IDE driver, it will not support any SCSI drives.
Jope is offline  
Old 03 July 2013, 13:45   #5
Cymru
Registered User
 
Join Date: Sep 2012
Location: Dorathea/AT
Posts: 376
The Amiga IDE hardware/firmware is very basic supporting only hard drives; a second layer of software is needed to handle recognition of CDROM's, tape drives and the like (ATAPI). These programs (IDEfix and such) add in the SCSI command set for the IDE device to handle more complicated devices.
Cymru is offline  
Old 03 July 2013, 14:37   #6
mfilos
Paranoid Amigoid

mfilos's Avatar
 
Join Date: Mar 2008
Location: Athens/Greece
Age: 42
Posts: 1,577
Ah! I didn't know that.
Basically I always used an updated scsi.device alas I never had a problem with that. Thanks for the info.
mfilos is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiga 4000d mal101 support.Hardware 10 21 May 2013 07:12
Slowdown Amiga 4000D amigatv New to Emulation or Amiga scene 19 10 February 2013 09:44
FS: Amiga 4000D (1 of 2) r.cade MarketPlace 2 21 August 2012 19:35
WTB amiga 4000D bigmac MarketPlace 3 23 January 2009 00:02
Best Tracker for Amiga 4000D lopos2000 support.Apps 0 16 June 2005 12:26

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:45.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.07581 seconds with 13 queries