English Amiga Board


Go Back   English Amiga Board > Support > support.Other

 
 
Thread Tools
Old 08 August 2013, 02:55   #1
jimbob
Registered User

 
Join Date: May 2006
Location: Kilmacolm
Age: 43
Posts: 629
CF0 icon, WB2 & mount version

I was just trying to make a WB 2.05 disk that could mount a compact flash card as CF0:

Unmodified WB2.05 disk in df0:
Copied fat95 to l:
Copied compactflash.device to devs:
Copied cf0 icon to df0:

Move disk to A600 with KS37.300, boot. Double click the CF0 icon and it crashes, suspend or reboot then a red guru.

Next, I copied the contents of the CF0 file into the mountlist adding the lines

cf0:

and

#

at the beginning and end of the section.

Now I can use "mount cf0:" in a shell and it works fine. Great but I want the icon to work so I copy the mount command from WB3.1 to C: calling it mount3 and change the default tool of CF0 to mount3 instead of mount. Double clicking the icon now works.

I'm wondering though, does the 2.05 version of mount, (37.2), just not support the icon method of mounting devices and will using the 3.1 version, (40.4), cause any trouble on KS2?
jimbob is offline  
Old 08 August 2013, 10:03   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 6,244
Quote:
Originally Posted by jimbob View Post
I'm wondering though, does the 2.05 version of mount, (37.2), just not support the icon method of mounting devices
Yes. This method of mounting was invented with WB 2.1.



Quote:
and will using the 3.1 version, (40.4), cause any trouble on KS2?
I don't think so. There were not many changes in the DOS area between 2.x and 3.x.
thomas is offline  
Old 08 August 2013, 23:05   #3
jimbob
Registered User

 
Join Date: May 2006
Location: Kilmacolm
Age: 43
Posts: 629
Thanks Thomas, that's good enough for me. Haven't had any apparent trouble with the way the drive is mounted. Run programs from CF, read write files, create and write back adfs.
jimbob is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
PNG Icon to Color Icon Converter? Leandro Jardim request.Apps 1 24 May 2010 04:39
DH1 & 2 Won't Mount in 3.9 on A2000 Info-Seeker support.Hardware 6 13 April 2010 04:11
What's the latest version of icon.library for OS3.9? NovaCoder support.Apps 3 30 June 2009 15:43
How can I change the default CF0: icon? keropi support.Apps 3 21 March 2008 11:53
No CD Icon & cannot Eject CD. monk support.Hardware 2 02 June 2006 00:16

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:38.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.08242 seconds with 15 queries