English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 08 June 2021, 13:39   #181
Decker
Registered User
Decker's Avatar
 
Join Date: Mar 2011
Location: Finland
Posts: 120
Quote:
Originally Posted by tero View Post
renderlib v40 was the culprit. with renderlib v32 everything works again.
I think that did it. I now have iGame2 running with no tooltype or setting to disable guigfx. No errors, launches just fine.
Decker is offline  
Old 08 June 2021, 14:05   #182
walkero
Registered User

walkero's Avatar
 
Join Date: May 2012
Location: Dublin/Ireland
Posts: 103
So the problem is renderlib version. Hmm... I wonder if we should have a check in place.
walkero is offline  
Old 08 June 2021, 14:24   #183
Decker
Registered User
Decker's Avatar
 
Join Date: Mar 2011
Location: Finland
Posts: 120
Quote:
Originally Posted by vulture View Post
Maybe check if some dithering options are enabled for the datatype?
The IGAME.IFF screenshots open in iGame 1.6a and MultiView without dithering. That said, when reading my ILBM datatype in hex, there is a string reading 'ILBMDTHD'.

Tried Henryk Richter's ILBM DT 47.3, which didn't do anything for iGame, but broke the fancy Copper-Daemon in MagicWB
Decker is offline  
Old 08 June 2021, 18:35   #184
vulture
Registered User
 
Join Date: Oct 2007
Location: Athens , Greece
Posts: 1,279
oh I see, then it could be how render.library is configured to display the images.
vulture is offline  
Old 08 June 2021, 19:38   #185
Decker
Registered User
Decker's Avatar
 
Join Date: Mar 2011
Location: Finland
Posts: 120
Quote:
Originally Posted by vulture View Post
oh I see, then it could be how render.library is configured to display the images.
Holy Hell. Based on that I:

1. Tried Muller's renderlib from Aminet (dev/misc/renderlib.lha)
2. Got the error 'Cannot open guigfx blabla'.
3. Once again I disabled Guigfx.

Now the screenshots look fine. No Dithering. Even when I switch back to my previous render library, it doesn't matter.

I'm glad, but honestly can't tell why it works.
Decker is offline  
Old 08 June 2021, 23:37   #186
vulture
Registered User
 
Join Date: Oct 2007
Location: Athens , Greece
Posts: 1,279
strange, maybe walkero can work it out
vulture is offline  
Old 09 June 2021, 00:54   #187
coldacid
WinUAE 1200/40, V4SA
coldacid's Avatar
 
Join Date: Apr 2020
Location: Candinavia
Posts: 271
Quote:
Originally Posted by Decker View Post
Holy Hell. Based on that I:

1. Tried Muller's renderlib from Aminet (dev/misc/renderlib.lha)
2. Got the error 'Cannot open guigfx blabla'.
3. Once again I disabled Guigfx.

Now the screenshots look fine. No Dithering. Even when I switch back to my previous render library, it doesn't matter.

I'm glad, but honestly can't tell why it works.

Both renderlib v32 and v40 are by Timm Müller. It sounds like v40 doesn't do the dithering though? Could you just confirm for us which version you have on your system now? Thanks.
coldacid is offline  
Old 09 June 2021, 08:49   #188
Decker
Registered User
Decker's Avatar
 
Join Date: Mar 2011
Location: Finland
Posts: 120
render.library 32.0 (27-Jun-2017)
Decker is offline  
Old 09 June 2021, 09:34   #189
Lisko
Registered User

 
Join Date: Mar 2021
Location: Avellino, Italy
Posts: 91
Quote:
Originally Posted by walkero View Post
At the latest iGame versions we had some changes to load as an image the icon of the slave, in case a screenshot is not available. Maybe that changed the way the screenshot gets the dithering. I will check again that code and come back to you if there is anything I could do.
Hi is this something that has to be enabled?
I have latest stable version of iGame and if there is no screenshot for a game only the standard iGame image placeholder gets displayed. Am I missing something?
Lisko is offline  
Old 09 June 2021, 19:23   #190
coldacid
WinUAE 1200/40, V4SA
coldacid's Avatar
 
Join Date: Apr 2020
Location: Candinavia
Posts: 271
Quote:
Originally Posted by Lisko View Post
Hi is this something that has to be enabled?
I have latest stable version of iGame and if there is no screenshot for a game only the standard iGame image placeholder gets displayed. Am I missing something?

If you're running the latest stable (2.0) then the iGame placeholder should only be used if igame.iff doesn't exist in the game directory and iGame can't load the icon image for some reason. The icon file needs to match the executable or slave filename (i.e. gameexe and gameexe.info, or game.slave and game.info) for iGame to recognize it.


I would advise double-checking the file listings for the drawers your games are in. If the icon files are properly named, or there's an igame.iff file that isn't being picked up, then my next suggestion is check if you have any issues with your datatypes.
coldacid is offline  
Old 12 June 2021, 12:10   #191
Lisko
Registered User

 
Join Date: Mar 2021
Location: Avellino, Italy
Posts: 91
Quote:
Originally Posted by coldacid View Post
If you're running the latest stable (2.0) then the iGame placeholder should only be used if igame.iff doesn't exist in the game directory and iGame can't load the icon image for some reason. The icon file needs to match the executable or slave filename (i.e. gameexe and gameexe.info, or game.slave and game.info) for iGame to recognize it.


I would advise double-checking the file listings for the drawers your games are in. If the icon files are properly named, or there's an igame.iff file that isn't being picked up, then my next suggestion is check if you have any issues with your datatypes.
Maybe was really a problem with the datatypes because after upgrading my amigaos installation from 3.9 to 3.2 the icons started to show up in iGame
Lisko is offline  
Old 12 June 2021, 12:52   #192
walkero
Registered User

walkero's Avatar
 
Join Date: May 2012
Location: Dublin/Ireland
Posts: 103
@Lisko
Yeah, iGame requires datatypes to load the images for sure.
walkero is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
X-bEnCH - The Amiga Game Launcher (Whdload, exe, ..) and more official topic. JimNeray Amiga scene 562 29 May 2021 00:07
latest dev build of fs-uae launcher .cue woes ARTHUR071169 support.FS-UAE 2 22 March 2016 09:01
iGame - MUI based game loader on Aminet Peter Amiga scene 89 06 February 2016 12:05
Best WHDLoad launcher / latest version of iGame? Decker support.Games 2 23 July 2015 21:49
iGame 4.3" LCD Portable Game Console Anemos Retrogaming General Discussion 22 23 November 2012 11:14

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:24.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.09784 seconds with 16 queries