English Amiga Board


Go Back   English Amiga Board > Support > support.OtherUAE

 
 
Thread Tools
Old 23 April 2021, 16:38   #1
acidbottle
Registered User

acidbottle's Avatar
 
Join Date: Jul 2018
Location: Scotland
Posts: 499
Amiberry and controllers

Need some help from some bright spark here!

Have used Amibian and Amiberry, also Amikit and Amiberry, latest version 4.1.2 I think.

Have very unsucessfully tried to get 2 USB controllers working, both Monster Joystick 9 pin adapter and X-arcade stick, via USB.

When I installed both distros I managed to get the MJ adapter working just fine. I updated the controller datatbase and paths and now neither distro can find anything.

Have been on Amikit support, Jan is pretty helpful, but really this is not an Amikit issue I believe.

I suppose I could throw usb controllers and adapters at the thing until one sticks but really I need to know what I need to add in the controller configs to get this thing working, idreally the MJ adapater. I am pretty sure an old version of Amiberry was working but later versions seems broken? PI emulation is a bit rubbish without a controller!

Thank you
acidbottle is offline  
Old 23 April 2021, 19:56   #2
Hungry Horace
Wipe-Out Enthusiast

Hungry Horace's Avatar
 
Join Date: Nov 2005
Location: .
Age: 41
Posts: 2,528
I'm not sure i understand what the problem is - is it just not mapped correctly, or does the device not show up in the menu at all?

Amiberry will show any connected SDL device so if its not there at all, its the OS at fault. Do the controlers show using the joystick tests on command line?

there's quite a bit on the wiki about controller setups : https://github.com/midwan/amiberry/wiki


The latest amiberry does try to do some auto-configuration of the buttons, but even when that doesnt work correctly, the F12 menu should still show the device(s)

You might need to post some screenshots
Hungry Horace is offline  
Old 23 April 2021, 21:19   #3
acidbottle
Registered User

acidbottle's Avatar
 
Join Date: Jul 2018
Location: Scotland
Posts: 499
Thanks Horace for stepping in.

Basically I have tried the adapter in 2 distros, Amibian and Amikit.

The device does not show up in the input menu at all. With Amikit distro I do see configs for Keyboard, Keyrah and Retroarch, by default, but no MJ adapter.

When i first ran Amiberry through Amibian, the device did show under input menu as "MONSTER JOY" or something. I updated Amiberry to the latest version (both distros) and updated the control database and it has vanished entirely from the input menu.

The control config file does list 100s of various devices but not the ones I have.
acidbottle is offline  
Old 23 April 2021, 22:55   #4
Hungry Horace
Wipe-Out Enthusiast

Hungry Horace's Avatar
 
Join Date: Nov 2005
Location: .
Age: 41
Posts: 2,528
No worries.

I'd try this first:
https://recalbox.gitbook.io/document...ck-with-jstest

check what js* devices are shown and see if they are showing up from jstest /dev/input/js0 for example

The devices you are seeing at the moment are effectively 'virtual' devices created from keyboard controls.

I assume the MJ adaptor is a standard USB device?

It might be worth downloading say Amibery 3.x and seeing if it works on there. I know there were some changes, but it should only be around mapping of devices once seen, and shouldnt prevent the connected ones appearing.

Last edited by Hungry Horace; 23 April 2021 at 23:02.
Hungry Horace is offline  
Old 24 April 2021, 16:58   #5
acidbottle
Registered User

acidbottle's Avatar
 
Join Date: Jul 2018
Location: Scotland
Posts: 499
Okies well good news.

I firstly rolled back to Amiberry 4.0, the version i think was default with Amikit Pi on launch. I also swapped the USB cable, even though the MJ one was brand new.

I dont know what changed but it now shows again, though under "ONYXSOFT" or something similar. Not going to touch another thing from here!

Cheers for the reples.
acidbottle is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amibian/amiberry on Raspberry Pi 1 Overmann support.OtherUAE 20 01 March 2020 19:27
Amiberry 3.0 very slow endre1952 support.OtherUAE 6 26 November 2019 19:29
Amiberry Expectations MartinW support.OtherUAE 11 05 March 2019 13:30
Custom controls on Amiberry?? Akira support.OtherUAE 29 09 November 2018 18:49
Autofire in uae4arm/Amiberry cakeisaliegamin support.OtherUAE 5 02 June 2018 13:16

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:26.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.11718 seconds with 13 queries