English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 21 July 2019, 04:31   #1
Zxspectrum16k
Registered User

 
Join Date: Feb 2019
Location: Lower Hutt
Posts: 5
Amiga 600 PSU -12v line is oscillating between -1.5v and -0.5v

I've tested each Pin on the power connector of my 600s PSU, they all seem ok except for the -12v pin which is oscillating between ~-1.5v and -0.5v g0ing from -1.5v to -0.5v and back to -1.5v in around 1 second.

Visual inspection of the PSU components doesn't show any obvious problems with any components.

Any thoughts on what the issue might be, where to start looking?

PSU is a 391 029-05 (possibly an Australasian revision?) with the "391 029-03 rev A" looking to be the closest match.

Last edited by Zxspectrum16k; 21 July 2019 at 05:21. Reason: updated with PSU revision info
Zxspectrum16k is offline  
Old 21 July 2019, 06:13   #2
whitegiant89
Lone CBM user

whitegiant89's Avatar
 
Join Date: Mar 2007
Location: Atherton / Australia
Age: 50
Posts: 148
Send a message via MSN to whitegiant89
Having pulled my 3 a500 psu's apart after sitting for 20 years, i found quite a few
capictors had leaked. they looked perfect on the top but had bulged and leaked from the bottom. I just Finished recapping the and they are putting out the right voltage now.
whitegiant89 is offline  
Old 21 July 2019, 06:47   #3
Zxspectrum16k
Registered User

 
Join Date: Feb 2019
Location: Lower Hutt
Posts: 5
Thanks, good call. I'll look at recapping for sure then. Just to be certain the caps are good going forward
Zxspectrum16k is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
PSU -12V rail fried, easy fix? LittleAnimal255 support.Hardware 16 26 March 2019 13:31
-12v line Sim085 support.Hardware 5 20 October 2017 17:02
Developing a new A500/1200/600 power supply. -12V needed? Mounty Retrogaming General Discussion 114 03 August 2016 17:16
Low -12V on A1200 PSU.. jbenam support.Hardware 5 05 October 2009 22:10
Small fanless PSU with +5V 2.5A, +12V 1.0A, -12V 0.1A? Photon support.Hardware 7 22 October 2008 18:25

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:11.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.06128 seconds with 13 queries