English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 30 September 2009, 23:32   #1
shortwind
 
Posts: n/a
NetBSD 5.0

Trying to install NetBSD 5.0 in WinUAE. I've gotten to the boot screen, the installation starts to boot, then it just freezes at the line:

"qn0 at zbus0 pa 0xe90000 man/pro 2011/2"

Any ideas on what I could be doing wrong?

Thanks in advance,
Shortwind

WinUAE 2.0.0.b16 - config and bootlog attached.

Last edited by shortwind; 03 October 2009 at 14:49.
 
Old 01 October 2009, 10:41   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,084
Do not use "UAE" harddrive controller. All non-AmigaOS operating systems require hardware emulated harddrives (IDE emulation is most compatible, SCSI isn't compatible enough yet)

(this may not fix the problem but at least your attached config can never boot)

Last edited by Toni Wilen; 01 October 2009 at 11:41.
Toni Wilen is online now  
Old 02 October 2009, 19:38   #3
shortwind
 
Posts: n/a
NetBSD 5.0 Update

Toni, my configuration I sent as an example did boot, it just never made it past that one line.

I changed to IDE, and now it gets farther in the boot process. I've made it into the main miniroot.fs configuration questions. It asks for the root drive, etc. But as soon as it tries to write to /sbin/init is displays a error and reboots the machine. It goes way to fast to see what the error is.

I'll do more research because this is probably not a EMU error, but a error with my setup. I wish someone else here (linux guru) would play with this and see if it is just me, or something with the emu..... sorry I can't tell you much more now....

Thanks for the response, I'm at least getting into the setup sequence now.

I don't have access to a real Amiga with a MMU, so I can't see if what's suppose to happen in a real setup, sorry.

Laters,
Shortwind
 
Old 02 October 2009, 21:09   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,084
You can move "fps.adj" in display panel to slow down the emulation.

Where can I download ready to use netbsd images? (preparing hardfiles etc is so boring..)
Toni Wilen is online now  
Old 02 October 2009, 21:53   #5
squidbass
Registered User
squidbass's Avatar
 
Join Date: Sep 2007
Location: Southport The Last Resort
Posts: 195
I'm about to pluck up the courage and try and install netbsd 5 on my amiga 1200/40MMU...is it actually possible to install netbsd/linux in winuae? I thought it didn't emulate MMUs? Let me know how you get on - as I will ...
squidbass is offline  
Old 02 October 2009, 21:59   #6
gilgamesh
Linux snob

gilgamesh's Avatar
 
Join Date: Sep 2008
Location: Monkey Island
Posts: 997
MMU support (really!)

In short: MMU works quite well, Linux just to a certain degree yet.

I'd be interested in a step by step explanation of what shortwind did, too.
gilgamesh is offline  
Old 03 October 2009, 14:53   #7
shortwind
 
Posts: n/a
How I "tried" to Install NetBSD 5.0.1

Well, here is a quicky intro to how I tried to get this project going:

1. Downloaded the latest .iso from http://ftp.netbsd.org/pub/NetBSD/iso/5.0.1/

2. Extracted the .iso to a directory on my hard drive.

3. Next I had to setup a .hdf for the netbsd installation. Used basic IDE0 RDB, then boot into WB 3.1 and use HDTools partition into the three primary partitions as stated in the installation guide from the .iso.

4. Ran xstreamtodev to move the miniroot.fs file to the "swap" partition on the netbsd.hdf as instructed.

5. Exit emulation, remove the standard WB 3.1 hdf. Reboot.

6. Emulation starts in the NetBSD installation.

Hmm. It will not let me attach the netbsd.rar file. It's only 2.14meg, but says it's too big.... will have to find somewhere to put it so you can download this file.

(P.S. Going to download some older versions and see if I can get any further in the installation.)

Laters,
Shortwind
 
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
NetBSD/Amiga gibs New to Emulation or Amiga scene 95 13 May 2020 18:44
NetBSD 6.0 released! strim News 2 19 October 2012 02:44
NetBSD 68k megabyte support.Apps 1 27 June 2012 13:30
WinUAE 2.3.0 + NetBSD 5.0.2 No go. ahhyes support.WinUAE 71 15 November 2010 10:29
NetBSD/Amiga ?? Highlander support.WinUAE 10 14 January 2005 16:24

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:13.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.07408 seconds with 13 queries