English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 02 July 2022, 09:50   #1
DetFedeSvin
Registered User

 
Join Date: Jun 2022
Location: Denmark
Posts: 3
Amiga 500 yellow screen

I have an Amiga 500, Rev 6A, with yellow screen. I have tested all the custom chips, the CPU, u10, u11, u12, u13, u34, 35, and the ram chips in another A500 where they are working without any issues. Furthermore, I have swapped the custom chips’ single sided sockets for machined sockets. All the CPU’s lines is checked.

When removing a ram chip, the screen changes to green.


When swapping the Kickstart rom to DiagROM, the check halts when checking the raster.


DiagROM serial output:


Amiga DiagROM V1.2 - 13-Aug-19 - By John (Chucky/The Gang) Hertell


Testing if serial loopbackadapter is installed: <> NOT DETECTED
- Parallel Code $ff - Start of ROM, CPU Seems somewhat alive
Checking status of mousebuttons for different startups:

Set all Interrupt enablebits (INTENA $dff09a) to Disabled: Done
Set all Interrupt requestbits (INTREQ $dff09c) to Disabled: Done
Set all DMA enablebits (DMACON $dff096) to Disabled: Done

Testing if OVL is working: OK
- Parallel Code $fe - Test UDS/LDS line
- Test of writing word $FFFF to $400 OK
- Test of writing word $00FF to $400 OK
- Test of writing word $FF00 to $400 OK
- Test of writing word $0000 to $400 OK
- Test of writing byte (even) $ff to $400 OK
- Test of writing byte (odd) $ff to $401 OK
- Parallel Code $fd - Start of chipmemdetection

Addr $00080400 OK Number of 32K blocks found: $10
Chipmem Shadowram detected, guess there is no more chipmem, stopping here

Startaddr: $00000400 Endaddr: $0007FFFF
- Fastmemcheck skipped as we found chipmem
- Parallel Code $fb - Memorydetection done

Using $0006CCEC as start of workmem (Base)

- Parallel Code $fa - Starting to use detected memory

Testing if serial loopbackadapter is installed: <> NOT DETECTED
Detecting if we have a working raster: rr11m 2;11H?? 2;11H





Any ideas on where to look next?
DetFedeSvin is offline  
Old 03 July 2022, 17:49   #2
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 1,183
Adrian's Digital Basement released this video recently.

Green screen, but similar problems. DiagROM passed the memory test but failed on the working raster check.

It turned out to be the RAM.

[ Show youtube player ]
nogginthenog is offline  
Old 05 July 2022, 19:17   #3
DetFedeSvin
Registered User

 
Join Date: Jun 2022
Location: Denmark
Posts: 3
Could be the ram, however I have checked all the custom and ram chips in another Amiga. Where they are working. Can it be a passive component?
DetFedeSvin is offline  
Old 05 July 2022, 21:26   #4
PascalDe73
PascalDe73

PascalDe73's Avatar
 
Join Date: Apr 2019
Location: Charleroi Belgium
Age: 49
Posts: 26
Yellow Screen can be Keyboard Problem about PCB on the A500 Keyboard. and or Memory expansion

Remove You Keyboard and try it again.

It can be addition memory card too ... remove it too and retry.

otherwise read this too :

https://ia601207.us.archive.org/33/i...le-shooter.pdf

Last edited by PascalDe73; 05 July 2022 at 21:38.
PascalDe73 is offline  
Old 06 July 2022, 21:05   #5
DetFedeSvin
Registered User

 
Join Date: Jun 2022
Location: Denmark
Posts: 3
Unfortunately the there are no change if a keyboard or a memory expansion are connected/removed.
DetFedeSvin is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiga 600 yellow screen caver99 support.Hardware 5 03 June 2022 18:26
Amiga A600 yellow screen badbat support.Hardware 1 01 April 2022 19:36
Yellow Screen Amiga 500 with +512kb Abelardator2 Hardware mods 19 25 June 2013 21:25
Problem with my Amiga 500 (Yellow Screen, Reboot) souls support.Hardware 4 14 January 2012 14:11
Amiga 600 not booting... Yellow screen, and Red screen when turning PSU off jbenam support.Hardware 34 20 March 2011 22:10

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:31.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.07073 seconds with 15 queries