English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 05 December 2013, 13:24   #1
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 3,188
Strange CPU usage under Wine

This kind of follows on from a posting in the WinUAE 2.7 beta thread.

I noticed something strange with WinUAE CPU usage testing under Wine/Linux (with Nvidia binary driver). Can any other Wine users reproduce this?

With native chipset modes and D3D, triple buffering, no scaling, no vsync, CPU usage is inversely proportional to window size! The larger the window, the lower the CPU usage. Which seems very strange. With no buffering or double buffering however, CPU usage is proportional to window size.

With DirectDraw on the other hand, CPU usage is proportional to window size.

I tested various settings, using the "top" command in Linux to see the CPU usage of the WinUAE process.

Native chipset (PAL 640x560 Workbench), Direct3D, triple buffering, null filter, no scaling
Window a little larger than the Workbench screen: 71-72% CPU
Window maximised: 34% CPU

With DirectDraw the opposite is true, e.g. 73-74% with smaller window vs 91% CPU with window maximised.

RTG modes are different. With uaegfx:

uaegfx 640x480 (window a little larger), D3D, triple buffering: 69% CPU
With maximised window: 76-77% CPU
1024x768 Workbench with maximised window: 77-79% CPU
1024x768 Workbench, DirectDraw, maximised window: 69% CPU
640x480 WB, DirectDraw, smaller window: 69% CPU

Finally Cirrus RTG (Piccolo):
DirectDraw, 640x480 WB and small or maximised window, and 1024x768 WB with maximised window: all 69% CPU
D3D 1024x768 WB, maximised window: 89% CPU. Same WB with window a little larger than the WB screen: 81% CPU.
Same window size but 640x480 Workbench: 80% CPU
640x480 WB with similar window size: 70% CPU
mark_k is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is this Normal cpu usage? exoticaga support.WinUAE 6 18 February 2008 09:22
Heavy cpu usage - again abelthorne support.WinUAE 5 03 March 2004 11:32
WinUAE high CPU usage DeCreator support.WinUAE 2 17 July 2003 02:12
WinUAE CPU usage at 100% argh wakeupbomb support.WinUAE 4 23 January 2003 09:27

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:52.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.06185 seconds with 15 queries