English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 28 December 2020, 10:52   #1
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
OS 4.1FE and Classic 4.1.6 Voodoo 3 Warp3D test

I hope this topic is allowed because many applications work with voodoo3 and maybe it is worth continuing with the tests.
I would like to insert the applications and games that work to improve any support for the 4.1 version of amiga also with any external or internal corrections to winuae.

I also remember that many of these tests can be done with 4.1.6 Classic

-wipeout 2097 works perfect in window
[ Show youtube player ]
White is offline  
Old 28 December 2020, 12:01   #2
dreadnought
Registered User
 
Join Date: Dec 2019
Location: Ur, Atlantis
Posts: 852
It seems a bit slow? The original runs at 60 fps. 30 fps, but seems much faster.

Last edited by dreadnought; 28 December 2020 at 12:25. Reason: factual correction
dreadnought is offline  
Old 28 December 2020, 12:21   #3
Mad-Matt
Longplayer

Mad-Matt's Avatar
 
Join Date: Jan 2005
Location: Lincoln / UK
Age: 41
Posts: 1,796
Send a message via ICQ to Mad-Matt Send a message via MSN to Mad-Matt
It plays just like on original Amiga hardware so in that sense it is mission accomplished. Well.... once integration with aos3 is fully operational anyway.

[ Show youtube player ]
Mad-Matt is offline  
Old 28 December 2020, 12:29   #4
andyhants
Registered User

 
Join Date: Nov 2013
Location: Hampshire England
Posts: 148
So from what you guys are showing here - am I right in understanding that WipeOut 2097 could only run in a Window under native OS4.1 & not full-screen?
andyhants is offline  
Old 28 December 2020, 12:31   #5
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
@Mad-Matt
Thanks for your video
i hope other users test warp3d with 4.1 the aim is to have more people doing the tests

@dreadnought
30fps is fine too :-)
White is offline  
Old 28 December 2020, 12:32   #6
Mad-Matt
Longplayer

Mad-Matt's Avatar
 
Join Date: Jan 2005
Location: Lincoln / UK
Age: 41
Posts: 1,796
Send a message via ICQ to Mad-Matt Send a message via MSN to Mad-Matt
@andyhants 640x480 has a refresh issue but fullscreen 800x600 1024x768 is fine but the game gets a little slower the higher you go. It was easier to record in a window without having to mess with upscaling for youtube.
Mad-Matt is offline  
Old 28 December 2020, 12:44   #7
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
-PayBack works but has slowdowns apparently it seems in reading data or something like that I still haven't understood
[ Show youtube player ]
White is offline  
Old 28 December 2020, 12:56   #8
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
there is an underlying problem from how I was suggested the "GURUMEDITATION" or the DSI which is the underlying problem of why Warp3D does not work well with 4.1 when starting the "applications-games" if it were solved it would work much better and as if some instructions failed
White is offline  
Old 28 December 2020, 13:06   #9
Mad-Matt
Longplayer

Mad-Matt's Avatar
 
Join Date: Jan 2005
Location: Lincoln / UK
Age: 41
Posts: 1,796
Send a message via ICQ to Mad-Matt Send a message via MSN to Mad-Matt
Payback runs way too fast in AOS4 for me. along withthe refresh issues the game textures flicker alot.
Mad-Matt is offline  
Old 28 December 2020, 13:14   #10
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
@Mad-Matt
If I remember correctly I replaced the prefs with the one present in the payback demo in the installation of the original cd and it seems to work but I did it a long time ago 'I don't remember
White is offline  
Old 28 December 2020, 13:17   #11
Seiya
Registered User

Seiya's Avatar
 
Join Date: Nov 2014
Location: Italy
Posts: 1,196
@white
but how you run voodoo3 on OS4? i tried, but it remain undetected. Do you change from Picasso IV or do you have changed one and added the other?
However i tried every config, but Voodoo3 is unknown for OS4
Seiya is offline  
Old 28 December 2020, 13:22   #12
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
@Seiya
when installing the 4.1 system simply choose voodoo

winuae PCI
and mediator 4000mk2 Full PCI DMA
also for network and audio

Last edited by White; 28 December 2020 at 13:33.
White is offline  
Old 28 December 2020, 13:50   #13
Mad-Matt
Longplayer

Mad-Matt's Avatar
 
Join Date: Jan 2005
Location: Lincoln / UK
Age: 41
Posts: 1,796
Send a message via ICQ to Mad-Matt Send a message via MSN to Mad-Matt
[ Show youtube player ]

Quick vid of payback. Wouldn't want to play it with it running like this. Runs better in AmigaOS3 with 68k Jit.
Mad-Matt is offline  
Old 28 December 2020, 14:04   #14
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
I have to reinstall it then and try again I used it just to test by reading the other posts with the tests for the cvision64

I tried just out of curiosity "spencer demo" written for "warp3d and nova" and it works but in some cases the audio stops.
Have you tried it? "OS4.1FE"
White is offline  
Old 28 December 2020, 14:05   #15
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 24,741
Looks like it simply runs as fast as possible. Could be normal behavior and some vsync/frame limiter option needs to be enabled.
Toni Wilen is offline  
Old 28 December 2020, 14:10   #16
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
I just wanted to report this using 4.1FE with "wazp3D" all these applications work the same obviously with a lower video rendering.
But the "DSI" problem always recurs the requester appears I ignore the error and then the application starts and works so I think there is something underlying that has nothing to do with Warp3D at least in part if it were solved it would be a great step for 4.1

@Toni
thank you for your suggestion
White is offline  
Old 28 December 2020, 14:32   #17
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
also works "Spencer" I forgot to allocate more memory
this is written for warp3D and Nova so I believe it is newer than QuakeGL executables etc.
[ Show youtube player ]
White is offline  
Old 28 December 2020, 15:06   #18
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
Also works Alien vs Predator (PC version)
without defects and out of parameters but this shows the emulation of the voodoo with winuae and of first quality.
There would probably be work to be done but the potential is there
[ Show youtube player ]
White is offline  
Old 29 December 2020, 09:24   #19
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
I read that there is now G-Rex + voodoo3 support in the beta of the day
I tried a clean install of 4.1 on reboot the screen stays black.
If, on the other hand, I modify an existing 4.1 installation with the "GRex" line in the startup-sequence and enable the G-Rex+Voodoo3, the boot takes place without problems and everything is recognized and works.
White is offline  
Old 29 December 2020, 12:14   #20
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,153
-DemoPPC + Voodooo Work perfect (Rewarp)
I went back to looking better Rewarp I applied the patch correctly.
Now all DemoPPC + Voodoo works perfectly
textures are applied correctly and everything works.
Even the "DSI" or "GURUMEDITATION" no longer occurs.
Gears "Warp3D" still has transparencies so Rewarp can't solve the problem of transparency in the center.
Games like quakeGL etc. they still don't work with Rewarp
"Thellier" is it possible to work on this?
Could it help Winuae in some way to apply corrections?
Can it be useful if modified in some way?
Thanks
[ Show youtube player ]
White is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Warp3D and Voodoo 3 remig support.Hardware 8 28 March 2018 17:13
Warp3D with G-Rex and Voodoo 4?? Alexco support.Other 7 16 August 2013 03:20
Does Warp3D work on a Voodoo 5 5500 Mediator PCI Setup? fitzsteve support.Apps 5 15 October 2010 01:10
Voodoo 5 Warp3D Support Hewitson support.Hardware 12 09 February 2008 15:48
Removing cyberpatcher gives +2.7 fps on warp3d gears_ppc test... keropi support.Apps 2 02 July 2006 22:08

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.13150 seconds with 14 queries