English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 21 June 2021, 14:24   #721
chip
Registered User
 
Join Date: Oct 2012
Location: Italy
Age: 46
Posts: 2,520
I got your point of view

No intention by myself to put pressure on Toni, i strongly respect his hard work

For this reason that i wrote in the beginning of my question "There's no hurry at all"
chip is offline  
Old 21 June 2021, 18:40   #722
Zarnal
Registered User

 
Join Date: Feb 2018
Location: France
Posts: 346
Quote:
Originally Posted by Zarnal View Post
There is an image shift problem with BC-Kid (at least since b17) in windowed mode (720 * 568) and without scaling ( or default ) (pic 1). Edit : Quickstart A500

No problem with WinUae 4.4 under the same conditions (pic 2).

Note : the savestate is ingame.

Edit 2 : since b1.

More information : the fullscreen mode is also affected by this problem.
Zarnal is offline  
Old 24 June 2021, 15:36   #723
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,032
Status:

I am still sort of "stuck" with programmable hsync position + bitplane overrun combination, some tests still fail to work correctly and I am not sure exactly where it goes wrong. Too many moving parts needs to work exactly right at the same time.

Nothing much happens until it gets fixed. Not much point to clean it up or optimize or fix some other chipset related bugs if there is still something important missing that needs rewrite..

Last edited by Toni Wilen; 24 June 2021 at 15:55.
Toni Wilen is offline  
Old 24 June 2021, 16:50   #724
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 45
Posts: 1,786
Thanks for status report... I'm refraining from reporting usual bugs with some games for those reasons
hexaae is offline  
Old 11 July 2021, 23:50   #725
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 50
Posts: 5,774
Toni, found an issue with latest beta. I'm pretty sure it worked and it works on a real amiga

Take Shadow Of the Beast 3, there's the number of gold bars at the bottom center of the screen (also when demo + level select is running).

In the latest beta (23) this number of gold bars doesn't appear, or only flashing briefly from time to time. Not sure when the bug came up but it's there.

here's a pic: no "00" text where I have drawn a blue circle.

Click image for larger version

Name:	ShadowOfTheBeastIII_Disk1_001.png
Views:	319
Size:	19.8 KB
ID:	72519

I have tested with original IPF (just boot disk 1, skip intro disk) & A500 cycle exact (quickstart 1MB config) and also on whdload (I though I had broken something with my latest fix but no)
jotd is offline  
Old 12 July 2021, 21:55   #726
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,032
Quote:
Originally Posted by jotd View Post
Toni, found an issue with latest beta. I'm pretty sure it worked and it works on a real amiga

Take Shadow Of the Beast 3, there's the number of gold bars at the bottom center of the screen (also when demo + level select is running).

In the latest beta (23) this number of gold bars doesn't appear, or only flashing briefly from time to time. Not sure when the bug came up but it's there.

here's a pic: no "00" text where I have drawn a blue circle.

Attachment 72519

I have tested with original IPF (just boot disk 1, skip intro disk) & A500 cycle exact (quickstart 1MB config) and also on whdload (I though I had broken something with my latest fix but no)
Thanks, fixed. Beast 3 title screen statefile is one of my compatibility test statefiles but I didn't notice that the middle "00" was missing..

btw, main problem related to weird display modes was finally solved today. Hopefully this means "normal" beta updates can restart soon..
Toni Wilen is offline  
Old 12 July 2021, 22:22   #727
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 50
Posts: 5,774
Great!!

this middle 00 is really not important in the game either so I didn't notice it until it started flashing in my tests...
jotd is offline  
Old 14 July 2021, 15:50   #728
ceztko
Registered User
 
Join Date: Aug 2006
Location: Italy
Posts: 99
Quote:
Originally Posted by Toni Wilen View Post
btw, main problem related to weird display modes was finally solved today. Hopefully this means "normal" beta updates can restart soon..
Has this been the most epic refactor ever?
ceztko is offline  
Old 18 July 2021, 14:28   #729
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,032
I am not sure about epicness because almost all changes are totally invisible, at least when running more or less normal programs. Perhaps when program(s) appear that use new previously unsupported "screen mode".
Toni Wilen is offline  
Old 18 July 2021, 20:40   #730
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,032
https://download.abime.net/winuae/fi...uae_4900b24.7z

Beta 24:

Chipset update is almost done but there is still some hopefully minor (and hopefully it stays minor) "weird screen mode" side-effects remaining..

- usegfx Picasso96 DISPLAYCHAIN is now only forced if uaegfx monitor is monitor id=0 (shared with native chipset). Previously DISPLAYCHAIN was always forced.
- uaegfx in other monitor than native: uaegfx window was tiny before it resized to selected Picasso96 resolution. Now reset default is 640x480 instead of 0x0. uaegfx window also didn't re-open after reset.
- Extra multi monitor mode window positions are now stored to registry/ini.
- Bitplane wrap around (extreme bitplane overrun condition where BPLxDAT fetches before hsync start are visible after hsync end) is now fully supported.
- Sprite fix (Shadow of the Beast 3 missing sprite)
- Adjusted extreme overscan positioning and filter (for example integer scaling) support improved.
- Two (or more) horizontal DIWSTRT/STOP regions are now supported. Previously only first region was visible.
- Programmed mode WB modes should now have 100% correct vertical and horizontal blanking. Hardwired blanking is now correct in overscan+ modes.
Toni Wilen is offline  
Old 18 July 2021, 20:45   #731
Viceroy
Registered User
 
Join Date: Jul 2006
Location: Sunderland
Posts: 856
Well done!
Viceroy is offline  
Old 18 July 2021, 21:06   #732
Zarnal
Registered User

 
Join Date: Feb 2018
Location: France
Posts: 346
Hello,

there is an right image shift problem with BC-Kid.

Quickstart A500 or A600. Since b1.

Last edited by Zarnal; 16 September 2021 at 20:15.
Zarnal is offline  
Old 18 July 2021, 23:22   #733
rutra80
Registered User

 
Join Date: Jul 2019
Location: Poland
Posts: 142
Quote:
Originally Posted by Toni Wilen View Post
Automatic resize causes window resizing loop in stock Workbench.

Also there are crashes or wrong scaling on all my P96 installs except stock OS3.2, need to investigate more for more info...

Last edited by rutra80; 18 July 2021 at 23:29.
rutra80 is offline  
Old 19 July 2021, 18:22   #734
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,032
Quote:
Originally Posted by Zarnal View Post
Hello,

there is an right image shift problem with BC-Kid.

Quickstart A500 or A600. Since b1.
Fixed (but note that vertically it isn't same as previously because it only changed between PAL/NTSC and BCKid uses weird 56Hz mode which is neither)

Quote:
Originally Posted by rutra80 View Post
Automatic resize causes window resizing loop in stock Workbench.
Fixed.

Quote:
Also there are crashes or wrong scaling on all my P96 installs except stock OS3.2, need to investigate more for more info...
If it is emulator crash, attach or email dump file (disable JIT, reduce RAM size to keep the dump file useful and not too big)
Toni Wilen is offline  
Old 20 July 2021, 19:00   #735
Viceroy
Registered User
 
Join Date: Jul 2006
Location: Sunderland
Posts: 856
Hi Toni,

Was testing out 4.9.0 beta 24 today and have come across three issues:


RTG:

Tested with some RTG games in DamienD's collection.

I tested 15 out of the 60 games that he's configured; every single one crashed / WinUAE exits completely when switching to an RTG screen.

Attached are two of the dump files created.


American Laser Games:

Tested all 4 available ALG games. The perfect gun calibration that DamienD set is no longer working, and way off.

I tried resetting up via "Calibrate Gun", had the target lined up perfectly; saved, started the game, yet the target was still way off.

Tested previous betas and this issue started at "4.9.0 Beta 22".


Sound:

The audio sometimes has slight pops, cracks etc and isn't crisp... it's noticeable in "Aladdin [AGA]" when you see the "Disney" screen and the music starts; also in "Alien Storm" at the Legend trainer screen.

Changing the buffer from "8" --> "10" helps a little bit but doesn't resolve. This started back early in the betas.

Just tested 10 x RTG games using beta 23; no issues at all.

Cheers Viceroy

Last edited by Viceroy; 20 July 2021 at 19:10.
Viceroy is offline  
Old 20 July 2021, 19:34   #736
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,032
Quote:
Originally Posted by Viceroy View Post
RTG:

Tested with some RTG games in DamienD's collection.

I tested 15 out of the 60 games that he's configured; every single one crashed / WinUAE exits completely when switching to an RTG screen.

Attached are two of the dump files created.
Unfortunately I still can't duplicate it and dump seems to point out that VRAM buffer is not as large as it is supposed to be (which won't really help).

What is mode before crash and what is new mode (that crashes)?

Log from working version would also help. Which Picasso96 version? It might be also important.

Quote:
Tested all 4 available ALG games. The perfect gun calibration that DamienD set is no longer working, and way off.
A bit annoying test case. Perhaps some other light gun game has easier to use calibration screen

Quote:
The audio sometimes has slight pops, cracks etc and isn't crisp... it's noticeable in "Aladdin [AGA]" when you see the "Disney" screen and the music starts; also in "Alien Storm" at the Legend trainer screen.
There shouldn't be any performance changes in recent version (since at least b22).

Does CPU% show larger values than previous beta?
Toni Wilen is offline  
Old 20 July 2021, 22:13   #737
rutra80
Registered User

 
Join Date: Jul 2019
Location: Poland
Posts: 142
Quote:
Originally Posted by Toni Wilen View Post
If it is emulator crash, attach or email dump file (disable JIT, reduce RAM size to keep the dump file useful and not too big)
Attached.
Attached Files
File Type: rar WinUAE.rar (48.8 KB, 37 views)
rutra80 is offline  
Old 20 July 2021, 22:44   #738
Viceroy
Registered User
 
Join Date: Jul 2006
Location: Sunderland
Posts: 856
Hi Toni Here is the requested info:

RTG:

"PAL: High Res" set for Workbench.

Any RTG display mode crashes e.g 300 x 400, 640 x 400, 640 x 480; 8 bit / 16 bit.

Even just changing from "PAL: High Res" to any RTG display mode in Prefs --> ScreenMode and immediate crash.

Picasso96; version installed is "Picasso96-2_1.e".

RTG; version installed is "rtgmaster_user V42.0".

Logs from working beta 23 and crashing beta 24 attached.


ALG:

Works fine up to beta 21. Attached are .NVR files. Try these there an no issue. Then try the exact same ones in beta 22 onwards.

You don't even need them though. Start any ALG game, press <F1>, select Gun Calibration, get everything right, shoot with Start held <F2>, then start the game. You see that what you just set isn't there and it's back at default.


Audio:

Very slight CPU increase but nothing near 100% that would cause this. This has been occurring for me most of the beta, as far back as 5.

Cheers Viceroy
Attached Files
File Type: zip ALG_nvr.zip (1.2 KB, 39 views)
File Type: rar WinUAE b23_Logs.rar (76.6 KB, 30 views)
File Type: rar WinUAE b24_Logs.rar (112.9 KB, 31 views)
Viceroy is offline  
Old 21 July 2021, 11:28   #739
goldmomo
Registered User

 
Join Date: Jul 2021
Location: Germany
Posts: 3
Hello,

I have some glitches with Beta 24 when a 68030 and MMU on or EC mode is selected (OCS, cycle exact). Problem occurs with some tests that use COPJMP1 / 2. Issue does not happen on 4.4.0 and Amiga 500 with 68030 (cannot rule out that my code is wrong).
Attached Thumbnails
Click image for larger version

Name:	68030_mmu_ec_none.PNG
Views:	85
Size:	132.5 KB
ID:	72606   Click image for larger version

Name:	68030_mmu_ec_on.PNG
Views:	94
Size:	124.7 KB
ID:	72607  
Attached Files
File Type: zip copperHV2c.zip (5.8 KB, 39 views)
goldmomo is offline  
Old 21 July 2021, 13:38   #740
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,032
Light gun shift confirmed but it is possible this is gun specific shift that was used as a default and standard guns (or at least light pens) don't have this shift. Need to test more programs..

Quote:
Originally Posted by goldmomo View Post
Hello,

I have some glitches with Beta 24 when a 68030 and MMU on or EC mode is selected (OCS, cycle exact). Problem occurs with some tests that use COPJMP1 / 2. Issue does not happen on 4.4.0 and Amiga 500 with 68030 (cannot rule out that my code is wrong).
Something similar has been reported before this beta series but I haven't managed to duplicate it. I haven't yet tested but hopefully your test case works
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 4.0.1 beta series Toni Wilen support.WinUAE 64 15 July 2018 12:03
WinUAE 3.6.1 beta series Toni Wilen support.WinUAE 166 07 March 2018 22:48
WinUAE 3.2.0 beta series Toni Wilen support.WinUAE 385 08 November 2015 23:06
WinUAE 2.5.1 beta series Toni Wilen support.WinUAE 69 22 December 2012 10:22
WinUAE 2.2.0 beta series Toni Wilen support.WinUAE 119 28 June 2010 02:35

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:23.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.12140 seconds with 14 queries