English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 10 August 2022, 23:43   #1
coriolis1986
Registered User
 
Join Date: Mar 2021
Location: Universe
Posts: 11
Merlin RTG on Amiga 2000

Hi all.

I'm trying to use Merlin RTG card on my unexpanded A2000 with AmigaOS 2.04.

I tried Merlin Install disks from here http://amiga.resource.cx/exp/merlin , but it is not working. Neither HRGPrefs, nor other applications. Only 1.36 version could start Merlin_1.29 utility from c: and after this some new videomodes showes in screenmode prefs.

May be I should buy an accellerator for A2000?

I also read that very-very old versions of Picasso96 (pre 1.17 versions) works on 2.04. Do anyone have this?
coriolis1986 is offline  
Old 12 August 2022, 05:37   #2
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 2,543
I'm not sure what you're trying to accomplish using a Merlin card on a 2.04 ROM 68000 system. Picasso96 generally requires an 020, since almost all non RTG cards are PIO, which means you're using the CPU to throw memory at them. At 7.14 MHz 680000 speeds that's basically meaning the CPU is spending all the time drawing the thing.
That being said,
Does the Merlin have all of the hardware fixes applied to it?
I have a Merlin in an A2000 and it works great. It is also a fine card in an A4000 in Z3 mode.
But you really want to run Picasso96 on it and that will require an 020. A GVP Combo 030@33Mhz is just fine for it. The more you could throw at it the better, a GVP 040 would be good too.
grelbfarlk is offline  
Old 12 August 2022, 09:52   #3
coriolis1986
Registered User
 
Join Date: Mar 2021
Location: Universe
Posts: 11
Yes, my Merlin card have all fixes on it.

Picasso96 requires Kickstart 3.1 . Only very-very old archaeological versions below 1.17 will work on 2.04, so I want to find one of them.

Now I try to use an original Merlins drivers (non-P96), and only older version 1.36 working after manual staring command from c: directory. But other Merlin applications (HRGPrefs and others) not working at all.
coriolis1986 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help for SimCity 2000 RTG Zilog support.Games 5 07 December 2018 20:20
Merlin and his Magic Jimbo Hardware pics 5 02 October 2010 23:00
FS: Merlin RTG Fieldday MarketPlace 0 01 December 2009 12:44
XPert Merlin Oscillator gwionm support.Hardware 5 14 October 2008 01:16

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:31.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.06639 seconds with 13 queries