English Amiga Board


Go Back   English Amiga Board > Coders > Coders. Language > Coders. C/C++

 
 
Thread Tools
Old 26 June 2021, 19:01   #1
Warty
Registered User

 
Join Date: Aug 2018
Location: Minneapolis, USA
Posts: 238
SnoopDOS cybergraphics.library fail messages

I was doing some detective work with SnoopDOS this morning, to see why the 3.2 NDK sample code wouldn't run when compiled by VBCC (libraries weren't autoloading), and noticed that for my app, I'm getting a failure message for every IFF I open. This is 3.2, on 3 bit depth screen.

From an appearance point of view, the code has always seemed to work: IFF files do get loaded, and I can blit them around as needed.

I think this is probably happening during a call to NewDTObject().

I'm not explicitly opening cybergraphics.library, so I guess GfxBase or DataTypesBase makes use of cybergraphics.library? What's going on here, and do I need to worry about it? Any way to prevent these fails?
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2021-06-26 wb2k cybergraphics fail.png
Views:	50
Size:	22.1 KB
ID:	72383  
Warty is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
SnoopDOS app for bsdsocket.library redblade request.Apps 3 27 June 2019 13:21
locale.library load FAIL Stuart support.Other 8 24 November 2014 18:44
cybergraphics.library v41 LuMan support.Other 5 07 December 2010 16:53
CyberGraphics 4.2 CU_AMiGA request.Other 12 07 October 2006 17:20

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:27.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.06814 seconds with 16 queries