English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 12 April 2022, 18:23   #1
nandius_c
Fernando Cabrera

 
Join Date: Oct 2013
Location: Spain
Posts: 106
Mouse and keyboard problem after version 3.2.

Hi there, I'm stuck in version 3.2. If I update to a higher version the mouse pointer, the keyboard or even both stop working after switching from WinUAE to Windows or even just a few seconds after starting the emulation (not untrapping the mouse). I've tried changing the mouse and joystick settings in WinUAE but I couldn't solve it.

I have an MSI CX61 laptop.


I attach logs for version 4.9.1.


Any ideas?

Thanks in advance.


winuaebootlog.txt

winuaelog.txt
nandius_c is offline  
Old 13 April 2022, 12:22   #2
Gilloo
Registered User
 
Join Date: Nov 2010
Location: Grenoble, Isère, Rhône-Alpes, France, Europe, Earth
Posts: 228
Use WinUAE in a window, not full screen, or F12 then cancel, you will retrieve the focus, the keyboard and the mouse.
Gilloo is offline  
Old 13 April 2022, 19:56   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,364
Does same happen if you use external USB keyboard? Does it only happen in fullscreen mode?

btw, switch off DirectDraw (misc panel), it usually works very badly in Windows 8 and later. Especially in fullscreen modes.
Toni Wilen is offline  
Old 14 April 2022, 23:56   #4
nandius_c
Fernando Cabrera

 
Join Date: Oct 2013
Location: Spain
Posts: 106
I always run WinUAE in windowed mode. I tried changing DrirectDraw to Direct3D and with an external USB keyboard: no change.


Both the mouse and the keyboard stop working inside the emulated Amiga, but I can still use keys for WinUAE (re-loading state etc.).
nandius_c is offline  
Old 25 April 2022, 08:33   #5
nandius_c
Fernando Cabrera

 
Join Date: Oct 2013
Location: Spain
Posts: 106
Is there anything else I could try?
nandius_c is offline  
Old 26 April 2022, 18:41   #6
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,364
When input stops in emulated Amiga, enter GUI -> Game ports -> Test/Remap -> Test.

Does keys and mouse still respond in test mode window? (F12 to exit)
Toni Wilen is offline  
Old 27 April 2022, 12:52   #7
nandius_c
Fernando Cabrera

 
Join Date: Oct 2013
Location: Spain
Posts: 106
Yes, both mouse and keyboard work fine while in test mode.
nandius_c is offline  
Old 30 April 2022, 19:46   #8
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,364
Strange..

Ok, next test. Run winuae using command line: "winuae.exe -log -inputlog 1 -inputdevicelog 3" (use windowed mode).

Does log window still show input events when the problem happens? Or does it start only showing PC-side events and Amiga-side events stop happening?

For example:

"Amiga key 20 0" means Amiga key code 20 was pressed (0) or released (1).
"HANDLE=xxxxx CODE=xx Flags=xx.." = Windows RawInput event data.
Toni Wilen is offline  
Old 01 May 2022, 21:12   #9
nandius_c
Fernando Cabrera

 
Join Date: Oct 2013
Location: Spain
Posts: 106
All key and mouse events seem to go on after the problem happens. Find a file attached with the log. I started pressing keys just after the problem happened (no key presses before that moment).


Thanks for your help!
Attached Files
File Type: zip WinUAE.zip (12.2 KB, 9 views)
nandius_c is offline  
Old 16 May 2022, 23:41   #10
nandius_c
Fernando Cabrera

 
Join Date: Oct 2013
Location: Spain
Posts: 106
Any clues from the log attached to my last message, please?
nandius_c is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multi-Monitor and virtual mouse driver / magic mouse problem phipslk support.WinUAE 0 11 January 2022 21:33
Mouse / keyboard problems from version 3.3 and above nandius_c support.WinUAE 4 04 April 2018 17:32
Mouse click problem with cintiq companion and virtual mouse driver donmikko support.WinUAE 9 19 February 2017 11:32
A4000, mouse clicks, no mouse move, no keyboard OverDose support.Hardware 4 16 March 2011 13:25
Problem with inteference - wireless keyboard and mouse Rabbit80 support.Hardware 4 25 August 2008 01:09

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:50.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.07520 seconds with 16 queries