English Amiga Board


Go Back   English Amiga Board > Other Projects > project.WHDLoad

 
 
Thread Tools
Old 14 November 2010, 20:13   #1
Gaula92
Registered User
Gaula92's Avatar
 
Join Date: Aug 2008
Location: Spain
Posts: 467
Lemmings Whdload on P-UAE: stalls after a while

Hello there

I'm having a hard time finding out why is this happening. I'm using P-UAE (an updated version on E-UAE with the WINUAE core integrated by Gnostic) to emulate a plain 68K, KS 2.0 with ECS and IDE HD.
It works great (even perfect scroll in games thanks to my custom 50HZ 720x576 video mode for Linux), but the game stalls after playing for a while, after 5 or 6 phases...
The game music keeps playing, but the entire game freezes, except for the green cursor.

I've tried different combinations, different memory configurations, but I KNOW this game doesn't need cycle-exact cpu or blitter to work right.
It happens with both WHDLOAD versions: 1 Disk and 2 Disk versions behave the same.
I'm using latest P-UAE code from github. Not JIT or anything (plain 68K emulation as said).

People at a.org says it's a "know issue", but this Whdload Lemmings has been around since 2001, so I really doubt it. I'm using the ECS version 1.4 WHDLOAD install with latest registered WHDLOAD.
Gaula92 is offline  
Old 14 November 2010, 23:00   #2
dlfrsilver
CaptainM68K-SPS France
dlfrsilver's Avatar
 
Join Date: Dec 2004
Location: Melun nearby Paris/France
Age: 44
Posts: 9,081
Send a message via MSN to dlfrsilver
copylock problem AFAIK...
dlfrsilver is offline  
Old 14 November 2010, 23:12   #3
Gaula92
Registered User
Gaula92's Avatar
 
Join Date: Aug 2008
Location: Spain
Posts: 467
So.. what about the CDTV version? It can't feature copylock
Gaula92 is offline  
Old 14 November 2010, 23:23   #4
TCD
Registered User

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 43
Posts: 24,024
Have you tried it on a real Amiga or WinUAE? Can well be just a P-Uae issue.
TCD is offline  
Old 14 November 2010, 23:34   #5
KevG
Banned
 
Join Date: Jan 2009
Location: U.K.
Posts: 93
It happens on a real Amiga too. The mouse pointer stops and everything locks up. There is also slight image corruption on the screen. Tested on A1200 + 4MB Fast Ram.

Hope that helps.

Kev G
KevG is offline  
Old 15 November 2010, 14:57   #6
Gaula92
Registered User
Gaula92's Avatar
 
Join Date: Aug 2008
Location: Spain
Posts: 467
Tried on my old trusty A1200 with 4MB fast. Also tried on Minimig in TUrbo and normal modes. It happens in both systems, too.
Gaula92 is offline  
Old 15 November 2010, 16:00   #7
Hungry Horace
Wipe-Out Enthusiast

Hungry Horace's Avatar
 
Join Date: Nov 2005
Location: .
Age: 40
Posts: 2,527
this has come up many times....

http://eab.abime.net/showpost.php?p=600873&postcount=14

http://eab.abime.net/showthread.php?t=34651

seems not to be anything to do with PUAE (or any other UAE)

I know this doenst happen in the JST - perhaps if someone could persuade JOTD and Psygore to compare their sources...
Hungry Horace is offline  
Old 15 November 2010, 16:56   #8
Gaula92
Registered User
Gaula92's Avatar
 
Join Date: Aug 2008
Location: Spain
Posts: 467
Where can I find the JST installed version? I've been googling without much success. Maybe some nice person could upload it into the zone..
Gaula92 is offline  
Old 15 November 2010, 17:13   #9
Hungry Horace
Wipe-Out Enthusiast

Hungry Horace's Avatar
 
Join Date: Nov 2005
Location: .
Age: 40
Posts: 2,527
the patch is here: http://jffabre.free.fr/amiga/l.html

i'm sure it will install using the IPFs
Hungry Horace is offline  
Old 15 November 2010, 18:05   #10
Psygore
Moderator

Psygore's Avatar
 
Join Date: Jan 2002
Location: France
Posts: 485
It's surely an unsupported version and the protection failed.
It's on my todo list.
Psygore is offline  
Old 15 November 2010, 20:24   #11
Gaula92
Registered User
Gaula92's Avatar
 
Join Date: Aug 2008
Location: Spain
Posts: 467
Ok, I managed to install the JST version from IPFs, but it only runs on WinUAE, it won't run on PUAE / Minimig... what configuration do you recommend, Hungry Horace?
Gaula92 is offline  
Old 15 November 2010, 20:39   #12
Retro1234
Boo

Retro1234's Avatar
 
Join Date: Jun 2006
Location: 5150
Posts: 4,938
Quote:
Originally Posted by gaula88@hotmail View Post
So.. what about the CDTV version? It can't feature copylock
Have you tried the WHDload CDTV install - Does it happen with this?
The CDTV version also has its own HD install on the Disc

:edit doesnt have HD install on Disc/CD but is easy to install

Last edited by Retro1234; 15 November 2010 at 21:47.
Retro1234 is offline  
Old 15 November 2010, 22:03   #13
Gaula92
Registered User
Gaula92's Avatar
 
Join Date: Aug 2008
Location: Spain
Posts: 467
@Boo Boo: your idea did the trick! I used the files in the DATA folder in the WHDLOAD LemmingsCDTV version, and wrote a small script that assigns LemMisc1, LemMisc2, LemSamples, LemLevels and other folders as volumes, as required by the main executable.
Then I run "Lemmings" at the end of the script and presto!
Ah... the Amiga shell. It's so nice!

Thanks for all your ideas, folks!

BTW: Is the same problem present in Oh No More with WHDLoad?
Gaula92 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS-UAE - Unregistered WHDLOAD : WHDLOAD.KEY - FIX Neil79 support.FS-UAE 14 29 January 2013 22:34
68060 change/use register stalls Nut Coders. Asm / Hardware 8 27 April 2012 09:08
whdload Lemmings and Pinball Fantasies Jimbo support.Games 3 01 August 2010 15:22
Problem with Holiday Lemmings 1993 / WHDLoad edd_jedi support.Games 11 13 April 2010 14:40
Lemmings WHDload singledisk version? gary request.Old Rare Games 2 16 May 2003 06:22

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:51.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.08628 seconds with 13 queries