English Amiga Board


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 07 December 2012, 19:44   #1
mr_a500
Amiga-based Cyborg
mr_a500's Avatar
 
Join Date: Dec 2004
Location: Canada
Posts: 807
Why is NTSC mode so much slower than PAL?

Running the same setup & Workbench in PAL and NTSC mode, NTSC is way slower. (I'd say 34.8% slower, but that's just going by feel. ) Sound is much slower and choppier.

Is there a reason for this huge difference in speed? I don't recall there being a speed difference when I tried WinUAE a few years ago.

Last edited by mr_a500; 07 December 2012 at 19:51.
mr_a500 is offline  
Old 07 December 2012, 20:13   #2
kipper2k
Registered User

 
Join Date: Sep 2006
Location: Thunder Bay, Canada
Posts: 4,129
Quote:
Originally Posted by mr_a500 View Post
Running the same setup & Workbench in PAL and NTSC mode, NTSC is way slower. (I'd say 34.8% slower, but that's just going by feel. ) Sound is much slower and choppier.

Is there a reason for this huge difference in speed? I don't recall there being a speed difference when I tried WinUAE a few years ago.
If you run a PAL game in a PAL computer it will play normal speed, if you play a PAL game in an NTSC computer the screen will cut off the bottom portion of the screen and the music will also play faster
kipper2k is offline  
Old 07 December 2012, 20:16   #3
FrodeSolheim
FS-UAE Developer
FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 40
Posts: 3,886
Quote:
Originally Posted by mr_a500 View Post
Running the same setup & Workbench in PAL and NTSC mode, NTSC is way slower. (I'd say 34.8% slower, but that's just going by feel. ) Sound is much slower and choppier.

Is there a reason for this huge difference in speed? I don't recall there being a speed difference when I tried WinUAE a few years ago.
Hi, one possible reason is that your computer is now powerful enough to run with full vsync (or at least that there are some performance problems related to running with full vsync). With the default auto setting, FS-UAE will enable full video synchronization when the Amiga refresh rate and the host refresh rate matches (60Hz).

Try to adjust the video synchronization setting in Settings -> Video Settings, and change it from "Auto" to "Sync to Vblank" (which should rather be called "Flip on Vblank" when I think about it) or "Off". Using "Off" should be the fastest option.
FrodeSolheim is offline  
Old 07 December 2012, 20:28   #4
mr_a500
Amiga-based Cyborg
mr_a500's Avatar
 
Join Date: Dec 2004
Location: Canada
Posts: 807
Quote:
Originally Posted by FrodeSolheim View Post
Hi, one possible reason is that your computer is now powerful enough to run with full vsync (or at least that there are some performance problems related to running with full vsync). With the default auto setting, FS-UAE will enable full video synchronization when the Amiga refresh rate and the host refresh rate matches (60Hz).

Try to adjust the video synchronization setting in Settings -> Video Settings, and change it from "Auto" to "Sync to Vblank" (which should rather be called "Flip on Vblank" when I think about it) or "Off". Using "Off" should be the fastest option.
Yes, that was it. I'm running at 60Hz, so FS-UAE must have automatically turned on full sync and my computer's not fast enough for that. Thanks again!

(...watch out for more problem threads from me though... )

Edit: I didn't go to "Settings -> Video Settings" because I don't have the config GUI. I just edited the config file manually.
mr_a500 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
NTSC CD32 and Flatscreen TV (PAL Mode?) atrionfo support.Hardware 1 12 December 2011 20:12
Amiga CD32 qustion: autoboot NTSC console in pal mode hutton80 Amiga scene 2 10 November 2010 19:55
i hear that PAL/NTSC mode is switchable ... NfernalNfluence New to Emulation or Amiga scene 17 25 August 2010 14:11
NTSC A500 Pal/NTSC mod pics kipper2k Hardware pics 2 29 March 2009 07:56
NTSC as default mode on a PAL Amiga12oo oldpx support.Hardware 31 13 September 2002 21:43

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:59.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.07838 seconds with 13 queries