English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 03 August 2018, 22:34   #1
unic0der
 
Posts: n/a
Amiga 500: Bottom half of screen shows only garbage

Hello everyone,

Bought an Amiga 500 (Rev 6) off Ebay three days ago. Worked perfectly the first two days.
Today, though, the Amiga decided that it shall no longer show anything on the bottom half of my screen. Doesn't matter via which cable or port it connect (both mono and rgb). The bottom half of the screen is always garbage. Sometimes as in the attachment, sometimes a more solid color. And even more funky, the mono output plug does now also display some color (?!)

The only changes I did in the meanwhile was, that I connected a freshly bought "Boomerang B432" Gamepad to the Amiga (of course, when it was switched off) and a shiny new RGB -> SCART cable today.

Any ideas what went wrong? Hopefully the Gamepad or RGB cable doesn't have a problem and permanently damaged the machine.

Update: I also got the following Guru meditation when wiggling the RGB plug at the back of the computer: 80C01570
Attached Thumbnails
Click image for larger version

Name:	amiga problem.jpg
Views:	111
Size:	1.02 MB
ID:	59112  
 
Old 04 August 2018, 18:41   #2
Hewitson
Registered User
Hewitson's Avatar
 
Join Date: Feb 2007
Location: Melbourne, Australia
Age: 38
Posts: 3,747
As much as it's not recommended, wiggling the RGB plug shouldn't cause a guru.

Can you try the Amiga on a TV to rule out the monitor?
Hewitson is offline  
Old 04 August 2018, 18:58   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 24,988
TV most likely gets confused by Amiga's progressive mode and shows only half of the lines and the rest is uninitialized internal buffer RAM garbage. (More common side-effect is showing full height display but only updating it every other field)

Try setting WB to interlaced mode, does it "fix" the display?
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kim Dot Com Documentary Shows an Amiga 500 Pyromania Amiga scene 3 14 May 2018 13:55
Bottom of screen is missing Iwantgames:) support.Hardware 0 26 July 2015 00:35
WTD: Atari STE Parts - Bottom half of case & more ElectroBlaster MarketPlace 0 02 March 2011 16:23
Garbage on screen during boot absence Coders. General 6 20 February 2011 20:28
Wanted - A1200 Tin Shield Bottom Half - NEW Peter MarketPlace 0 15 September 2010 17:06

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:06.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.08837 seconds with 14 queries