English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 26 January 2022, 20:15   #141
coldacid
WinUAE 4000/40, V4SA
coldacid's Avatar
 
Join Date: Apr 2020
Location: Candinavia
Posts: 474
Quote:
Originally Posted by Toni Wilen View Post
This never gets finished enough..

Short of emulating every single transistor and wire across an entire system, it never will be
coldacid is offline  
Old 27 January 2022, 08:24   #142
rutra80
Registered User

 
Join Date: Jul 2019
Location: Poland
Posts: 162
rutra80 is offline  
Old 27 January 2022, 16:20   #143
DZh
Registered User
 
Join Date: Apr 2021
Location: Minsk/Belarus
Posts: 30
More from Beta4 (I did not notice before):

http://eab.abime.net/attachment.php?...1&d=1643296788
Attached Thumbnails
Click image for larger version

Name:	002.png
Views:	262
Size:	28.5 KB
ID:	74541  
DZh is offline  
Old 28 January 2022, 20:06   #144
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
Quote:
Originally Posted by coldacid View Post
Short of emulating every single transistor and wire across an entire system, it never will be
It is not needed in fully digital system like Amiga. And it would be enough to keep it at logic element (logic gates, latches, flipflops etc) level, not transistor level. If someone really wants to do it

Quote:
Originally Posted by DZh View Post
More from Beta4 (I did not notice before):

http://eab.abime.net/attachment.php?...1&d=1643296788
Fixed. And some others. Another attempt at final beta tomorrow or sunday..
Toni Wilen is online now  
Old 28 January 2022, 22:08   #145
DZh
Registered User
 
Join Date: Apr 2021
Location: Minsk/Belarus
Posts: 30
Confirmed. Thank you Toni.
DZh is offline  
Old 29 January 2022, 19:53   #146
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
https://download.abime.net/winuae/fi...nuae_4910b8.7z
https://download.abime.net/winuae/fi...ae64_4910b8.7z

Beta 8: Yet another possibly final 4.9.1..

- Sprite collision bitplane end position calculation was not updated to 4.9.0+ chipset emulation. Probably didn't cause problems because it was too large and it most likely could not cause any spurious collisions.
- b6 ECS Denise CSYNC fix broke vertical blanking when EXTBLANKEN=1. Made only visible difference if mode was weird (not WB monitor driver)
- If programmed mode HSYNC start is later than normal, use it instead of standard VGA-like config. (More correct horizontal position if weird mode)
- Yet another Copper comparator update. WAIT and SKIP timing change again, all my statefile tests still work (and one that didn't also works now). SKIP comparison check timing is not same as WAIT, SKIP seems to check comparison result just before next copper instruction gets loaded (SKIP comparison active as long as IR1 and IR2 bits 0 are set)
- b4 bitplane number update fix, if number of bitplane was increased after hsync start but before hsync end, sometimes bitplane count change was ignored until next line.
- "Default" filter mode now also auto-adjusts if horizontal size does not match vertical (for example if horizontal is hires but vertical is nondoubled: double vertical automatically using filter scaling). Other modes are not yet updated because it can break existing configs.
- Reverted 490b25 68030+ MMU "CE" mode cycle count update that made it too slow compared to matching non-MMU mode.
Toni Wilen is online now  
Old 30 January 2022, 12:05   #147
21stcentury
Registered User

 
Join Date: Jul 2014
Location: Paris
Posts: 56
There's a problem with the PAL Filter. The yellow color has disappeared. The filter works fine with an older release. Strange.

I like this filter because the colors are similar to a CRT screen.


Last edited by 21stcentury; 30 January 2022 at 12:11.
21stcentury is offline  
Old 30 January 2022, 16:01   #148
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
Quote:
Originally Posted by 21stcentury View Post
There's a problem with the PAL Filter. The yellow color has disappeared. The filter works fine with an older release. Strange.

I like this filter because the colors are similar to a CRT screen.

Attach config file please. And when did it work previously? 4.4.0?
Toni Wilen is online now  
Old 30 January 2022, 17:44   #149
DZh
Registered User
 
Join Date: Apr 2021
Location: Minsk/Belarus
Posts: 30
This is 32bit version only problem starting from 4.3.0. WinUAE 4.2.1 - Ok.
DZh is offline  
Old 30 January 2022, 18:01   #150
21stcentury
Registered User

 
Join Date: Jul 2014
Location: Paris
Posts: 56
The previous release was 4.2.
I tried everything with my graphic card drivers but... nothing

Dzh have maybe right because I use a 32 bits version.
Attached Files
File Type: uae AMIGA 1200.uae (11.9 KB, 17 views)

Last edited by 21stcentury; 30 January 2022 at 18:09.
21stcentury is offline  
Old 30 January 2022, 18:25   #151
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
Quote:
Originally Posted by 21stcentury View Post
The previous release was 4.2.
I tried everything with my graphic card drivers but... nothing

Dzh have maybe right because I use a 32 bits version.
Did you attach correct config? Attached config has no filters enabled (and it is saved with 4.9.0).
Toni Wilen is online now  
Old 30 January 2022, 18:50   #152
21stcentury
Registered User

 
Join Date: Jul 2014
Location: Paris
Posts: 56
Only the PAL filter is enabled



Maybe I did something wrong, this is my attached config again
Attached Files
File Type: uae AMIGA 1200.uae (11.9 KB, 22 views)
21stcentury is offline  
Old 30 January 2022, 19:21   #153
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
Better

It was caused by weird code that got probably broken when compiler was updated. Fixed in next version. (But I recommend finding D3D shader that does the same, it would be much more effient and modern way to do it. But don't ask in this thread.)
Toni Wilen is online now  
Old 30 January 2022, 19:55   #154
21stcentury
Registered User

 
Join Date: Jul 2014
Location: Paris
Posts: 56
Thanx a lot. I prefer to wait the next version. I never found a shader with this PAL filter configurations who is perfect.

And with the PAL filter, we have access to more extra settings like noise (superb), saturation etc...
21stcentury is offline  
Old 31 January 2022, 01:08   #155
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 46
Posts: 1,965
Quote:
Originally Posted by vulture View Post
Hi Toni,

With "Full Contact" using the .IPFs and either a standard "A500 / OCS / Cycle-exact" or "A500 / ECS Agnus / Cycle-exact" Quickstart; there are now issues with the fighters shadows etc,

[INDENT]WinUAE 4.9.0:



WinUAE 4.9.1 beta:

I can still confirm some gfx glitches with Full Contact, see left border etc. tested also with IPFs and A500 quick config, or maybe is just an overscan issue (I kept everything standard selecting just A500 quickconfig):



Other special gfx fx used by the game to present enemies cards etc. seem glitched though...

Last edited by hexaae; 31 January 2022 at 01:16.
hexaae is offline  
Old 31 January 2022, 09:26   #156
ross
Defendit numerus

ross's Avatar
 
Join Date: Mar 2017
Location: Crossing the Rubicon
Age: 51
Posts: 3,688
Quote:
Originally Posted by hexaae View Post
I can still confirm some gfx glitches with Full Contact, see left border etc. tested also with IPFs and A500 quick config, or maybe is just an overscan issue (I kept everything standard selecting just A500 quickconfig):
This is a problem of the game.
The overscan issues are cause 'open' DIW (visible borders area are not covered).

Enter debugger, then:
W 72329 c7

Tested with IPF #2246, A500(512+512)
ross is offline  
Old 31 January 2022, 09:49   #157
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 46
Posts: 1,965
Quote:
Originally Posted by ross View Post
This is a problem of the game.
The overscan issues are cause 'open' DIW (visible borders area are not covered).

Enter debugger, then:
W 72329 c7

Tested with IPF #2246, A500(512+512)
Yep. Forcing "Filter: Auto Integer Scaling" fixes it indeed.
But the fact the game still runs too fast with gfx glitches when showing opponent's card even in Quickstart A500 mode...? It also crashes with GURU when pressing ESC during a combat... but maybe are just game bugs even on a real A500 512+512 (I admit I didn't like this game when I was a kid except the cool intro )

Last edited by hexaae; 31 January 2022 at 09:59.
hexaae is offline  
Old 31 January 2022, 16:45   #158
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
I am not interested in A500 testing, it simply looks too crap (and not really anything to do with 4.9.x anyway, except the copper glitch that got fixed. The rest are "correct" glitches.)

It looks like game wants to exit to AmigaDOS when ESC is pressed:

Code:
 0 0006fe00 33fc c000 00df f09a      move.w #$c000,$00dff09a
 0 0006fe08 33fc 0020 00df f096      move.w #$0020,$00dff096
 0 0006fe10 33fc 81d0 00df f096      move.w #$81d0,$00dff096
 0 0006fe18 2279 0006 fdea           movea.l $0006fdea [00000000],a1
 0 0006fe1e 23e9 0032 00df f080      move.l (a1,$0032) == $00000032 [082c00fc],$00dff080
 0 0006fe26 23e9 0032 00df f084      move.l (a1,$0032) == $00000032 [082c00fc],$00dff084
 0 0006fe2e 2c79 0000 0004           movea.l $00000004 [00000676],a6
 0 0006fe34 4eae fe62                jsr (a6,-$019e) == $000004d8
Obviously last jsr (Close graphics.library?) goes nowhere because execbase is long gone..
Toni Wilen is online now  
Old 31 January 2022, 17:28   #159
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 46
Posts: 1,965
Ok, sorry So it was just original crap code and nothing else...
hexaae is offline  
Old 01 February 2022, 20:19   #160
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 47
Posts: 25,372
https://download.abime.net/winuae/fi...nuae_4910b9.7z
https://download.abime.net/winuae/fi...ae64_4910b9.7z

Beta 9: (really going to be final?)

- b8 "default" filter update was not complete. Now image is automatically integer scaled if original image is half (or less) size of host window/fullscreen size.
- b8 MMU change didn't change much because MMU + CE isn't "real" CE mode but normal MMU + some timing adjustments. (Because there is not much point). Timing adjustments adjusted, now MMU + CE shouldn't be much slower than non-MMU CE mode.
- PAL filter (and probably some other software filters that internally use YUV) had wrong colors since 4.3.0, 32-bit version only.
Toni Wilen is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 4.9.0 beta series (Was 4.5.0) Toni Wilen support.WinUAE 1068 07 December 2021 17:45
WinUAE 4.0.1 beta series Toni Wilen support.WinUAE 64 15 July 2018 12:03
WinUAE 3.5.0 beta series (was 3.4.1) Toni Wilen support.WinUAE 177 14 June 2017 23:31
WinUAE 2.4.1 beta series Toni Wilen support.WinUAE 223 09 May 2012 16:16
WinUAE 2.4.0 beta series Toni Wilen support.WinUAE 342 29 March 2012 09:02

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.16444 seconds with 14 queries