English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 28 January 2022, 00:14   #1
Sim085
Registered User
 
Join Date: Apr 2009
Location: N/A
Posts: 883
A500 with samsung keyboard problem

I have an A500 with a samsung keyboard (the one with the two ribbons). It has a strange problem and therefore not sure if the issue is with the keyboard membrane or the keyboard controller. I know for sure the A500 itself works fine because with a different keyboard the issue does not show itself.

The reason why I am not sure of the source of the problem (and suspect the keyboard controller might be at fault) is that whenever I had a problem with a keyboard membrane the symptoms are always the same... some keys do not work.

However in this particular case;

- On boot the number pad enter button remains reporting it is being pressed.
- When some other keys are pressed it stops reporting it is pressed.
- Pressing the key does not work.
- But some times it works and remains reporting it is pressed.
- All other keys on the keyboard work fine.

Has anyone encountered this problem? Does it sound like a controller issue or still what to be expected from a membrane issue?
Sim085 is offline  
Old 28 January 2022, 21:23   #2
RetroPassionUK
RetroPassion

RetroPassionUK's Avatar
 
Join Date: Aug 2018
Location: Kent
Posts: 214
Quote:
Originally Posted by Sim085 View Post
I have an A500 with a samsung keyboard (the one with the two ribbons). It has a strange problem and therefore not sure if the issue is with the keyboard membrane or the keyboard controller. I know for sure the A500 itself works fine because with a different keyboard the issue does not show itself.

The reason why I am not sure of the source of the problem (and suspect the keyboard controller might be at fault) is that whenever I had a problem with a keyboard membrane the symptoms are always the same... some keys do not work.

However in this particular case;

- On boot the number pad enter button remains reporting it is being pressed.
- When some other keys are pressed it stops reporting it is pressed.
- Pressing the key does not work.
- But some times it works and remains reporting it is pressed.
- All other keys on the keyboard work fine.

Has anyone encountered this problem? Does it sound like a controller issue or still what to be expected from a membrane issue?
Remove the 2 ribbons and see if the issue persists, then you will know if its the membrane or the controller board. We are currently repairing a chicken lips keyboard at the moment which shows an issue with the caps lock light that keeps flashing and only ctrl-A-A works, will let you know how that goes! there is not much on the board so should be fixable unless its the membrane which getting a working replacement will be difficult.
RetroPassionUK is offline  
Old 31 January 2022, 01:06   #3
Sim085
Registered User
 
Join Date: Apr 2009
Location: N/A
Posts: 883
Once back home will try to remove the ribbons and see what happens.
Sim085 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Samsung keyboard controller PCB Rissy request.Other 0 22 April 2021 14:20
Can i use a Mitsumi keyboard in place of a Samsung? Rissy support.Hardware 7 21 April 2021 13:09
Need Samsung keyboard cap spring Rissy support.Hardware 0 19 April 2021 18:44
A500 keyboard, reset problem orange support.Hardware 10 04 November 2010 19:51
A500 Keyboard Problem jonzo support.Hardware 5 10 October 2007 14:08

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:53.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.08962 seconds with 15 queries