Thread: NOOB Needs Help
View Single Post
Old 28 May 2010, 17:10   #1
bburtonpa
Amiga user since 1985
 
Join Date: Apr 2005
Location: Middlesex, NJ USA
Posts: 14
NOOB Needs Help

Ok, I'm not really a N00B, it's just been a VERY LONG time since I have written any Amiga code. I am trying to relearn the proper way to open an Amiga window. My window opens fine...I am able to close it without any issue...what I am UNABLE to do is resize the window!

Here is code snippet of how I open the window::

MyWindow = (struct Window *)OpenWindowTags( NULL,
WA_Left, 20,
WA_Top, 20,
WA_Width, 300,
WA_Height, 100,
WA_Title, (ULONG)"My Window", /* struct TagItem expects a ULONG. */
WA_DepthGadget, TRUE,
WA_CloseGadget, TRUE,
WA_SizeGadget, TRUE,
WA_DragBar, TRUE,
WA_IDCMP, IDCMP_CLOSEWINDOW,
TAG_END);

Assume that the all the necessary libraries are opened, the message loop is correct etc. I have compiled the app with both AmiDevCPP (cross compliled) and SASC 658 (native). The window opens, all the gadgets are in the correct location, I can drag the window around, close it properly, etc. I JUST CAN'T RESIZE THE @%#^%#^$#$# thing. When I click the resize gadget, I get a red border around the window which disappears when I release the mouse button. I've run other applications such as Turbo Text and the other windows resize without any problem.

Please note: I do not have a "REAL" amiga to try this on; everything I am doing is on a "stock" AmigaForever installation.

Could this be an issue with AmigaForever or have I been living in the Windows world too long to do this right...!!!

THANKS!! ANY help will be appreciated...
bburtonpa is offline  
 
Page generated in 0.04355 seconds with 11 queries