View Single Post
Old 23 July 2014, 22:55   #9
alkis
Registered User

 
Join Date: Dec 2010
Location: Athens/Greece
Age: 50
Posts: 644
Found a workarround.
This on terminal starts fs-uae correctly:
__GL_WRITE_TEXT_SECTION=0 fs-uae

And the relative documentation for it (/usr/share/doc/nvidia-340/html/openglenvvariables.html)
Disabling executable memory optimizations

By default, the NVIDIA driver will attempt to use optimizations which rely on being able to write to executable memory. This may cause problems in certain system configurations (e.g., on SELinux when the "allow_execmem" boolean is disabled or "deny_execmem" boolean is enabled, and on grsecurity kernels configured with CONFIG_PAX_MPROTECT). When possible, the driver will attempt to detect when it is running on an unsupported configuration and disable these optimizations automatically. If the __GL_WRITE_TEXT_SECTION environment variable is set to 0, the driver will unconditionally disable these optimizations.
alkis is offline  
 
Page generated in 0.04366 seconds with 11 queries