View Single Post
Old 11 May 2021, 12:06   #40
FrodeSolheim
FS-UAE Developer
FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 40
Posts: 3,873
Quote:
Originally Posted by RetroKing View Post
On my Windows 7 Ultimate Workstations:
FSUAE Launcher
missing: api-ms-win-core-path-l1-1-0.dll (dependency of python39.dll)
The issue is that Windows 7 is no longer supported by the Python project. Python 3.9 (well, the official builds at least) only supports Windows 8.1+.

Since these builds are built with Python 3.9, the minimum Windows version is 8.1 for these Launcher builds. I might reconsider and build the Windows version of the Launcher with Python 3.8 (the last Python version which supports Windows 7). But I'm not sure if it is worth it since Microsoft is no longer supporting Windows 7 either.

Quote:
Originally Posted by RetroKing View Post
I would suggest to make your Autoupdater STANDALONE (exe). So that the Frontend works without strange depencies (Online & Offline) and also lightweight for older systems.
The auto-updater is part of FS-UAE Launcher and uses the same dependencies as FS-UAE Launcher. No additional dependencies are introduced by the updater.

Last edited by FrodeSolheim; 11 May 2021 at 12:57.
FrodeSolheim is offline  
 
Page generated in 0.06815 seconds with 11 queries