English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Amix (http://eab.abime.net/forumdisplay.php?f=125)
-   -   Amix in WinUAE (http://eab.abime.net/showthread.php?t=67210)

Noth 02 March 2014 15:32

Quote:

Originally Posted by mark_k (Post 941113)
Just wondering, for people running WinUAE under Wine (or running an X server in Windows)...

Has anyone tried running X programs in Amix, but setting the display so the program opens on the native Linux desktop? Or vice versa, running Linux programs and having them appear on the Amix X desktop? Hopefully that should be possible by setting up the correct ports for slirp.

I tried to get Remina to contact XDM using the port forwarding, but it didn't connect... possibly my messed up DNS setup causing the pain. Haven't tried from AMIX to Linux though.

EDIT: talking of which, do you lucky people with A3000s have DNS working according to the instructions on the amigaunix.com site? I've never got AMIX to resolve anything in WinUAE.

vintageBytes 03 March 2014 08:40

I tried my custom X11R5 install script on my A3000T this weekend, but it did not work. I'm pretty sure this is a problem with my Merlin RTG. I'll try to find a Picasso II card for testing...

Amiga_CDTV 03 March 2014 19:33

I sent PM's with vintageBytes and on a sidenote I was just told how to send files from/to a real Amix- machine over a null-modem cable (with Kermit, open it up and set the following: "set line /dev/term/ser", "set baud 38400" and "set file type binary" and the "receive" or "send"). Works nicely (with the same cable I use with AmigaExplorer to send stuff over), thanks!

Now a question: can I use this same method with WinUAE emulated Amix? Ie. can I use Kermit to send stuff from/into the emulated Amix on a single PC?

amilo3438 03 March 2014 19:52

Amix vs AmigaDOS ...

UNIX: Is It For You? Part I: For The User
UNIX: Is It For You? Part II: For The Programmer

and some helpful links ...

Top 10 Best Cheat Sheets and Tutorials for Linux / UNIX Commands

Noth 05 March 2014 23:26

Ok I've tested in a basic AMIX install (with the supplied b&w X11R4, not the patched version) having multiple instances of X running. Specifically I launch olinit, and when that loads I switch terminals and launch xinit :7 (if the console is 7). It'll load but it won't load twm, because twm can't work out what X port to open on. There are ways around this but I haven't had much success yet (disabling xhost restrictions using xhost + should help).

EDIT: if you configure XDM to start on boot after having made sure xinit works, then you can login via XDM and get twm, and then login on another virtual console, launch olinit :9 (if console 9) and hey presto, two desktops! Should make life on the A3000 a bit more comfortable. You can also via the properties - miscellaneous get OpenLook to run on console login, if that's your thing.

For using AMIX's serial port in WinUAE yes that's possible although I haven't tried Kermit. Of more interest if we can use the serial port fully is either trying cu (from the uucp package) to connect to the console (like you'd do with a nullmodem cable), and running SLIP to get full connectivity over the serial port... think of it as ghetto ethernet. There's no reason it shouldn't work but it's a bit obscure to setup (and I'm no fan of pmadm).

Noth 06 March 2014 03:23

1 Attachment(s)
Mhhh funny... the only OpenLook app I can get to run under X11R5 is oclock... Not very configurable but doesn't matter. This desktop is done with an .xinitrc that uses xsetroot -bitmap tile.xbm to set the background and launches oclock, and a decently configured .twmrc. Funnily enough oclock has a transparent backgroung! Not exactly standard for 1991!

Noth 06 March 2014 06:31

2 Attachment(s)
And for the AMIX 1990 background... I took Keith Ohlf's NeXTSTEP icon and made it an AMIX one. You'll find a screenshot and .png below (I spent about an hour using WIn8.1's Paint to do this and it's as bad ever...). Convert it back to whatever file format xv supports (TIFF it likes a lot) and you can use as a nice greyscale background should the fancy take you. Not sure if it'll look ok in b&w though...

Noth 08 March 2014 16:34

Ok I've tested XDMCP connections... Remember to open 177 udp for this to have a chance of ever working, because it plain doesn't. Even trying this gives an error :
Code:

bash# X :8 -query localhost
XDMCP fatal error: Session declined No valid address

. I've been googling but I can't find an answer so far... Probably a DNS issue which means won't ever work as far as I can tell (never got AMIX to resolve DNS properly).

vintageBytes 11 March 2014 08:16

Does anyone know where to get some programs for Amix? There should be at least some software :-)
Where can e.g. Motif be downloaded (Amix states, that this is available)?

One A3070 picture in BBOAH shows a Maple V tape:

http://www.bigbookofamigahardware.co...3070drive2.jpg

I was lucky on ebay and found an Archive Viper 150MB tape drive for 7 Euros. I will try the original installation with this drive, when it arrives...

Amiga_CDTV 11 March 2014 20:33

1 Attachment(s)
Nice find that tape drive. And for a very reasonable price ;)

I did some experimenting with (b&w so far) backgrounds, here's my new one (see pic.). Doesn't work too well in greyscale though...

Ignore the red-blue Xlogo, I was just having fun with the -fg and -bg -parameters :)

vintageBytes 12 March 2014 11:00

Looks nice :-)
I received the tape drive yesterday, it seems to work. I've ordered 3 tapes and will try to create an installation tape today.

EDIT: Okay... I can rewind and retension the tape, but when I try to write to it, Amix tells me, that the device is not existing.
Tape drive is jumpered to ID 4, as it should be. Any ideas, why this is not working? Could it be a problem with the HD hack install method?

Amiga_CDTV 15 March 2014 20:38

@vintageBytes: did you try to address it as /dev/rmt/4 ? This was about all that was said on the topic in the "Using Amiga Unix" -manual, just my two cents on the topic.

Has anyone tried the patches on this page on AmigaUnix.com? I just copied the Y2K- fixed setclk into my WinUAE installation and now it accepts 2014 correctly.

If any/some of those really help, wouldn't it be nice to have sort of a "Service pack" made with all those little fixes? I am sure there are more (a lot ;)) of small fixes that would be nice to have easily installed. The setclk should be easy to fit fe. into the 2.1p patch disk as it's only 4KB.

About the audio driver: at least in WinUAE it seems to be working as is, mine beeps when it starts shutdown etc (if audio emulation is enabled). But I don't think it did beep on my 3000T.

I have been reading "UNIX for Dummies" (late 1990's print, plenty of these on eBay!). Couple of more chapters to go but I really think I am learning now!

Btw: has anyone tried printing from Amix in WinUAE ?

Amiga_CDTV 16 March 2014 13:43

Quote:

Originally Posted by vintageBytes (Post 942959)
Does anyone know where to get some programs for Amix? There should be at least some software :-)

Well, I found something that-sounds-about-right in Funet's Amiga archive, see /index/amiga/unix/misc and /index/amiga/X11.

vintageBytes 17 March 2014 10:49

I've tried the X11R5 patch, but this does not work for me. I can't compile without errors.
Printing should work, as there are printing services started by default. There seem to work only postscript printers.
If you do not want to print anything, you can disable the printing services with

Code:

mv /etc/rc2.d/S80lp /etc/rc2.d/s80lp
This should save memory...

Yesterday I connected my 3000T's SCSI drive to my WinUAE computer and did a clean "tape" install. This worked, but I still can not acces the tape drive via the device name (should be /dev/rmt/4hn). Amix still tells me, that the device does not exist. I can retension and rewind the tape and even amixpkg tries to access the tape.

My test was to zero out the tape with

Code:

dd if=/dev/zero of=/dev/rmt/4hn bs=32k
Thanks for the links, I'll check them :)

Noth 18 March 2014 17:43

Creating a "service pack" wouldn't be hard, just make up an amix package and install that. You could add a new kernel (not sure if the package system can do post install stuff), all those files that get patched via the floppy image, etc.

vintageBytes 18 March 2014 20:38

Yes, should be easy.
Any shell script can compile and install a new kernel. The altered X11R5 installscript does that, too.

I still cannot figure out the problem with my streamer: can this be caused by the missing internal battery?

mark_k 18 March 2014 22:25

Can you get any AmigaOS programs to see the tape drive?
Do you have a SCSI card for your PC, to allow you to connect the tape drive to it?

Amiga_CDTV 18 March 2014 22:34

I used this program to set the battery backed-up SCSI parameters in my 3000T: http://aminet.net/package/driver/media/SCSIPrefs
The docs mention following settings: Long SCSI timeout, Multiple LUN support on/off, Host adapter SCSI ID. None of them sounds like having any effect on the tape drive, I would think.

Probably good idea to test if any Amiga OS tape backup tool works with the drive.

See some-mentions-around-the-topic here: https://groups.google.com/forum/#!to...re/qGeuA8RmbRs

Edit: see also here (http://www.dpmworld.net/AmigaGallery/a3070/index.html), have you got the early WD33C93-04 -chip or do you have the SCSI termination resistors installed into the motherboard (=terminating the bus before the ext.scsi connector)?

vintageBytes 24 March 2014 08:29

I was on a computer festival this weekend, here in southern Germany. There were a couple of Amiga enthusiasts and with the help of them we figured out, why the X Server is not running on my A3000T:

The combination of Ariadne I and Merlin does not work. :nuts

If I pull the network card, X is starting. So, we tried a Picasso II and this combination works!

The tape drive is still not found under the device name, but I was able to do a backup with HDBackup from Workbench 3.1. I will add a battery, maybe this can help. The SCSI-Chip is the -08 version.

What should be included in a "service pack"?
I'm thinking of:
  • Latest patch level
  • setclk Y2K patch
  • SVGA patch for X-server

I will test the additional software provided on the amigaunix.com page, maybe it would be a good idea to include some of them, too? Tools like bzip2 or updated tools for tar, cpio could be a good enhancement.

If Amix has network access, it could also be a good idea to arrange these files on a FTP server, so they can be accessed by the Amiga itself.

Oh, btw. I was able to connect my NetBSD notebook via FTP to the A3000T. I logged in as root (with Amix root password) and had full access to the computer. Very easy to share data ;)

Noth 24 March 2014 11:19

The AMIX ftp client doesn't know how to do passive mode so it won't work in slirp... It'll connect and login, change dir, but can't list or download. wget is a much better bet for this.

I agree we may as well include all possible improvements in the service pack, it'd save a lot of time.

Very weird that the Merlin wouldn't work with the Ariadne... At least you got it fixed with a nice PicassoII! Welcome to the world of colour X11!


All times are GMT +2. The time now is 17:14.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.08767 seconds with 11 queries