English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   project.ClassicWB (http://eab.abime.net/forumdisplay.php?f=61)
-   -   Mouse wheel madness in Dopus (Classic Wb Lite v 24) (http://eab.abime.net/showthread.php?t=55302)

emuola 22 September 2010 07:42

Mouse wheel madness in Dopus (Classic Wb Lite v 24) *now a new error*
 
*Sorry for double posting, I guess this is the more correct thread anyway. Mods please delete the thread in Support.Apps*

Having trouble with my mouse wheel... Succesfully installed Micromys v3 driver and Freewheel is also enabled (Classic wb Lite v24).

Wheel works fine in WB windows, but in Dopus only the slider (or scroll bar) moves, but not the content of the Dopus window?! I noticed that if I change the setting of scrolling in Freewheel prefs to either "active window" or "window under pointer", Dopus works ok until next reboot. So, Dopus works everytime right after I change the Freewheel prefs (scrolling settings). It does not matter what I choose in the prefs as long as I choose something and then try Dopus straight away (no reboot). I haven't changed/saved anything in Dopus. Should I? It seems that straight after reboot Dopus somehow "loses the wheel". If I then again change the setting to either one of those two, Dopus works until next reboot. Strange.

Running A1200/1230IV/32MB/4Gb/Classic WB Lite v 24. The mouse is a old cordless Logitech hooked up to Micromys v3.

The weird thing is that I can reproduce this in Winuae 1.6 also (running the same Classic WB Lite v24, but different hw ofcourse).

*edit*
It seems that to reproduce this in Winuae I have to set the Scrolling to "Active window" in Freewheel prefs. After reboot only the scrollbar moves, not the content of the Dopus window. If I set the scrolling to "window under pointer", Dopus works in Winuae.
*edit*

*edit2*
It's the Saving in the Freewheel prefs (at least in Winuae, cannot test with real hw just now)... Straight after the boot only the scroll bar moves. If I then click Save in the Frewheel prefs, wheel starts to work ok...
*edit2*



Any clues?

emuola 24 September 2010 14:11

Ok, I figured that I could change the order in which the additional programs like FreeWheel load with WBSmanager (and of course hoped that it would cure my weird wheel behaviour in Dopus). I moved Freewheel and FreeWheel.cfg a bit downwards and booted. Just after wb had loaded I got an error: "Unable to open your tool 'Freewheel.cfg'" I then changed the order to the original, but the error is still there everytime I reboot :crying I also disabled the Freewheel, but I still get the error!

What did I break here? :help And how do I fix it?

The order in WBSmanager is this:

StartPatchWB
ToolsDaemon
MagicMenu
Freewheel
FreeWheel.cfg
Copper
Tinymeter

Bloodwych 24 September 2010 15:02

Just go into the Startup drawer and remove Freewheel.cfg

That's a config file, not an executable file so it can't be run at startup. It should be in the Prefs/ENVARC drawer somewhere. Depends on where Freewheel stores its prefs. If you look in the Freewheel readme file, it may mention where the settings are stored.

I'm afraid I don't have the tools available to test and help you out on the Dopus issue at the moment. Not sure why Freewheel would be losing its settings on reboot. I don't remember any issues in the past, but anything is possible.

Might be worth disabling Freewheel if you haven't tried already by removing it from the stratup drawer or using the top tools->Freewheel->disable option in the top menu bar or under Run->Settings->Components->Freewheel. Might be a conflict with your mouse driver.

emuola 24 September 2010 15:48

Quote:

Just go into the Startup drawer and remove Freewheel.cfg
Thanks man :bowdown What a relief. I really don't know how the file got in the wrong place. I didn't put it there for sure :) I noticed an interesting issue... When the freewheel is disabled scrolling in Dopus actually works although a bit slow. I have the micromys driver in the user startup. I guess that makes the wheel work, right? It might be, that Freewheel somehow conflicts with micromys driver. The reason I have the micromys driver is that without it the wheel was completely dead (even with FreeWheel enabled).

Bamiga2002 25 September 2010 09:25

I have freewheel.cfg in the WBStartup with WBStartup+ manager but NOT enabled (ticked) so it's in the same dir but it is loaded by FreeWheel not a separate startup item.

emuola 26 September 2010 07:56

Ok, I haven't got the wbstartup+ (I guess it does not come with Classic WB). I could try that out :) Thanks again Bamiga2002.

@Bloodwych:

Could the problem be that the file actually *should* be there, so that Freewheel loads the prefs on every boot. In my case the file just would not be there originally and then when I fiddled with the WBSManager it somehow got there but as executable or something (I'm not so good with Amiga filesystem properties etc)?

Bloodwych 26 September 2010 08:26

It would seem silly for a program to add prefs in the same directory when it's designed as a startup item tool, for reasons you have found out. That's what ENV: is for, or occasionally the S drawer. Or perhaps removing the executable flag from the prefs file would help and it would be ignored on boot?

I'm not sure. Spend too long away from Amiga's these days - I forget stuff! I'll have to test, but can't at the moment until I'm back on my main PC.

Bamiga2002 26 September 2010 10:17

The config file IS in the same directory and is flagged RWED. And i remembered wrong: WBStartup+ loads the config file also. So it's safe to put on WBStartup-drawer. Maybe you have to re-install it, may be corrupt executable...

emuola 26 September 2010 12:18

Quote:

The config file IS in the same directory and is flagged RWED. And i remembered wrong: WBStartup+ loads the config file also. So it's safe to put on WBStartup-drawer. Maybe you have to re-install it, may be corrupt executable...
Ok, I'll have to check the flags for the file. I have a copy of the "original" config file, so I can put it back there and test it. Sorry to ask, but what does that RWED mean? I only know *nix permissions/flags like rwx :( Is the E for Executable?

Thanks guys for your help :) Don't worry Bloodwych, I have started forgetting things also ;)

emuola 26 September 2010 14:55

Ok, tested a bit further...

I had an old FreeWheel.cfg -file (it had the flags set to RWED), which I copied to the WbStartup drawer. Rebooted and guess what. No errors... Weird! My original mouse problem is still here (scrolling in Dopus only after saving the freewheel prefs), but this time the same cfg-file did not cause any errors although it was exactly in the same (wrong?) place.

I found out some old threads in amiga.org describing the same kind of odd behaviour with Dopus, but unfortunately ther was no solution. This problem has been seen before, but apparently it still is quite rare.


All times are GMT +2. The time now is 07:28.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.08308 seconds with 11 queries