English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Apps (http://eab.abime.net/forumdisplay.php?f=8)
-   -   Help with SMBFS? (http://eab.abime.net/showthread.php?t=60570)

madman 14 August 2011 12:16

Help with SMBFS?
 
Quick background, I have a home network consisting of a Linux file server to which all the PC's in the house connect without any problems. Now I have my 1200 back and working I want to be able to connect it to the shares on the server. This is where I am having the problem.

Using smbclient I can connect with out a problem with the command line:

smbclient \\server\sharename password -U username

this connects me to the share and I can see all the files within no problem.

Obviously this is not ideal, I would rather mount the share for workbench access. I have tried the following command:

smbfs workgroup=workgroupname user=username password=password service=//server/sharename device=smb0: volume=sharename

All I get is:

smbfs: Cannot connect to server (5, Input/output error).
smbfs: Could not connect to server (5, Input/output error).

I have tried all sorts of combinations of switches and syntax to no avail. The fact that smbclient can connect proves the connection is possible and the credentials are correct as does the fact that I can connect from any other PC.

Help?? Does anyone have any idea why it won't connect with SMBFS?

madman 14 August 2011 19:32

All sorted. Turns out the version of SMBFS available on Aminet, version 1.66 is not compatible with Linux shares either on a NAS or a Linux server. I downloaded the version 1.74 from sourceforge

http://sourceforge.net/projects/amig.../smbfs%201.74/

This one works. So, nothing wrong with my syntax, just the version of SMBFS I was running. Happy now! :D


All times are GMT +2. The time now is 12:16.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.04350 seconds with 11 queries