English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   Amiga scene (http://eab.abime.net/forumdisplay.php?f=2)
-   -   iGame v2 - A well known Amiga game launcher ( New Build! ) (http://eab.abime.net/showthread.php?t=94347)

falken 20 April 2021 20:23

Quote:

Originally Posted by walkero (Post 1478071)
Awesome. Created the https://github.com/MrZammler/iGame/issues/149 and https://github.com/MrZammler/iGame/issues/150 where I described the features and the proposed solution, to tack them. Feel free to add comments there if you want.

This is great news!

d3cka2d3pwood 04 June 2021 16:36

Hi,

iGame is my most used and favorite app for my Amiga systems and with the introduction of OS 3.2 recently it would be awesome if it was compatible with it.

I'm having issues getting iGame to work with OS 3.2, is anyone else experiencing these issues or is there a fix available?

crazyc 04 June 2021 16:46

Its not compatible? Igame is almost a bit of a deal breaker for me as well!

Is it a MUI issue?

kriz 04 June 2021 17:04

Also surprised to see that it could have issues, check you got all required files maybe..

d3cka2d3pwood 04 June 2021 18:05

I'm really not sure what the issue is, I've tried reinstalling MUI and I have used the library files from a working 3.1 system.

Aardvark 04 June 2021 19:13

Tried with NOGUIGFX Tooltype?

d3cka2d3pwood 04 June 2021 19:19

its working! I'm just stupid lol. Read the 3.2 OS manual and install from the CD!!!

rule no. 1 read the manual haha

Decker 07 June 2021 19:36

iGame 1.6 alpha is what I'm using so far, it runs fine. Also, an earlier 2.0 version ran fine when I tried it.

This one: Can't open Guigfx library v17 or higher

I'm running ClassicWB ADVSP Lite.

Got the lib in /libs from Aminet: guigfxlib.lha (20.0)
Also replaced the library with: guigfxlib_nofpu.lha (20.0)

Always the same error.

https://i.imgur.com/3c5NmOy.jpg


Edit: Well :D The answer is above. Tooltype = NOGUIGFX. But am I missing on something now? Why can't it access the library?

I'm also running OS/KS 3.0 if that matters.

Romanujan 07 June 2021 20:35

@Decker From "iGame2" directory execute command "version guigfx.library FULL". What is the result?

Decker 07 June 2021 22:14

guigfx.library 20.0 (19/11/97)

Decker 07 June 2021 23:01

Here's another odd thing,

2.x (bottom left) for me has always displayed dithered, rastered screenshots compared to 1.6x. Might look better on a small CRT screen, not so much on any LCD. Any way to change this?

https://i.imgur.com/R67tRpZ.jpg

walkero 08 June 2021 00:17

@Decker
can you please share which version of MUI are you using on your machine?

Decker 08 June 2021 01:01

According to splash screen, it's 3.8 (Generic 68000 version)

tero 08 June 2021 01:31

I have the same issue on one of my Systems. guigfx.library can't be found, but not only with iGame but with eagleplayer + EMPYGUI24 too.

This system is a copy of another one where iGame and eagleplayer work but with a handfull of additional programs installed (patches; p96 etc etc). My guess is that guigfx is in conflict with one of those, but i couldn't figure out what exactly.

EDIT: Working for me now. renderlib v40 was the culprit. with renderlib v32 everything works again. It seems there are 2 different renderlib on aminet.
https://aminet.net/package/dev/misc/renderlib68k

walkero 08 June 2021 11:17

GUIGfx it is a little bit tricky to make it work, because there are so many different versions. If I am not wrong, inside the GUIGfx archive there is an example program. If that works, then this is installed fine on your system.

One of the latest MUI 5 version include GUIGfx, so this makes things much more easy for the end user.

@decker
If I understand right, for both iGame versions you are not using GUIGfx. Possibly you have it disabled from tooltypes or prefs. Can you please confirm that?

At the latest iGame versions we had some changes to load as an image the icon of the slave, in case a screenshot is not available. Maybe that changed the way the screenshot gets the dithering. I will check again that code and come back to you if there is anything I could do.

Also, for the problem about opening guigfx.library, can you please tell me what CPU do you use with the ClassicWB ADVSP Lite? Probably the library is for different CPU and fails to open, that's why you get this message. But I will have a look to see if there is a bug somewhere. But you can check yourself also, if the example in GUIGfx package works on that system or crashes.

@all
Thank you all guys for using iGame and reporting those issues

Decker 08 June 2021 11:59

Quote:

Originally Posted by walkero (Post 1489390)
@decker
If I understand right, for both iGame versions you are not using GUIGfx. Possibly you have it disabled from tooltypes or prefs. Can you please confirm that?

Confirmed, disabled from tooltype. 1.6a was by default or I disabled it years ago. And yesterday did the same for 2.1b.


Quote:

can you please tell me what CPU do you use with the ClassicWB ADVSP Lite? Probably the library is for different CPU and fails to open, that's why you get this message.
Using 68030/25,
tried both guigfx.library versions, the standard and noFPU one. Didn't notice any other separating factors in aminet.

These are the ones I tested, and don't come with a demo AFAIK:
https://aminet.net/dev/misc/guigfxlib.lha
https://aminet.net/dev/misc/guigfxlib_nofpu.lha

This one does, according to file list:
https://aminet.net/dev/mui/MCC_Guigfx.lha (Guigfx MUI custom class V19.2)

walkero 08 June 2021 12:08

@decker
Yeah, you are right about the demos. Try the MCC GuiGfx one and tell me if it works. Possible will crash your system if the guigfx is missing...

Decker 08 June 2021 12:51

https://i.postimg.cc/t1qV21Sn/GUIGfx-demo.jpg

Worked fine, ran directly from an external mount. At any rate, I'm sure this is something specifically related to my system/configuration. No reason to sweat over it too much since iGame does work for me after all.

Of course, any solution to that slightly jarring screenshot display issue would be appreciated. Doesn't anyone else have this?

https://i.postimg.cc/bZt9n2Gx/igame-16-vs-21-2.jpg

vulture 08 June 2021 12:55

Maybe check if some dithering options are enabled for the datatype?

walkero 08 June 2021 13:16

@decker
Thank you so much for the tests and the feedback. I will check if there is anything I can do to fix those issues. For that reason I created the following issues:

https://github.com/MrZammler/iGame/issues/152
https://github.com/MrZammler/iGame/issues/153


All times are GMT +2. The time now is 12:51.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.08055 seconds with 11 queries