English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   project.MAGE (http://eab.abime.net/forumdisplay.php?f=76)
-   -   Can't start any WHDLoad game in GBA 1.6 (http://eab.abime.net/showthread.php?t=47222)

manganoid 03 September 2009 20:32

Can't start any WHDLoad game in GBA 1.6
Hi guys, first of all great forums. I'm an emu-freak and am very fond of amiga, c64,zx etc. I also like games (duh) and decided to try the Game Base Amiga.
i have the full package (without the CDTV and CD32 versions) and all works well XCEPT THE DARN WHDLOAD GAMES:crying. I use WinaUAE 1.4.6 (tried the 1.5.0, still the same) and the thing is when I go to EXTRAS -> WHDLOAD then GBA starts WHDRun and when I click Start game the winuae starts but it just hangs there (Not responding). when i ALT+TAB to WHDRun it says "Waiting for WunUAE to finish". I can turn off WHDRUN (ALT+CTR+DEL) but there is NO WAY I can turn off WINUAE except for the power button on my PC. I'm not new to emus and frontends but this left me clueless. PLS HELP :help
Thanx in advance guys and keep up the good work

eLowar 04 September 2009 07:57

Alright, let's start with some things to clarify:
  • WinUAE actually hangs (is "not responding" what Windows tells you or your own assessment?) and can't be closed at all? Hitting "Quit WHDRun" in WHDRun should normally kill WinUAE, too (there's also a "Kill WinUAE Process" function in WHDRun's Tools menu). Also normal methods to exit WinUAE should work (ALT+F4, F12|Quit, etc.).
  • This happens for all WHDLoad games, but for no ADF (or possibly SPS) games? If not, please specify some games it does happen for.
Possible problems (please disregard any that don't apply to you):
  • Some games won't start properly if you have no kickstart ROMs in your WHD folder (although you should get a popup dialog on the Amiga side about that), or if you don't have a (legally) licensed WHDLoad version (if there is no key, WHDLoad should normally tell you that, if there's a pirated key, you'll often just run into random problems).
  • The place to put kickstart ROMs is <GameBase>\GameBase Amiga\WHD\Devs\Kickstarts\.
  • The place to put WHDLoad keys is <GameBase>\GameBase Amiga\WHD\S\ (other locations are possible, but this one's preferred). They need to be renamed to match the names of the .pat and .rtb files already included with GBA.
Some more things you can verify (just to rule them out):
  • Does C:\GBGame\rezip\ contain a directory named like the game you've been trying to run (after you tried to run it)? If the unzipping step in WHDRun succeeded, this should normally be the case.
  • Does the file <GameBase>\GameBase Amiga\WHD\S\user-startup (you can open it with any text editor) contain two lines mentioning the game you've been trying to run? Again, this should normally be the case if WHDRun reported no error.
  • There have also been script issues with GBA lately, but since you're not using the latest WinUAE, I think they probably don't apply to you.
That's all I can think of right now, maybe someone else has a more immediate idea what's wrong, but this should help diagnosing the problem.

manganoid 11 September 2009 19:08

Hmmm, it seems that everything is O.K. with Amiga GB, the problem seems to be with the WINUAE. I tried (and installed) Workbench 3.1 on a virtual HD and everything was O.K., I then tried to install WBench 3.9 but couldnt make the backup disc coz I didnt know the CD driver and its number under WinUAE. I read Tom's guide to Installing the WB 3.9 and it says that I should check uaescsi.device in the Misc section of WinUAE and that I should make a log file. When I do that WinUAE hangs the same way as when trying to load WHDLOAD via GB AMIGA. (Not Responding, and Winuae process cannot be 'killed' from the Task manager -> when I click close ALT-f4 and so on the 'End program' window appears, then the 'Send error report' window, I click 'don't send' but the Winuae still remains resident as if it's respawning. Weird
I have an AHCI SATA HDD, maybe that bothers it?

eLowar 11 September 2009 19:10

I honestly have no idea. Try a newer WinUAE version (make sure to watch out for the script problems with WinUAE 1.6+, solutions are available in other threads in this forum) for starters.

Edit: Actually the script problems probably don't affect WHDLoad games, but if you experience other problems (other than crashes), do look them up.

manganoid 13 September 2009 13:46


eLowar 13 September 2009 14:28


Originally Posted by manganoid (Post 594353)

No worries. Do feel free to report back when you've found out anything new or have tried some more things. I wish I could help more, but I can't think of anything more to say right now.

Follow-up is generally appreciated (I mean if anything is resolved), since someone else with similar problems might come along later.

All times are GMT +2. The time now is 23:11.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.

Page generated in 0.04289 seconds with 11 queries