English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   Config file backward compatibility (http://eab.abime.net/showthread.php?t=72503)

mark_k 09 February 2014 15:45

Config file backward compatibility
 
1 Attachment(s)
A little tip for anyone having issues using a config saved with WinUAE 2.7.0 with earlier WinUAE versions...

I wanted to use my current config with an earlier version of WinUAE. But since adjusting the config and saving with a newer version, something about it causes older versions to crash.

The config works with WinUAE 2.7.0. With WinUAE 2.6.1, loading and starting emulation gives this log output:
JIT: Can't handle access 00839A40!
JIT: Can't handle access 7BC52DE4!
... that line repeated many times ...
JIT: Can't handle access 7BC52DE4!
Segmentation fault


Loading the config, disabling JIT and starting emulation just reports
Segmentation fault

Similar result with WinUAE 2.6.0, except there without JIT it reports:
ExceptionFilter Trap: 09B96AAC 38E800E2 00000000
Segmentation fault


It turns out that the cause of the problem was using the new line mode settings in WinUAE 2.7.0. In the config I have line mode set to Double and interlaced line mode set to Double, fields. For whatever reason earlier versions of WinUAE don't like that; no Line mode radio button is selected when I load the config. After setting line mode to Double I was able to start emulation as normal.


All times are GMT +2. The time now is 19:37.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.06808 seconds with 11 queries