English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Hardware (http://eab.abime.net/forumdisplay.php?f=20)
-   -   CIA responsible for 80000003 error? (http://eab.abime.net/showthread.php?t=27055)

Fingerlickin_B 15 December 2006 12:29

CIA responsible for 80000003 error?
 
I've been getting the "Program failed (error 80000003). Wait for disk activity to finish." error and can't figure out why.

I ran Wilcom's Amiga Analizer and it came with serial port errors, but low and behold it eventually blamed the CIA-B chip.

Since I've had no other problems hardware-wise aside from this test result, I figured maybe the 80000003 error may be related...

If anyone has any ideas please let me know.

I have another machine I can rat one of the CIAs from, but it gives the same errors...maybe it's CIA-A is still ok?

PZ.

thomas 15 December 2006 19:25

Why don't you consider a software problem ?

Other than that, you have to give far more details: which kind of machine, which expansions, what software crashes in which situation etc.

Certainly, if the CIA is dead it could put random signals on the address bus causing illegal address alerts. On the other hand, if there is a problem with the address bus, it could cause the problems with the serial port while the CIA is totally ok.

Did you check for heat, dirt, bad RAM, leaking battery, weak power supply etc. (all the standard causes for random crashes which are much more likely than a dead CIA) ?

Fingerlickin_B 19 December 2006 04:48

My A500 is dead now anyway :(

Photon 19 December 2006 20:44

Dead as in black screen usually means CPU is dead or the ROM is completely unreadable. A good CPU in a bad CPU socket can also give black screen. If you can, swap ROM and CPU from a working machine and see if you get some other color than black and report back :)

A Guru will tell you there's a software error, but a program can fail due to faulty hardware. If you find it works OK with a good CPU I can sell you one.

Ironclaw 19 December 2006 21:37

Quote:

Originally Posted by Fingerlickin_B
I've been getting the "Program failed (error 80000003). Wait for disk activity to finish." error and can't figure out why.

I ran Wilcom's Amiga Analizer.....

Looool :laughing

Fingerlickin_B 20 December 2006 02:35

Nah, I used some secondhand peripheral that has f*cked it...it loads but has lots of problems...I know it's hardware because all the disks that used to work still work in my "parts" machine.

I moved all the socketed components between the machines but it made no difference, so it must be a problem with something else on the mobo........I couldn't be bothered trying to find out what though, as this Amiga stuff is all become much more of a hassle than I thought it would be!

Just waiting on a better machine now anyway.

Oh, and yes, in proper English (not US English) that is the correct spelling :)

PZ.


All times are GMT +2. The time now is 13:11.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.04300 seconds with 11 queries