English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Other (http://eab.abime.net/forumdisplay.php?f=74)
-   -   For those who tamed the Furia...... (http://eab.abime.net/showthread.php?t=107723)

cjwhiting1982 24 July 2021 12:18

For those who tamed the Furia......
I've recently bought a Furia for my A600, i bought the Amiga just over a month ago so not had it long. I've recapped it in that time and removed the Anti-UltraHD device which goes by the name of an RF Modulator.
It's been 30 years since i was playing about with the Amiga but in those days i didn't have Workbench, just hundreds of floppy games. I don't have any knowledge in how the whole OS system works like how to patch devices like SCSI or how the setpatch/startup commands work.

So my A600 so far has;
Furia, 16gb SanDisk Ultra 16gb on an angled IDE connector, added 3.1 (40.063 rom) and a 1mb trap door exp.

I've installed several OS' so far and got them all to boot of the SD card no problem. WHDLoad seems to be crash almost constantly and throws up Guru messages at some point. I removed the Furia and fired it back up, ran IK+ and it played fine without it. So the Furia is the culprit and not running stable.

What i've read so far is that;
1. Furiatune needs to be tinkered with and added to the startup/setpatch (not sure which one). No idea how to do this or access this boot file. I've tried turning cache and fpu on and off with WHDLoad but sometimes it makes matters worse.
2. I have to patch to a later scsi.device (43.45??), i think mine is currently 40.5. I tried loadmodule scsi.device but nothing updated, i did have a folder with two files one being scsi.device4345 and the other a lower number. I did this on WinUAE with a diretory added from my PC to show the files. To do this patch does it have to be patched from command line or can the file be copied via Dopus or someother means and just replace the existing scsi.device file?
3. I have to update the hard drive file system or at least the big partitions to PFS3, currently my boot partition is around 280MB and two other partitions just under 3GB. Remaining space is unallocated.
4. Workbench 3.1> - I need to installl a later version of Workbench because some of the more updated drivers will help the Furia become more stable.
Currently i've got 3.1 installed and i managed to get WHDLoad working for a few mins on a few games last night then eventually crashed. Some games just refuse to boot. IK+ i got an error message saying "The data/disk files are damaged or it is an unsupported version". Removed Furia and it plays fine.
I've installed WB3.1, 3.1.4 and 3.9 and they all don't work. 3.1.4 refused to boot at one point but then i think that might be rom related. 3.9 which take a long time to boot and would hang just on the main screen,
5. Shadowrom/Maprom??? What does it do, does it allow you to map a rom file from the hard drive and use new features?

Sorry its bit of a rant but i'm pretty sure others have gone through this and been able to work it out and get better results. Like i said i don't have any experience working in Workbench or how some functions work. I'm starting to think i should've just bought a fast ram expansion.
I could use a Dummies guide to Workbench that explains what each folder does, like C: contains executables, Librarys contains........... library stuff!

For you guys out there that have a Furia could you let me know what your setups are for best stability please. The amount of threads i've read i think there should be some sort of tutorial.

lilwshu 24 July 2021 14:30

Have you set the Maxtransfer rate on your SD card to the appropriate setting in HDToolbox? Accelerated Amigas seem to be a bit more sensitive to this than stock 68K ones, and you will see the sort of issues you are seeing if it is left at the default value.

cjwhiting1982 24 July 2021 15:45

Yes I set the rate to 1x1fe00 i think, hit enter to save. I also saw someone mention that the default buffer at 30 should be higher. I've set mine to 100. A post I read previously somewhere said this should be higher for large drives.
Am I right in thinking DH0/boot drive doesnt need to be formatted to pfs3 since my partition is 280mb in size? Other partitions are pfs3.

wazza 24 July 2021 16:05

3.1.4 and 3.2 won't work with older versions of the Furia firmware, so it does depend on how old your card is. I have a white furia card from about 4 years ago and can never get 3.1.4 to work on mine, it just hangs half way through booting. 3.1 however is fine.

The Shadowrom thing will copy the kickstart rom into fast memory which gives you a nice system speed up (along with the IDE speed up option). It's worth persevering with the "quirks" of the Furia as once you get it going, it really is a speedy little card and there isn't much to tell it apart from an 030 because the IDE access is so fast.

The correct max transfer value is 0X1FE00 which is slightly different to what you've posted above.

cjwhiting1982 24 July 2021 16:58

I purcahsed the Furia from RetroLemon in UK. On website it says ver 13.1, its the red version. I only ordered it just over a week ago so it must have the most up to date firmware.

I've just booted it up and confirm the maxtransfer is set to 0x1fe00 so thats OK. Currently about to make up another SD with 3.1.4 and add on BestWB to see if that makes a difference. If one SD card build is rubbish i've already got another one ready to try something else.

How do i set up shadowrom? Do i just enable it from shell with furiatune or is there a file i have to edit to enable it on every boot?

Superman 24 July 2021 20:42

1 Attachment(s)
You will need to put furiatune into C and edit the startup sequence to make permanent changes. From my screenshot I have Shadowmem activated and the addmem command to unlock the extra 1.5mb.

cjwhiting1982 25 July 2021 01:02

Thanks, I've had furiatune in c for a few days now. Reinstalled WB3.1 and BetterWB. I used redit to open and change startup-sequence for maprom. It didn't work, returned with a "failed returncode 20" error message.
I managed to open it up and delete the script I entered to let it boot as normal. The script was from another post from here, a few years old but both didn't work.
I'll try your simple one line tomorrow see if that has any affect.
I did manage to boot chuck rock and play it for a few minute before turning it off. I'll also try more games instead of the same couple.
The most common error messages I'm getting is: Exception "address error", "illegal instruction" and "line 1111 emulator ".
I did a fresh install on boot drive too with pfs3aio and fresh whdload install.

cjwhiting1982 25 July 2021 20:57

Superman I just tried that line from your s-s. Just crashed thr amiga. Hdd light flashes to indicate its loading then just goes solid, floppy drive clicking stops too.
What is that symbol that you have after "NIL>"? I dont have that in my s-s, is that just classicwb specific?
I'll have to winuae edit the line out to get it going again. I was even just sat idle on redit for about 5mins before I started to edit the s-s and I got a crash.
I forgot to mention that I haven't been able to boot floppy games either since I've installed this furia.

Superman 25 July 2021 22:12

You can ignore that symbol at the end its just something that the editing software adds to the end of each line. It seems you are having some strange issues. The only time mine was unstable was when it wasnt attached properly on the CPU. I had to push down really hard to make it seat properly and now its rock solid.

I am running kickstart 3.1 with classicwb3.1 and my furia is a version 2 white board. I have heard that my version wont work with ks3.1.4 or above without a firmware update but I'm not sure about the newer red boards.

cjwhiting1982 25 July 2021 23:43

Mine is a rev 3 board. Now about seating it properly. Do you have those stand off supports under the furia to keep it level or have you just got it locked in place with just the CPU?
I don't have the supports installed cos I think mine was yellow screening when I had them in.
I've taken it off maybe about 3 times since installing it and think maybe the solder joints on the cpu might have small cracks, maybe add a bit more solder/reflow the CPU.
Just trying to rules things out. I've read that there is a programme called MBRTest-2 that can be used to test ram, couldn't find a download link to it.

It's been a proper shit experience so far with this furia but I'm not gonna let it stop me from getting the damn thing working. Pisses me off when I see these youtube videos and some guy just pops it in and it works first time lol

Superman 26 July 2021 00:21

I don’t have any fixings at all on mine. It’s just pushed down over the cpu. If you want to test the memory I recommend downloading Amiga test kit from here https://github.com/keirf/Amiga-Stuff/releases

It can test lots of stuff including the memory.

cjwhiting1982 26 July 2021 09:18

Ah I think I downloaded that last night from github but haven't copied it over yet.

I'm beginning to think it's the connection to the cpu that is the issue. I bought a 600 a couple of years ago and managed to get a vampire for it. When I installed the cpu the same way there was a definate "snap" when I got it on. I haven't heard a snap when installing the furia so maybe not all the pins are making a good connection which is causing the instability.

cjwhiting1982 26 July 2021 12:26

I've just stripped it apart, removed mobo and checked the cpu legs with a microscope on my phone. I can see Mark's on each leg where the furia has made contact with it so looks like its connected fine.
I've put some flux and hot air over cpu legs to give it a reflow. Booted it up without furia and with sd card in and it booted to kickstart screen fine. Add the sd card add it doesnt display anything. I've just deleted and reinstalled WB3.1 on my sd so just about to try that see how it goes before I add the furia back into the mix.

Superman 26 July 2021 14:01

What version of kickstart are you running? It just occured to me that on the original kickstart 2 (37.300) I had all sorts of errors running my SD card until I upgraded to kickstart 3.1.

It is also possible that your furia could indeed be faulty in which case you would have to communicate with the seller.

cjwhiting1982 26 July 2021 14:52

KS 3.1 (40.063), i've put Amiga Test Kit on and its running the RAM test. It's doing random fill atm and is on round 22.3.

Does this test stop or does it run until failure? It's probably been running for just under an hour so i'll just let it chug along and do its thing.

Tested WHDLoad without furia on after my "reflow", had a 20 min sesh on IK+ and got my highest ever score lol. Popped Furia back in and nope :banghead, won't run IK+.

Superman 26 July 2021 14:57

The memory test runs forever as far as I know until you stop it. If its reached round 22 without errors then the memory will be fine.

cjwhiting1982 26 July 2021 15:08

Cool, i'll sack this test off since its been nearly an hour and its still going. Ran CIA chip test that all passed. Don't think there is anything left to test.
Only thing i can think of is maybe i need to run a later version of Workbench, i tried to bring up sysinfo but had to extract it from an lha file and it just crashed after i extracted it.
Some people have found they run better on later versions so will try that. I couldn't get 3.1.4 to run with for some reason its just wouldn't boot.
I might try 3.9 again see how that goes.

vatastala 26 July 2021 17:10

I highly recommend you to use HstWB, it solved all the problems for me, consider that I have a Furia v12 from late 2019, so not the latest firmware, and it works perfectly


Last page there's a link for a video, follow It and you'll be happy!!! :-)

cjwhiting1982 26 July 2021 18:16

Thanks dude, i tried to install that on Saturday but couldn't get it to work. My anti-virus kept deleting the 16gb sd zip file. Managed to get it in the end but couldn't figure out how to install it properly. I'll watch video this time cos this Furia is doing my bollocks in!


nikosidis 26 July 2021 20:18

Is your A600 ok without Furia?

My furia been working like a dream since I bought it.
I know there are some problems with Compact Flash cards.
It is important to get the right type.

My A600 got 3.1 rom, standard workbench 3.1.

What I did as I do to all my Amigas is to install pfs3.
I have not tried standard FFS from workbench 3.1

All times are GMT +2. The time now is 06:01.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.05095 seconds with 11 queries